Archived

This topic is now archived and is closed to further replies.

Kazhang

Low FPS In Tekkit.

29 posts in this topic

So I normally get 60FPS, I tend to get 30 while playing Tekkit (which is fine) but now, after about 5 minutes of being logged in (my server too)

It drops me to about 10-15 FPS, anyway to fix it? Tekkit has 6b of ram on it, even with 2gb,...no difference. Graphics are all low/etc. My computer can easily run 60FPS... It's not JUST Tekkit, but ANY program in the technic launcher (and any other launcher, like magic launcher)

64 bit operating system w/ 64 bit java... any way to improve my FPS?

All minecraft launchers tend to put me down FPS, even technic launcher on vanilla, yet regular minecraft keeps me at 60.

Share this post


Link to post
Share on other sites

does your server have any plugins installed? theres a bug with servers without plugins, that causes them to eat up processing power.

Share this post


Link to post
Share on other sites

does your server have any plugins installed? theres a bug with servers without plugins, that causes them to eat up processing power.

No i haven't added any in... should I? If so, what ones?

Share this post


Link to post
Share on other sites

Doesn't matter. I like Choptree2. It's just the not having any plugins that causes the leak. McMMO is a good choice too, if you like that kind of thing.

Share this post


Link to post
Share on other sites

Doesn't matter. I like Choptree2. It's just the not having any plugins that causes the leak. McMMO is a good choice too, if you like that kind of thing.

Didn't fix it...

That, and my EE Transmutation table is bugged? There are no items there, but when I click I can get an item, they're all invisable.

Share this post


Link to post
Share on other sites

Do you have a single core computer? the version of Optifine that comes standard may not be the right one for you.

Share this post


Link to post
Share on other sites

Do you have a single core computer? the version of Optifine that comes standard may not be the right one for you.

INTELĀ® Core i7-2630QM CPU @ 2.00GHz.

Thats my proccesor.

Share this post


Link to post
Share on other sites

Hrmph. How much ram do you have allocated?

To tekkit? I just upped it to 6gb... my comp has 8. But at 2, and 6... same issue.

Share this post


Link to post
Share on other sites

Is that serverside or clientside? i was asking about clientside, it's unlikely that the server is what's slow.

Try allocating 1 gig to the client, maybe even less. (java is a strange beast.)

Share this post


Link to post
Share on other sites

Is that serverside or clientside? i was asking about clientside, it's unlikely that the server is what's slow.

Try allocating 1 gig to the client, maybe even less. (java is a strange beast.)

It has 1gb. Just went down to 512.

Share this post


Link to post
Share on other sites

If less doesn't help, try it up to 2 gigs.

Ok, so down to 512, up to 2gb, up to...basically all. No change at all.

I thought it might of been machines (though I just had basics, no...automated anything yet, just the regular electric furnaces/2 generators/macerator/extractor.. .but now im out of my house building something else, still down to 15..

Share this post


Link to post
Share on other sites

Does this tuff happen on new worlds, or just the one you've got now? Also, what about other servers?

Share this post


Link to post
Share on other sites

Does this tuff happen on new worlds, or just the one you've got now? Also, what about other servers?

It's any server, any world.

Pretty much I've tested some things.

60FPS in Vanilla Minecraft download from the minecraft site.

15 FPS in ANY world/server using the Technic Launcher (even vanilla/hack/mine)

Downloaded magic launcher which is supposed to increase FPS, 15 FPS playing Vanilla on Magic Launcher... Seems to be launchers to me, but not sure.

Share this post


Link to post
Share on other sites

It's possible that you're launchers aren't closing out properly... Try reinstalling your java and any dependencies. Besides that. i've got no clue.

Share this post


Link to post
Share on other sites

It's possible that you're launchers aren't closing out properly... Try reinstalling your java and any dependencies. Besides that. i've got no clue.

Done that many times too :( i've even freshly restored my computer to manufacturer, installed java fresh (7 ofc) and then tested...still happened after like 3 days.

I found out yogbox lagging me is the mod Milleinare.

Share this post


Link to post
Share on other sites

I've been having this exact set of symptoms (including the magic launcher issue). I just figured out what was causing it, and boy do I feel stupid!

I have a Dell XPS 15z laptop. It has two GPUs: a shitty Intel chipset for low power video applications and a GeForce GT 525M for 3D performance applications. It's supposed to automagically switch between the two depending on the application. Something about the technic and magic launchers breaks this automagic. It looks like Nvidia had to carve out a special exception in the driver for Minecraft, since it runs within a java host machine. I suspect that the core issue is that the Mojang launcher runs minecraft.jar by way of javaw.exe (no console environment), while the technic launcher and magic launcher run it via java.exe.

To get technic/tekkit/yogsbox/magic launcher running on the right GPU, open the Nvidia Control Panel. Go to the "Manage 3D settings" section. Pop over to the "Program Settings" tab. Click the "Add" button. Browse to java.exe. The location will vary depending on your OS and java version. On my 64-bit system with Java 7 it is:

C:\Program Files\Java\jre7\bin\java.exe

Where it says, "Select the preferred graphics processor for this program", select "High-performance NVIDIA processor" instead of the default "Use global setting (Auto-select: [...])" option.

Bear in mind, this will cause all java applications that run with java.exe to use the NVIDIA GPU, not just Minecraft. For most people, this probably isn't an issue, but if you run a lot of 2D java apps on such a laptop for whatever reason, this will negatively impact your battery time. I don't know of any way to target Minecraft specifically. It might be possible with a registry hack, but I haven't been able to locate where the driver stores its per-application settings.

I don't know how you'd do this on an ATI/AMD system, but I think it's almost certain that you can.

With vsync off, I'm back to getting 90+ FPS everywhere, as I do in Vanilla minecraft with optifine.

Share this post


Link to post
Share on other sites

I have been having a similar problem recently, In vanilla Minecraft, with no optifine, and with a 128 bit texture pack, I get 100+ FPS. But when I play Tekkit, I fluctuate between 30 FPS and, more often than the former, 2-4 FPS, and that's with 4gb of RAM (My Mac has 6gb of RAM).

Share this post


Link to post
Share on other sites

try setting view distance to normal+64 or something like that. Servers usually don't let you load chunks further than that anyway. also, 2GB ram should be more than enough for SMP play.

Share this post


Link to post
Share on other sites

I set the render distance to short, and the... uhh... something setting to max FPS, on top of that I set most of my graphics settings to the lowest setting, AND I have a very powerful Mac. I know I would get perfect FPS if I removed my 128x Sphax, but tekkit looks so much better with it. If it helps, my Mac is 32 bit, and my Java version is 6. I am now getting a constant 1-3 FPS, and it does not ever improve, I just find it illogical that any modpack, no matter how many memory leaks it might have, can drop someone from 100+ FPS to 1-3 FPS.

Edit: I am using an extremely good graphics card as well, so I know it's not that. Also, I disabled MAtmos, and at first it made a monster of a difference, but after a while I went back to the same 1-3 FPS

Share this post


Link to post
Share on other sites

I have been having a similar problem recently, In vanilla Minecraft, with no optifine, and with a 128 bit texture pack, I get 100+ FPS. But when I play Tekkit, I fluctuate between 30 FPS and, more often than the former, 2-4 FPS, and that's with 4gb of RAM (My Mac has 6gb of RAM).

I have fps problems with the way that IC2 sounds are played. I just found the IC2.cfg file and changed true to false in this line:

soundsEnabled=true

I get 70 fps with sounds turned off, but with them on, it can go down to 0-2 fps.

I fixed this problem once before by updating lwjgl, but Technic Launcher tends to obliterate what you have. I don't even know if my current version of lwjgl is the latest, but I honestly don't miss the IC2 sounds.

Share this post


Link to post
Share on other sites

I have a Dell XPS 15z laptop. It has two GPUs: a shitty Intel chipset for low power video applications and a GeForce GT 525M for 3D performance applications. It's supposed to automagically switch between the two depending on the application. Something about the technic and magic launchers breaks this automagic. It looks like Nvidia had to carve out a special exception in the driver for Minecraft, since it runs within a java host machine. I suspect that the core issue is that the Mojang launcher runs minecraft.jar by way of javaw.exe (no console environment), while the technic launcher and magic launcher run it via java.exe.

To get technic/tekkit/yogsbox/magic launcher running on the right GPU...

Stathol, you're a prince.

This fixed my framerate issues - Dell XPS 17 (L702x) with switchable Intel / nVidia graphics.

Share this post


Link to post
Share on other sites

I've been having this exact set of symptoms (including the magic launcher issue). I just figured out what was causing it, and boy do I feel stupid!

I have a Dell XPS 15z laptop. It has two GPUs: a shitty Intel chipset for low power video applications and a GeForce GT 525M for 3D performance applications. It's supposed to automagically switch between the two depending on the application. Something about the technic and magic launchers breaks this automagic. It looks like Nvidia had to carve out a special exception in the driver for Minecraft, since it runs within a java host machine. I suspect that the core issue is that the Mojang launcher runs minecraft.jar by way of javaw.exe (no console environment), while the technic launcher and magic launcher run it via java.exe.

To get technic/tekkit/yogsbox/magic launcher running on the right GPU, open the Nvidia Control Panel. Go to the "Manage 3D settings" section. Pop over to the "Program Settings" tab. Click the "Add" button. Browse to java.exe. The location will vary depending on your OS and java version. On my 64-bit system with Java 7 it is:

C:\Program Files\Java\jre7\bin\java.exe

Where it says, "Select the preferred graphics processor for this program", select "High-performance NVIDIA processor" instead of the default "Use global setting (Auto-select: [...])" option.

Bear in mind, this will cause all java applications that run with java.exe to use the NVIDIA GPU, not just Minecraft. For most people, this probably isn't an issue, but if you run a lot of 2D java apps on such a laptop for whatever reason, this will negatively impact your battery time. I don't know of any way to target Minecraft specifically. It might be possible with a registry hack, but I haven't been able to locate where the driver stores its per-application settings.

I don't know how you'd do this on an ATI/AMD system, but I think it's almost certain that you can.

With vsync off, I'm back to getting 90+ FPS everywhere, as I do in Vanilla minecraft with optifine.

It doesn't give me the option to change it

Share this post


Link to post
Share on other sites