Archived

This topic is now archived and is closed to further replies.

Modernization

Need help with Server Side mods

Recommended Posts

I am currently trying to make my own modpack. I did this successfully (you can download it now and stuff), but when I tried to make a server all the tutorials uselessly said "remove server side mods, things like dmg indicators and minimaps". That's great, but I don't know which of my mods are server side mods. Instead of testing every mod one by one, can someone please tell me out all these mods which ones I put in the "Mods" folder in my custom modpacks server folder?

https://dl.dropboxusercontent.com/u/429117797/sdssd.PNG

Sorry idk if this is the right place to put this

Share this post


Link to post
Share on other sites

Haven't downloaded modpack yet, but a couple things jump out:

1) Mapwriter is client-side only, and you have the wrong version, your pack is 1.7.10, that one is for 1.8.9

2) Flans content packs don't go in /mods. They go in a Flans folder at the root. 

 

Share this post


Link to post
Share on other sites
  • Almost all mods that are client only clearly state that information in the posts/threads/curseforge pages/etc.

Here are a few points that typically indicate a client only mod:

  • If the mod only displays information in a HUD (Heads Up Display/On Screen Display) such as armor durability, debuffs, target info, minimaps, etc. then it is likely a client only mod.
  • If the mod only changes the way the world is displayed, but not the data that is sent to the server or seen by other players, such as mob dismemberment, shaders, etc., then it is likely a client only mod.
  • If the mod only changes the way the graphics are rendered on your client, such as Dynamic Lights, colored lighting, optimizations like OptiFine or FPS Tweaks, etc., then it is likely a client only mod.
  • If you are getting errors in your server log where a mod is being injected that talk about "world" or "client" or "GUI/display", then it is likely a client only mod.

Share this post


Link to post
Share on other sites

Ok I need help with 2 things.

1. can someone tell me how to set up flans? I don't know what you mean by folder and that stuff....

2. can someone send me a list of the server side mods please out of the ones I sent the screen shot of? Not HOW to find out which ones are server side. I need a list of mods from my list that are server side (not how find out if they are server side)

Share this post


Link to post
Share on other sites

So, you would like us to give you fish instead of teaching you how to fish? If you can't be bothered to perform the most straight forward of actions in order to get your own pack working I'm not sure we can help you.

Flan's Mod is set up in this manner:

  • The Flan's Mod JAR file goes in /mods/ in your modpack archive.
  • The Flan's weapon packs go in /Flan/ in your modpack archive.

Edit:

From the looks of that image you provided, you have some work to do before attempting to make a server. There are outdated mods, mods with odd (not-from-authors) names, etc. The first step in making a server is fully debugging the client modpack. Always provide the client pack API URL or a link to the pack's platform page when requesting custom modpack assistance (even if it's for a server on that pack).

Share this post


Link to post
Share on other sites
1 hour ago, Modernization said:

.... theres no folder called flans.

Correct. Just like you have to make the "bin", "config", and "mods" folders, if you intend to use Flan's you also have to make a "Flan" folder in the same location. It is that folder into which you place your weapons packs.

Share this post


Link to post
Share on other sites

Client:

  • The file "/mods/_CodeChickenLib-1.7.10-1.1.1.93-universal.jar" should be removed.
  • Why do you have the CoFH config folder (cofh) inside the /mods/ folder. This belongs in the /config/ folder.
  • BetterBuildersWands looks like a Forge/MC 1.8.9 mod. You need the 1.7.10 version.
  • Your Camping mod is not from a legitimate source. As is common when you don't get it directly from the author's preferred distribution channels, you have an ancient version of this mod.
  • You have the Camping mod, but not the required dependency mod RikMuldsCore
  • Your BuildCraft mod is out of date.
  • You should be using the "Latest" versions of ChickenBones mods, not the "recommended" versions.
  • Your Flan's mod is out of date and not compatible with the weapon pack versions you have.
  • Your Hats mod is not from a legitimate source.
  • Your iChunUtil mod is not from a legitimate source.
  • Your Modular Powersuits mod is not from a legitimate source.
  • You have MapWriter for Forge/MC 1.8.9. You need the 1.7.10 version.
  • Your IvToolkit mod is not from a legitimate source.
  • Your Not Enough Items mod is not from a legitimate source.
  • Your Numina mod is not from a legitimate source.

You have a lot of work to do before you are ready to consider building a server.

Share this post


Link to post
Share on other sites

While I'm doing all that- Do you know about when you load up the modpack / game it shows u the forge loading screen with the hammer in the corner and the 2 bars in the middle that show the progress? Do you know how to change this? I think its related to mojang.png or something

Share this post


Link to post
Share on other sites

Ok I think I fixed all those things but in the process I added a couple things- can you double check and see if I installed this new stuff correctly

Here's all my files

main.PNG

sds.PNG

config.PNG

dsd.PNG

dsdsdsd.PNG

This is the whole modpack folder broken down- ignore the zipped modpack.jar

Share this post


Link to post
Share on other sites

You have multiple mods from illegitimate sources. Any mod named in the format of "ModName-Mod-1.7.10.jar" or "Mod-Name-1.7.10.jar" is almost surely from a sketchy content stealing site.

Share this post


Link to post
Share on other sites

Ok ill double check all of those, but after that am I able to start making a server?

Also... Whenever anyone in my modpack places a flans vehicle, the game crashes. How do I fix this?

Share this post


Link to post
Share on other sites
18 hours ago, Modernization said:

Also... Whenever anyone in my modpack places a flans vehicle, the game crashes. How do I fix this?

Then no, you are not ready to start making a server. You will need to provide client crash reports in a pastebin in order to narrow down what's going on.

Share this post


Link to post
Share on other sites

Ok now I have this error- I'm trying to install the galaxy space add on that give syou tier 4-9 rockets for galacticraft but it gives me this error

https://dl.dropboxusercontent.com/u/429117797/crash-2016-03-25_16.44.44-client.txt

this is where I got the add-on

http://www.minecraftforum.net/forums/mapping-and-modding/minecraft-mods/2412548-1-7-10-galaxy-space-addon-for-galacticraft-3

Share this post


Link to post
Share on other sites
1 hour ago, Modernization said:

Ok now I have this error- I'm trying to install the galaxy space add on that give syou tier 4-9 rockets for galacticraft but it gives me this error

https://dl.dropboxusercontent.com/u/429117797/crash-2016-03-25_16.44.44-client.txt

this is where I got the add-on

http://www.minecraftforum.net/forums/mapping-and-modding/minecraft-mods/2412548-1-7-10-galaxy-space-addon-for-galacticraft-3

" Minimum build GalactiCraft3: 1.7-3.0.12.446"

"GalacticraftCore{3.0.12} [Galacticraft Core] (GalacticraftCore-1.7-3.0.12.375.jar)"

Share this post


Link to post
Share on other sites

  • Similar Content

    • By merp59
      I'm using the "Forge 1.12.2 Official" modpack and I'm trying to add some mods and every time I load it up it says something along the lines of "Please remove [insert some mod here] or update forge to 14.23.5.2770 and I have NO CLUE how to do that. I've looked up videos and articles and the sorts and haven't found ANYTHING for technic. PLEASE help. It has been hours. I need this step by step because I have no idea how to do almost anything besides add mods.
    • By dfrosty32
      Can someone explain how to add essentials or something like it to a 1.7.10 server pack?  Would be greatly appreciated.
    • By ObliviousStranger
      I recently downloaded the launcher and afterwards Pixelmon Generations modpack, and when i click the play button it closes and reopens the launcher after it finishes downloading the "Minecraft assets" and i tried updating my graphics card, reinstalling the modpack, and even reinstalling the launcher to no avail. I could really use some guidance please.
      Here's the log:
      https://pastebin.com/T74r2BkS
    • By ShadowOfSnow
      So I'm trying to update the forge version on a modpack from 14.23.4.2708 to 14.23.4.2739 to handle a version of CoFH Core. I did manage to download the appropriate version of Forge for the modpack and mod, but when I put it in the /bin/ folder it does not register. Should I restart my entire launcher or remove the other versions besides the Forge file in the bin folder?