Raghar

Can't setup plugins for Tekkit Lite Server

4 posts in this topic

Hello there,

firstly, before you burn me like a witch I will say this:

I've been trying to install it for last 3 hours, I've tried the method listed here. I've tried sponge/mcpc/bukkitforge. I've tried whole loads of things I do not understand. I've read pinned topics for it here and there, honestly I am just tired and about to give up.

So now that's our of the way.

Yesterday I've decided to setup server (for me and some friends, nothing big) of Tekkit Lite. Surprisingly I've managed that!
After a short while we realised that we need some commands available to everyone, but we do not want everyone to be op. That would be too dangerous.
Basically we figured that we want everyone to have teleport commands plus maybe like /home /spawn, some real real basics.
In my search for granting ability of using commands I have found that what I need are plugins (am I wrong here? Is there simpler way)

And so now I am completely stuck trying to install those plugins. I propably just need someone to point out my mistake, or just send me correct way.

So, this is what I have been doing to install plugins:

1. Extract tekkit lite server zip
2. Run server for the first time.
3. Stop server after it is completely done loading and creating.
4. Copy and paste bukkitforge1.4.7.jar to coremods folder.
5. Create plugins folger
6. Try running server>
7. This shit appears =[  <Here is a pastebin of serverlog of when I tried to run with bukkitforge>

And basically I've tried that with many other forms of forge like mcpc or sponge.
I also tried the other way around (extract server, add bukkitforge, then run for the first time - didn't work either, had similar texts in log appear)


Thx in advance for help, I would really love to play some tekkit lite with my friendos =]

Cheers, Raghar

P.S.: Sorry for my English, I am not a native speaker
P.S.2: I would gladly accept files of working server with plugins (in case helping me install those won't work)

Share this post


Link to post
Share on other sites

Here's my steps to getting a Tekkit Lite server with plugins.

Download a fresh copy of the server from the modpack page: http://www.technicpack.net/modpack/tekkitlite
Download mcpc-plus-1.4.7-R1.1-SNAPSHOT-f534-authfix1.jar from tcpr.ca: https://tcpr.ca/downloads/mcpc

Put the file in the same folder as the server download, edit the launch.bat file to use the mcpc-plus jar.

Should it say you need to run it with Java 7 you can get that from here assuming you have 64-bit windows: http://cdn.lemonmc.com/jre-7u80-windows-x64.exe

 

If you get an error similar to

Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.fusesource.jansi.internal.Kernel32

edit the launch.bat file again and add --nojline after the mcpc-plus jar filename.

Share this post


Link to post
Share on other sites

Thx for answer!

Sadly the problems ain't over.

I followed your steps and these are the results:


I did get the error:

1 hour ago, zaza7 said:

If you get an error similar to

Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.fusesource.jansi.internal.Kernel32

edit the launch.bat file again and add --nojline after the mcpc-plus jar filename.

and after I using the fix this is what I end up with this:  As far as I, a total noob, understand the mcpc caused a problem with loading buildcraft?

Thanks for helping me!

Cheers,
Raghar

 

EDIT1: Do you want me to run launch.bat and mcpc.jar with server files in zip form? Or with unpacked form, cause I have been running it with the unpacked files.

EDIT2: Maybe it will help, I've zipped and uploaded for screening the server files that show the problem with builcraft. Zipped broken server

 

Edited by Raghar
Didn't want to make 2 replies in a row

Share this post


Link to post
Share on other sites

Ok, nvm.

Your way does make the server work with the plugins. Thx a lot <3
You just gotta ignore the fact that GUI doesn't pop out and that buildcraft fails to check version.

Cheers,
Raghar

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Servant_Girl
      I basically got tired of mining silver, thinking it was tin, and tired of having to mine a block to see if it was tungsten or coal. SO I decided to take matters into my own hands and make a texture pack that very simply changes the ores to me more distinct from each-other, it also makes caves, quarries and ravines a lot more vibrant!
      This 'pack' was make exclusively to compensate for my inability to distinguish ores and its been working out great for me! So even if literally no one else uses this pack, I personally love it and it is for filling is purpose very effectively. So if you have the same problem feel free to download.
      From left to right we have:
      Copper-Tin-Silver-Lead-Ferrous

      Now embedded in stone:

      Uranium and Tungsten:


       
       
      Servant's Ores.zip
      Strikes me as silly and to be honest its a little bit frustrating that they would let up upload but let no one download...
      Here's an alternative link. https://s3.amazonaws.com/files.enjin.com/884882/modules/forum/attachments/Servant's+Ores_1505686228.zip
      I do not wish to use Planet Minecraft because I don't want to look like I'm jst adversizing and also because I can't stand the way that site makes you log in again every like three clicks
    • By StarStrike103
      Ok, I have a forge modpack 1.7.10. I've set up a server with mods and forge and everything and it works fine.
      But the issue is, is I want plugins in my server.
       
      Any help?
      Also, my plugins will only use forge - nothing else.
    • By Lynisfast
      This is my modpack: https://www.technicpack.net/modpack/breath-of-the-wild.1087741. Here is the source .zip When I launch it, it launches vanilla Minecraft. I am new to making modpacks, and have no idea what to do, as I followed the guide as closely as possible. Help, please!
    • By UltraMakroTaste
      PS: Sorry for my bad English i'm from German :'DDD
      Dear Tekkit-Legends Community
      I realy like Tekkit Legends ,but thats boring and not helpfull without plugins ...
      And than i wanted to install plugins on my Tekkit-Legends Server. I read that thread: ,but it don't works  
      i've tried everything. I always get this nice error: 
      [06:41:56 INFO]: The state engine was in incorrect state CONSTRUCTING and forced into state SERVER_STOPPED. Errors may have been discarded.
      i hope anyone can help me ...