• 0
SimplyAwkward09

Tekkit Classic crashes with Java 64

Question

I am only able to run Tekkit Classic (indeed any mod pack that I've tried) with Java 32. Upon trying various versions of Java 64, I get the error message "Java(TM) Platform SE binary has stopped working." Been unable to find a solution to this problem so far. I've attached the most recent log from the Technic Launcher.

Running on Windows 7

64 bit OS

8GB RAM

techniclauncher_2017-03-16.log

Share this post


Link to post
Share on other sites

1 answer to this question

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Spixium
      Can anyone help me figure out why I'm suddenly unable to run any minecraft modpacks?
      I set up a tekkit server which worked fine but then I realised tekkit is missing some of my favourite mods so I decided to make a big dig server instead. Except I couldn't get that to work and I tried all kinds of things to fix it. I eventually gave up and tried to play single player big dig only to find that wouldn't work either. And now tekkit and nuts and bolts and every other technic mod pack won't run even though they ran just fine yesterday! When I click play it has a loading bar but when the loading bar fills up minecraft doesn't open and the technic launcher window flashes.
      I've tried to delete everything I downloaded over the past couple of days. I've uninstalled and reinstalled 64 bit java. I've checked and my PC has 16GB of RAM, most of which isn't being used. I've checked the technic launcher settings and I've allocated it 4GB of RAM  and checked that it is indeed using the 64 bit java. I've uninstalled and reinstalled minecraft. I've turned my PC off and on again lol. I'm stuck
       
      https://pastebin.com/eAJQNFh8
    • By avtumnb
      Hi
      I used to use technic launcher all the time but i stopped for a while and i came back on a few months ago to use it and it wasn't loading the modpacks. I would download it and click play and the page would disappear for about 10 seconds then come back up and wouldn't start the modpack. I've updated java to the latest version and 64-bit. I've looked this up a lot but god damn i cannot find a solution. Please help! I will include the log below.
       
      techniclauncher_2017-06-16.log
    • By Vintagent
      ACTIVE AS OF APRIL 19, 2017
      Ladies and Gentlemen! Boys and Gir-- HA! There are no girls on this forum, although if you are a girl, you are still welcome to join my server. Okay, jokes are over, let's get down to business. My name is James (Vintagent) and last year I started a fresh single player world on the modpack TekkitClassic. After about a month or so I started to get bored, so there sat my single player world, cold, alone, tired, hungry, until one day I decided that I was sick of playing games alone. Lo and behold, VintaCraft was born! VintaCraft is a TekkitClassic server that is all about building a friendly community to help each other out. Whether it is huge builds, crazy machines, funny pranks, or just chillin out, VintaCraft is the place to be. No need for competitive playing, raiding, or griefing in any way. We play with each other for each other.Now, here are some specifics..
       
      Vintacraft
      Tekkit Version 3.1.2 Whitelist is enabled, please email me [email protected] message me through the forums and just ask me to give you the required information that is to be filled out for an application.  Pvp is disabled, I want a friendly and fun community. Nobody like this ==>  There are absolutely no banned items, I want everyone to have the full TekkitClassic experience, but you need to be responsible and respectful. GRIEFING AND RAIDING WILL NOT BE TOLERATED, either act will result in an immediate ban from the server, with no hopes of returning. This includes scamming, "trolling", hacking, or client side mods that are going to give you a leg up, just play clean and fair, and you'll have fun. Essentials is the only plugin on the server, there are no mods or admins that contribute, just me. There are 10-15 spots open! Friendly Pranks, jokes and whatnot are always in good fun, as long as they are reasonable. Server runs roughly 24/7 Running from the East Coast of the USA Nether and the End are enabled World and Dimensional anchors are not banned or limited, but I advise not using them as they tend to cause server lag Must be 16+ years old to play (The age restriction is here for maturity purposes only, if you are under the age of 16 and wish to fill out an application, please feel free to email me anyway to prove your maturity. Just be honest about your age, it is not going to jeopardize whether or not you are accepted.  
      Please take into consideration the style of server I am trying to run. I'm always open to suggestions about adding plugins and whatnot, let me know if you are interested. Thanks,
      -James
      <--Sweet Moves
    • By HailZz
      I got a new PC with Windows 10, Downloaded Technic Launcher, Then I downloaded Tekkit Classic, Then I press play then it loads Minecraft Assets and then just goes onto the Launcher again.
      I have uninstalled Java 8 and went to Java 7 Then I went back to Java 8, I have uninstalled Technic Launcher 5 times, I have uninstalled Tekkit Classic loads of times???
      Is there any help it will be appreciated
    • By SQbuilder
      A few weeks ago, I created a Tekkit Classic server. I opened up hamachi, and connect using my ip4 address, and so did my friends. Everything was perfect until a few weeks later. This morning, when I booted up the server, my server browser said that "Can't connect to server". When I tried to connect it said: "connection timed out: connect" I reset the server, my computer, hamachi, and tekkit several times, but nothing would work. I checked the server and nothing was wrong or different. I can't think of any ideas. Help!
      C:\Users\***********\Desktop\Minecraft Servers\Tekkit Server>java -Xmx3G -Xms2G -jar Tekkit.jar nogui 182 recipes 27 achievements 07:48:56 [INFO] Starting minecraft server version 1.2.5 07:48:56 [INFO] Attempting early MinecraftForge initialization 07:48:56 [INFO] Completed early MinecraftForge initialization 07:48:56 [INFO] Forge Mod Loader version 2.2.91.173 for Minecraft 1.2.5 loading 07:48:56 [INFO] Loading mods from C:\Users\******\Desktop\Minecraft Servers\Tekkit Server\mods 07:49:02 [INFO] Directory weaponmod contained no mods 07:49:04 [INFO] Forge Mod Loader has loaded 38 mods 07:49:05 [INFO] MinecraftForge v3.3.8.152 Initialized 07:49:05 [INFO] MinecraftForge v3.3.8.152 Initialized 07:49:05 [INFO] [WeaponMod] Properties file read succesfully! 07:49:06 [WARNING] Configuration for mod_ComputerCraft.enableAPI_http found value 0 outside acceptable range 4.9E-324,1.7976931348623157E308 07:49:06 [INFO] Loading ComputerCraft: To change block IDs, modify config/mod_ComputerCraft.cfg 07:49:06 [INFO] ComputerCraft: computerBlockID 207 07:49:06 [INFO] ComputerCraft: diskDriveBlockID 208 07:49:06 [INFO] ComputerCraft: diskItemID 4000 07:49:06 [INFO] CONFLICT @ -49 item slot already occupied by [email protected] while adding [email protected] 07:49:06 [INFO] ComputerCraft: Searching for RedPowerLib... 07:49:07 [INFO] ComputerCraft: RedPowerLib and methods located. 07:49:07 [INFO] CONFLICT @ -48 item slot already occupied by [email protected] while adding [email protected] 07:49:08 [INFO] Initializing alchemy values for Equivalent Exchange.. 07:49:08 [INFO] NetherOres: loaded Macerator Recipes 07:49:08 [INFO] Loading properties 07:49:08 [INFO] Starting Minecraft server on *:25565 07:49:11 [INFO] Loaded codechicken.wirelessredstone.core.CommandFreq 07:49:11 [INFO] [IC2] Config loaded from C:\Users\Sonny Quinday\Desktop\Minecraft Servers\Tekkit Server\.\config\IC2.cfg 07:49:12 [INFO] CONFLICT @ 1237 item slot already occupied by [email protected] while adding [email protected] 07:49:12 [INFO] CONFLICT @ -41 item slot already occupied by [email protected] while adding [email protected] 07:49:12 [INFO] [ccSensors] INFO: Loading SensorModule: Buildcraft 07:49:12 [INFO] [ccSensors] INFO: Loading SensorModule: IndustrialCraft2 07:49:12 [INFO] [ccSensors] INFO: Loading SensorModule: Forestry 07:49:12 [INFO] [ccSensors] INFO: mod_Forestry not found - SensorModule is disabled. 07:49:13 [INFO] [ccSensors] INFO: Loading SensorModule: RedPower2 07:49:13 [INFO] [ccSensors] INFO: Loading SensorModule: EquivalentExchange 07:49:13 [INFO] [ccSensors] INFO: Loading SensorModule: APS 07:49:13 [INFO] [ccSensors] INFO: mod_BuildcraftAPS not found - SensorModule is disabled. 07:49:13 [INFO] [ccSensors] INFO: Loading SensorModule: APS 07:49:13 [INFO] [ccSensors] INFO: mod_ThaumCraft not found - SensorModule is disabled. 07:49:13 [INFO] CONFLICT @ -78 item slot already occupied by [email protected] while adding [email protected] 07:49:13 [INFO] CompactSolars: MinecraftForge minor version mismatch, expecting 3.2.x, may lead to unexpected behavior 07:49:13 [INFO] CONFLICT @ -204 item slot already occupied by [email protected] while adding [email protected] 07:49:15 [INFO] RedPowerCore: MinecraftForge minor version mismatch, expecting 3.1.x, may lead to unexpected behavior 07:49:15 [INFO] Starting BuildCraft 2.2.14 07:49:15 [INFO] Copyright (c) SpaceToad, 2011 07:49:15 [INFO] http://www.mod-buildcraft.com 07:49:16 [INFO] [IC2] Loading IC2 submodule: bcIntegration22x 07:49:16 [INFO] [IC2] BuildCraft integration module loaded 07:49:16 [INFO] [IC2] Loaded minor compatibility modules: none 07:49:16 [INFO] ComputerCraft: turtleBlockID 216 07:49:16 [INFO] CONFLICT @ -40 item slot already occupied by [email protected] while adding [email protected] 07:49:17 [INFO] Forge Mod Loader load complete, 38 mods loaded 07:49:17 [INFO] This server is running CraftBukkit version git-Bukkit-jenkins-CraftBukkit-173 (MC: 1.2.5) (Implementing API version 1.2.5-R4.1-MCPC-SNAPSHOT) 07:49:17 [INFO] Loading mod_RedPowerWorld vForgeMod 07:49:17 [INFO] Loading mod_IC2_ChargingBench vForgeMod 07:49:17 [INFO] Loading Balkon's WeaponMod vForgeMod 07:49:17 [INFO] Loading mod_BuildCraftBuilders vForgeMod 07:49:17 [INFO] Loading mod_IC2 vForgeMod 07:49:17 [INFO] Loading mod_ccSensors vForgeMod 07:49:17 [INFO] Loading mod_WirelessRedstoneRedPower vForgeMod 07:49:17 [INFO] Loading mod_BuildCraftCore vForgeMod 07:49:17 [INFO] Loading mod_IC2AdvancedMachines vForgeMod 07:49:17 [INFO] Loading mod_ComputerCraft vForgeMod 07:49:17 [INFO] Loading mod_EnderStorage vForgeMod 07:49:17 [INFO] Loading mod_ModularForceFieldSystem vForgeMod 07:49:17 [INFO] Loading mod_RedPowerMachine vForgeMod 07:49:17 [INFO] Loading mod_CCTurtle vForgeMod 07:49:17 [INFO] Loading mod_CodeChickenCore vForgeMod 07:49:17 [INFO] Loading mod_CompactSolars vForgeMod 07:49:17 [INFO] Loading mod_ImmibisCore vForgeMod 07:49:17 [INFO] Loading mod_WirelessRedstoneCore vForgeMod 07:49:17 [INFO] Loading mod_WirelessRedstoneAddons vForgeMod 07:49:17 [INFO] Loading mod_IC2NuclearControl vForgeMod 07:49:18 [INFO] Loading mod_IronChest vForgeMod 07:49:18 [INFO] Loading mod_BuildCraftTransport vForgeMod 07:49:18 [INFO] Loading mod_RedPowerWiring vForgeMod 07:49:18 [INFO] Loading mod_MinecraftForge vForgeMod 07:49:18 [INFO] Loading mod_RedPowerControl vForgeMod 07:49:18 [INFO] Loading mod_RedPowerLogic vForgeMod 07:49:18 [INFO] Loading mod_RedPowerLighting vForgeMod 07:49:18 [INFO] Loading mod_RedPowerCore vForgeMod 07:49:18 [INFO] Loading mod_PowerConverters vForgeMod 07:49:18 [INFO] Loading mod_BuildCraftEnergy vForgeMod 07:49:18 [INFO] Loading mod_BuildCraftFactory vForgeMod 07:49:18 [INFO] Loading mod_NetherOres vForgeMod 07:49:18 [INFO] Loading mod_NotEnoughItems vForgeMod 07:49:18 [INFO] Loading mod_ImmiChunkLoaders vForgeMod 07:49:18 [INFO] Loading mod_EE vForgeMod 07:49:18 [INFO] Loading mod_Railcraft vForgeMod 07:49:18 [INFO] Loading mod_AdditionalPipes vForgeMod 07:49:18 [INFO] Loading mod_TubeStuff vForgeMod 07:49:18 [INFO] Preparing level "world" 07:49:18 [INFO] Default game type: 0 07:49:18 [SEVERE] Exception in thread "Thread-9" 07:49:18 [SEVERE] com.google.gson.JsonSyntaxException: java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 7 07:49:18 [SEVERE] at com.google.gson.internal.bind.ReflectiveTypeAdapterFactory$Adapter.read(ReflectiveTypeAdapterFactory.java:180) 07:49:18 [SEVERE] at com.google.gson.Gson.fromJson(Gson.java:755) 07:49:18 [SEVERE] at com.google.gson.Gson.fromJson(Gson.java:694) 07:49:18 [SEVERE] at org.bukkit.craftbukkit.updater.BukkitDLUpdaterService.fetchArtifact(BukkitDLUpdaterService.java:44) 07:49:18 [SEVERE] at org.bukkit.craftbukkit.updater.BukkitDLUpdaterService.getArtifact(BukkitDLUpdaterService.java:27) 07:49:18 [SEVERE] at org.bukkit.craftbukkit.updater.AutoUpdater$1.run(AutoUpdater.java:77) 07:49:18 [SEVERE] Caused by: java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 7 07:49:18 [SEVERE] at com.google.gson.stream.JsonReader.expect(JsonReader.java:339) 07:49:18 [SEVERE] at com.google.gson.stream.JsonReader.beginObject(JsonReader.java:322) 07:49:18 [SEVERE] at com.google.gson.internal.bind.ReflectiveTypeAdapterFactory$Adapter.read(ReflectiveTypeAdapterFactory.java:168) 07:49:18 [SEVERE] ... 5 more 07:49:19 [INFO] Registering world world, dimension 0, of providertype [email protected](0) with Minecraft Forge 07:49:19 [INFO] Registering world world_the_end, dimension 1, of providertype [email protected](0) with Minecraft Forge 07:49:19 [INFO] Registering world world_nether, dimension -1, of providertype [email protected](0) with Minecraft Forge 07:49:19 [INFO] Preparing start region for level 0 (Seed: 1530878175892299605) 07:49:21 [INFO] Preparing spawn area: 0% 07:49:22 [INFO] Preparing spawn area: 24% 07:49:23 [INFO] Preparing spawn area: 56% 07:49:24 [INFO] Preparing spawn area: 97% 07:49:24 [INFO] Preparing start region for level 1 (Seed: -5020703990991370870) 07:49:25 [INFO] Preparing spawn area: 40% 07:49:26 [INFO] Preparing spawn area: 52% 07:49:27 [INFO] Preparing spawn area: 93% 07:49:27 [INFO] Preparing start region for level 2 (Seed: -5020703990991370870) 07:49:28 [INFO] Preparing spawn area: 16% 07:49:29 [INFO] Preparing spawn area: 52% 07:49:30 [INFO] Preparing spawn area: 89% 07:49:30 [INFO] Server permissions file permissions.yml is empty, ignoring it 07:49:30 [INFO] Done (12.555s)! For help, type "help" or "?" 07:49:31 [INFO] [Railcraft] Loaded 0 saved Anchors