Teach me, Senpai. How do I do this hosting?

3 posts in this topic

Hello. I used to host my own Unturned server through a server hosting website. I decided to host a modpack, but I have no knowledge with it. So I asking this community to give me a hand for me to hold on and walk. I don't know which website are best and cheap to host a server for a modpack. I'm looking to spend about $30 USD maximum. Do I want to use bukkit for this? If so then how bukkit work? How do I add modpack to server files? How do I add plugins to server files? Any hints and tips? Thank you for your time to read and reply. 

Share this post

Link to post
Share on other sites

Modpacks Generally have custom Jar files, Any Public host should provide this.
Considering your budget is only $30, I Recommend bisectHosting due to working with them for a variety of years, They seem reliable.

Share this post

Link to post
Share on other sites

You can technically host it yourself for free, as long as you don't intend for too many people to be playing on it as it will eat up alot of Internet. To add more mods, simply download the mod off the internet (Curse Forge is reliable) for the appropriate version of Minecraft, navigate to the .Technic folder (Users/Your user/AppData/Roaming/.technic/modpacks/whatever modpacks you are using/mods. Then place the file into the mods folder and restart the server.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By kastleking12
      I joined a dimensional doors portal, then my game crashed.  After restarting my client, I get an error when trying to connect to my server.  
      Here is what my log says. 
      2017-04-23 21:08:11 [INFO] Done (0.853s)! For help, type "help" or "?" 2017-04-23 21:08:15 [INFO] kastleking12[/] logged in with entity id 86 at (3499.5, 9.0, -1827.5) 2017-04-23 21:08:15 [INFO] Disconnecting kastleking12 [/]: Internal server error 2017-04-23 21:08:15 [WARNING] Failed to handle packet for kastleking12 [/]: java.lang.NullPointerException java.lang.NullPointerException at at at at at at at net.minecraft.server.ServerListenThread.func_71766_a( at net.minecraft.server.dedicated.DedicatedServerListenThread.func_71747_b(SourceFile:29) at net.minecraft.server.MinecraftServer.func_71190_q( at net.minecraft.server.dedicated.DedicatedServer.func_71190_q( at net.minecraft.server.MinecraftServer.func_71217_p( at at 2017-04-23 21:09:07 [INFO] ZacSlave[/] logged in with entity id 87 at (3434.300000011921, 69.5625, -1697.300000011921)
    • By Trico
      Okay so basically everything was fine this morning but after I tried installing a resource pack made for Hexxit, which I deleted completely after this, everything went to crap. Whenever I try to join a server in multiplayer, it loads for 2 seconds, giving you a quick glance at your character being stuck half in and half out of a block then immediately goes to a black screen and crashes.

      Could it be the server itself? Could it be something corrupted on my end? I don't know. And yes, I have 2GB RAM allocated to it already, which was never a problem. And I'm running the latest Hexxit version.

      What I tried:
      Deleting (player).dat file Reinstalling TechnicLauncher Reinstalling Hexxit Updating Java Copying Saves folder, deleting .technic, and pasting Saves folder in the new one
        Here is the crash report
    • By sirherobrine
      Hello I have been running and editing my own custom modpack Crescent Moon and I could really use some help fixing some bugs in the server. As well as find bugs so If you would like to join my server and help with fixing bugs fantastic. If you just want to join and help find bugs by all means please do. Shoot me as message and feel free to join my discord if you need me. I will answer discord messages within about 12 hours and Technic with in 24 hours. Please I could really use some help I am the only one working on this and its really draining. Thanks for reading this hope to hear from someone very soon.
    • By bmack1223
      Website: | Server IP:   | Technic Pack Page: Madwell
      For more information on our servers, network, status, wiki's, launchers, pack pages, and more checkout our Discord here:
      Madwell is a modpack that has been in development for a few months. It is now in a stable release for the public to enjoy.
      If you are a fan of Warfare, you got to try this pack. You will not regret it!
      Madwell is a community of gamers and a independently hosted minecraft network. We believe in offering as many choices as possible without restricting gameplay. If your a griefer, raider, like to pvp, join a faction and conquer your enemies. All of that and more is possible on Madwell
      Worlds & Information:
      Spawn: This is our spawn world, we have rules, information,admin shops, buyable player shops, etc here for all players to use and access. Factions: As the name suggests this world is for factions only. You can wage war on other factions, claim land, take over land, grief, raid, pvp, etc. Server Information:
      Server Host: ShockByte Server Slots: 50+ Server Whitelist: No Server Banned Mods: None Server Banned Items: Banned Items wall at spawn Server Gamemode: Survival  Server Plugins: (20+ | Server Moderation plugins not listed) , Factions, Essentials,  WorldGuard, WorldEdit, GriefPrevention, ChestShop, and many more. Server IP: Server Website: Server Discord:  
      Modpack Requirements:
      Your computer must have the following to be able to run this modpack.
      5GB+ of Memory allocated to your Technic Launcher. Java 8 64-Bit (JRE or JDK)

    • By SQbuilder
      A few weeks ago, I created a Tekkit Classic server. I opened up hamachi, and connect using my ip4 address, and so did my friends. Everything was perfect until a few weeks later. This morning, when I booted up the server, my server browser said that "Can't connect to server". When I tried to connect it said: "connection timed out: connect" I reset the server, my computer, hamachi, and tekkit several times, but nothing would work. I checked the server and nothing was wrong or different. I can't think of any ideas. Help!
      C:\Users\***********\Desktop\Minecraft Servers\Tekkit Server>java -Xmx3G -Xms2G -jar Tekkit.jar nogui 182 recipes 27 achievements 07:48:56 [INFO] Starting minecraft server version 1.2.5 07:48:56 [INFO] Attempting early MinecraftForge initialization 07:48:56 [INFO] Completed early MinecraftForge initialization 07:48:56 [INFO] Forge Mod Loader version for Minecraft 1.2.5 loading 07:48:56 [INFO] Loading mods from C:\Users\******\Desktop\Minecraft Servers\Tekkit Server\mods 07:49:02 [INFO] Directory weaponmod contained no mods 07:49:04 [INFO] Forge Mod Loader has loaded 38 mods 07:49:05 [INFO] MinecraftForge v3.3.8.152 Initialized 07:49:05 [INFO] MinecraftForge v3.3.8.152 Initialized 07:49:05 [INFO] [WeaponMod] Properties file read succesfully! 07:49:06 [WARNING] Configuration for mod_ComputerCraft.enableAPI_http found value 0 outside acceptable range 4.9E-324,1.7976931348623157E308 07:49:06 [INFO] Loading ComputerCraft: To change block IDs, modify config/mod_ComputerCraft.cfg 07:49:06 [INFO] ComputerCraft: computerBlockID 207 07:49:06 [INFO] ComputerCraft: diskDriveBlockID 208 07:49:06 [INFO] ComputerCraft: diskItemID 4000 07:49:06 [INFO] CONFLICT @ -49 item slot already occupied by [email protected] while adding [email protected] 07:49:06 [INFO] ComputerCraft: Searching for RedPowerLib... 07:49:07 [INFO] ComputerCraft: RedPowerLib and methods located. 07:49:07 [INFO] CONFLICT @ -48 item slot already occupied by [email protected] while adding [email protected] 07:49:08 [INFO] Initializing alchemy values for Equivalent Exchange.. 07:49:08 [INFO] NetherOres: loaded Macerator Recipes 07:49:08 [INFO] Loading properties 07:49:08 [INFO] Starting Minecraft server on *:25565 07:49:11 [INFO] Loaded codechicken.wirelessredstone.core.CommandFreq 07:49:11 [INFO] [IC2] Config loaded from C:\Users\Sonny Quinday\Desktop\Minecraft Servers\Tekkit Server\.\config\IC2.cfg 07:49:12 [INFO] CONFLICT @ 1237 item slot already occupied by [email protected] while adding [email protected] 07:49:12 [INFO] CONFLICT @ -41 item slot already occupied by [email protected] while adding [email protected] 07:49:12 [INFO] [ccSensors] INFO: Loading SensorModule: Buildcraft 07:49:12 [INFO] [ccSensors] INFO: Loading SensorModule: IndustrialCraft2 07:49:12 [INFO] [ccSensors] INFO: Loading SensorModule: Forestry 07:49:12 [INFO] [ccSensors] INFO: mod_Forestry not found - SensorModule is disabled. 07:49:13 [INFO] [ccSensors] INFO: Loading SensorModule: RedPower2 07:49:13 [INFO] [ccSensors] INFO: Loading SensorModule: EquivalentExchange 07:49:13 [INFO] [ccSensors] INFO: Loading SensorModule: APS 07:49:13 [INFO] [ccSensors] INFO: mod_BuildcraftAPS not found - SensorModule is disabled. 07:49:13 [INFO] [ccSensors] INFO: Loading SensorModule: APS 07:49:13 [INFO] [ccSensors] INFO: mod_ThaumCraft not found - SensorModule is disabled. 07:49:13 [INFO] CONFLICT @ -78 item slot already occupied by [email protected] while adding [email protected] 07:49:13 [INFO] CompactSolars: MinecraftForge minor version mismatch, expecting 3.2.x, may lead to unexpected behavior 07:49:13 [INFO] CONFLICT @ -204 item slot already occupied by [email protected] while adding [email protected] 07:49:15 [INFO] RedPowerCore: MinecraftForge minor version mismatch, expecting 3.1.x, may lead to unexpected behavior 07:49:15 [INFO] Starting BuildCraft 2.2.14 07:49:15 [INFO] Copyright (c) SpaceToad, 2011 07:49:15 [INFO] 07:49:16 [INFO] [IC2] Loading IC2 submodule: bcIntegration22x 07:49:16 [INFO] [IC2] BuildCraft integration module loaded 07:49:16 [INFO] [IC2] Loaded minor compatibility modules: none 07:49:16 [INFO] ComputerCraft: turtleBlockID 216 07:49:16 [INFO] CONFLICT @ -40 item slot already occupied by [email protected] while adding [email protected] 07:49:17 [INFO] Forge Mod Loader load complete, 38 mods loaded 07:49:17 [INFO] This server is running CraftBukkit version git-Bukkit-jenkins-CraftBukkit-173 (MC: 1.2.5) (Implementing API version 1.2.5-R4.1-MCPC-SNAPSHOT) 07:49:17 [INFO] Loading mod_RedPowerWorld vForgeMod 07:49:17 [INFO] Loading mod_IC2_ChargingBench vForgeMod 07:49:17 [INFO] Loading Balkon's WeaponMod vForgeMod 07:49:17 [INFO] Loading mod_BuildCraftBuilders vForgeMod 07:49:17 [INFO] Loading mod_IC2 vForgeMod 07:49:17 [INFO] Loading mod_ccSensors vForgeMod 07:49:17 [INFO] Loading mod_WirelessRedstoneRedPower vForgeMod 07:49:17 [INFO] Loading mod_BuildCraftCore vForgeMod 07:49:17 [INFO] Loading mod_IC2AdvancedMachines vForgeMod 07:49:17 [INFO] Loading mod_ComputerCraft vForgeMod 07:49:17 [INFO] Loading mod_EnderStorage vForgeMod 07:49:17 [INFO] Loading mod_ModularForceFieldSystem vForgeMod 07:49:17 [INFO] Loading mod_RedPowerMachine vForgeMod 07:49:17 [INFO] Loading mod_CCTurtle vForgeMod 07:49:17 [INFO] Loading mod_CodeChickenCore vForgeMod 07:49:17 [INFO] Loading mod_CompactSolars vForgeMod 07:49:17 [INFO] Loading mod_ImmibisCore vForgeMod 07:49:17 [INFO] Loading mod_WirelessRedstoneCore vForgeMod 07:49:17 [INFO] Loading mod_WirelessRedstoneAddons vForgeMod 07:49:17 [INFO] Loading mod_IC2NuclearControl vForgeMod 07:49:18 [INFO] Loading mod_IronChest vForgeMod 07:49:18 [INFO] Loading mod_BuildCraftTransport vForgeMod 07:49:18 [INFO] Loading mod_RedPowerWiring vForgeMod 07:49:18 [INFO] Loading mod_MinecraftForge vForgeMod 07:49:18 [INFO] Loading mod_RedPowerControl vForgeMod 07:49:18 [INFO] Loading mod_RedPowerLogic vForgeMod 07:49:18 [INFO] Loading mod_RedPowerLighting vForgeMod 07:49:18 [INFO] Loading mod_RedPowerCore vForgeMod 07:49:18 [INFO] Loading mod_PowerConverters vForgeMod 07:49:18 [INFO] Loading mod_BuildCraftEnergy vForgeMod 07:49:18 [INFO] Loading mod_BuildCraftFactory vForgeMod 07:49:18 [INFO] Loading mod_NetherOres vForgeMod 07:49:18 [INFO] Loading mod_NotEnoughItems vForgeMod 07:49:18 [INFO] Loading mod_ImmiChunkLoaders vForgeMod 07:49:18 [INFO] Loading mod_EE vForgeMod 07:49:18 [INFO] Loading mod_Railcraft vForgeMod 07:49:18 [INFO] Loading mod_AdditionalPipes vForgeMod 07:49:18 [INFO] Loading mod_TubeStuff vForgeMod 07:49:18 [INFO] Preparing level "world" 07:49:18 [INFO] Default game type: 0 07:49:18 [SEVERE] Exception in thread "Thread-9" 07:49:18 [SEVERE] java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 7 07:49:18 [SEVERE] at$ 07:49:18 [SEVERE] at 07:49:18 [SEVERE] at 07:49:18 [SEVERE] at org.bukkit.craftbukkit.updater.BukkitDLUpdaterService.fetchArtifact( 07:49:18 [SEVERE] at org.bukkit.craftbukkit.updater.BukkitDLUpdaterService.getArtifact( 07:49:18 [SEVERE] at org.bukkit.craftbukkit.updater.AutoUpdater$ 07:49:18 [SEVERE] Caused by: java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 7 07:49:18 [SEVERE] at 07:49:18 [SEVERE] at 07:49:18 [SEVERE] at$ 07:49:18 [SEVERE] ... 5 more 07:49:19 [INFO] Registering world world, dimension 0, of providertype [email protected](0) with Minecraft Forge 07:49:19 [INFO] Registering world world_the_end, dimension 1, of providertype [email protected](0) with Minecraft Forge 07:49:19 [INFO] Registering world world_nether, dimension -1, of providertype [email protected](0) with Minecraft Forge 07:49:19 [INFO] Preparing start region for level 0 (Seed: 1530878175892299605) 07:49:21 [INFO] Preparing spawn area: 0% 07:49:22 [INFO] Preparing spawn area: 24% 07:49:23 [INFO] Preparing spawn area: 56% 07:49:24 [INFO] Preparing spawn area: 97% 07:49:24 [INFO] Preparing start region for level 1 (Seed: -5020703990991370870) 07:49:25 [INFO] Preparing spawn area: 40% 07:49:26 [INFO] Preparing spawn area: 52% 07:49:27 [INFO] Preparing spawn area: 93% 07:49:27 [INFO] Preparing start region for level 2 (Seed: -5020703990991370870) 07:49:28 [INFO] Preparing spawn area: 16% 07:49:29 [INFO] Preparing spawn area: 52% 07:49:30 [INFO] Preparing spawn area: 89% 07:49:30 [INFO] Server permissions file permissions.yml is empty, ignoring it 07:49:30 [INFO] Done (12.555s)! For help, type "help" or "?" 07:49:31 [INFO] [Railcraft] Loaded 0 saved Anchors