Trico

Crashing When Entering MP Server

10 posts in this topic

Okay so basically everything was fine this morning but after I tried installing a resource pack made for Hexxit, which I deleted completely after this, everything went to crap. Whenever I try to join a server in multiplayer, it loads for 2 seconds, giving you a quick glance at your character being stuck half in and half out of a block then immediately goes to a black screen and crashes.

Could it be the server itself? Could it be something corrupted on my end? I don't know. And yes, I have 2GB RAM allocated to it already, which was never a problem. And I'm running the latest Hexxit version.

What I tried:

  • Deleting (player).dat file
  • Reinstalling TechnicLauncher
  • Reinstalling Hexxit
  • Updating Java
  • Copying Saves folder, deleting .technic, and pasting Saves folder in the new one
     

Here is the crash report

Share this post


Link to post
Share on other sites
4 hours ago, AetherPirate said:

Grab the newest Nvdia driver  http://www.nvidia.com/Download/processFind.aspx?psid=85&pfid=610&osid=57&lid=1&whql=1&lang=en-us&ctk=0

if this does not help, pastebin this log:  C:\Users\Ziv\AppData\Roaming\.technic\modpacks\hexxit\crash-reports\crash-2017-04-19_14.33.21-client.txt

I actually fixed the problem, in a very odd way. I went on Solo for a bit then suddenly MP worked. Though thanks for the reminder to update my driver.

Except just now I've encountered a new issue... "Communication Error"
I've closed and reopened Hexxit but still says that

Know a solution for this?

Share this post


Link to post
Share on other sites

Could you grab this log?  C:\Users\Ziv\AppData\Roaming\.technic\modpacks\hexxit\crash-reports\crash-2017-04-21_09.45.55-client.txt 

Share this post


Link to post
Share on other sites

Turn off your server, backup your world, delete the Twilight Forest dimension (7), and restart and test

Share this post


Link to post
Share on other sites
21 minutes ago, AetherPirate said:

Turn off your server, backup your world, delete the Twilight Forest dimension (7), and restart and test

Oh man I wish I could, but this is a Public Server

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By kastleking12
      I joined a dimensional doors portal, then my game crashed.  After restarting my client, I get an error when trying to connect to my server.  
      Here is what my log says. 
      2017-04-23 21:08:11 [INFO] Done (0.853s)! For help, type "help" or "?" 2017-04-23 21:08:15 [INFO] kastleking12[/127.0.0.1:54423] logged in with entity id 86 at (3499.5, 9.0, -1827.5) 2017-04-23 21:08:15 [INFO] Disconnecting kastleking12 [/127.0.0.1:54423]: Internal server error 2017-04-23 21:08:15 [WARNING] Failed to handle packet for kastleking12 [/127.0.0.1:54423]: java.lang.NullPointerException java.lang.NullPointerException at net.minecraft.server.management.ServerConfigurationManager.func_72355_a(ServerConfigurationManager.java:120) at net.minecraft.network.NetLoginHandler.completeConnection(NetLoginHandler.java:194) at cpw.mods.fml.common.network.FMLNetworkHandler.handleClientConnection(FMLNetworkHandler.java:166) at cpw.mods.fml.common.network.FMLNetworkHandler.onConnectionReceivedFromClient(FMLNetworkHandler.java:120) at net.minecraft.network.NetLoginHandler.func_72529_d(NetLoginHandler.java:178) at net.minecraft.network.NetLoginHandler.func_72532_c(NetLoginHandler.java:71) at net.minecraft.server.ServerListenThread.func_71766_a(ServerListenThread.java:55) at net.minecraft.server.dedicated.DedicatedServerListenThread.func_71747_b(SourceFile:29) at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:677) at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:275) at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:573) at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:470) at net.minecraft.server.ThreadMinecraftServer.run(SourceFile:573) 2017-04-23 21:09:07 [INFO] ZacSlave[/73.147.41.111:61846] logged in with entity id 87 at (3434.300000011921, 69.5625, -1697.300000011921)
    • By sirherobrine
      Hello I have been running and editing my own custom modpack Crescent Moon and I could really use some help fixing some bugs in the server. As well as find bugs so If you would like to join my server and help with fixing bugs fantastic. If you just want to join and help find bugs by all means please do. Shoot me as message and feel free to join my discord if you need me. I will answer discord messages within about 12 hours and Technic with in 24 hours. Please I could really use some help I am the only one working on this and its really draining. Thanks for reading this hope to hear from someone very soon.  https://discord.gg/n3mYM9K
    • By Ellezana
      Hi all,
      I've been messing around with  my graphics drivers for a few days now after another game notified me that they were 2000 odd days out of date (gulp). I tried to update them multiple times (was on Intel HD Graphics 3000) however everytime I rebooted my laptop to apply the changes nothing seemed to change or happen or I got a notification saying I didn't match criteria or something along those lines. I was trying to play Blightfall earlier and had to update my Java for that and it still was painfully slow which I put down to the drivers. I've been trying to play Hexxit now and the launching is fine but then the game immediately crashed and comes up with a error report citing Bad video cards. I've tried to update so many times I'm at my wits end now. Any help would be gladly appreciated. I will provide any details necessary as long as I know where to find them. I also very recently upgraded to windows 10 if this affects anything?
      Thanks
       
    • By bmack1223
      Website: http://madwell.enjin.com/ | Server IP: 198.50.156.149   | Technic Pack Page: Madwell
      For more information on our servers, network, status, wiki's, launchers, pack pages, and more checkout our Discord here:
      https://discord.gg/rEUdZ
       
       
      Madwell is a modpack that has been in development for a few months. It is now in a stable release for the public to enjoy.
      If you are a fan of Warfare, you got to try this pack. You will not regret it!
       
      Madwell is a community of gamers and a independently hosted minecraft network. We believe in offering as many choices as possible without restricting gameplay. If your a griefer, raider, like to pvp, join a faction and conquer your enemies. All of that and more is possible on Madwell
       
       
      Worlds & Information:
      Spawn: This is our spawn world, we have rules, information,admin shops, buyable player shops, etc here for all players to use and access. Factions: As the name suggests this world is for factions only. You can wage war on other factions, claim land, take over land, grief, raid, pvp, etc. Server Information:
      Server Host: ShockByte Server Slots: 50+ Server Whitelist: No Server Banned Mods: None Server Banned Items: Banned Items wall at spawn Server Gamemode: Survival  Server Plugins: (20+ | Server Moderation plugins not listed) , Factions, Essentials,  WorldGuard, WorldEdit, GriefPrevention, ChestShop, and many more. Server IP:   198.50.156.149 Server Website:  http://madwell.enjin.com/ Server Discord: https://discord.gg/rEUdZ  
       
      Modpack Requirements:
      Your computer must have the following to be able to run this modpack.
      5GB+ of Memory allocated to your Technic Launcher. Java 8 64-Bit (JRE or JDK)


    • By SQbuilder
      A few weeks ago, I created a Tekkit Classic server. I opened up hamachi, and connect using my ip4 address, and so did my friends. Everything was perfect until a few weeks later. This morning, when I booted up the server, my server browser said that "Can't connect to server". When I tried to connect it said: "connection timed out: connect" I reset the server, my computer, hamachi, and tekkit several times, but nothing would work. I checked the server and nothing was wrong or different. I can't think of any ideas. Help!
      C:\Users\***********\Desktop\Minecraft Servers\Tekkit Server>java -Xmx3G -Xms2G -jar Tekkit.jar nogui 182 recipes 27 achievements 07:48:56 [INFO] Starting minecraft server version 1.2.5 07:48:56 [INFO] Attempting early MinecraftForge initialization 07:48:56 [INFO] Completed early MinecraftForge initialization 07:48:56 [INFO] Forge Mod Loader version 2.2.91.173 for Minecraft 1.2.5 loading 07:48:56 [INFO] Loading mods from C:\Users\******\Desktop\Minecraft Servers\Tekkit Server\mods 07:49:02 [INFO] Directory weaponmod contained no mods 07:49:04 [INFO] Forge Mod Loader has loaded 38 mods 07:49:05 [INFO] MinecraftForge v3.3.8.152 Initialized 07:49:05 [INFO] MinecraftForge v3.3.8.152 Initialized 07:49:05 [INFO] [WeaponMod] Properties file read succesfully! 07:49:06 [WARNING] Configuration for mod_ComputerCraft.enableAPI_http found value 0 outside acceptable range 4.9E-324,1.7976931348623157E308 07:49:06 [INFO] Loading ComputerCraft: To change block IDs, modify config/mod_ComputerCraft.cfg 07:49:06 [INFO] ComputerCraft: computerBlockID 207 07:49:06 [INFO] ComputerCraft: diskDriveBlockID 208 07:49:06 [INFO] ComputerCraft: diskItemID 4000 07:49:06 [INFO] CONFLICT @ -49 item slot already occupied by [email protected] while adding [email protected] 07:49:06 [INFO] ComputerCraft: Searching for RedPowerLib... 07:49:07 [INFO] ComputerCraft: RedPowerLib and methods located. 07:49:07 [INFO] CONFLICT @ -48 item slot already occupied by [email protected] while adding [email protected] 07:49:08 [INFO] Initializing alchemy values for Equivalent Exchange.. 07:49:08 [INFO] NetherOres: loaded Macerator Recipes 07:49:08 [INFO] Loading properties 07:49:08 [INFO] Starting Minecraft server on *:25565 07:49:11 [INFO] Loaded codechicken.wirelessredstone.core.CommandFreq 07:49:11 [INFO] [IC2] Config loaded from C:\Users\Sonny Quinday\Desktop\Minecraft Servers\Tekkit Server\.\config\IC2.cfg 07:49:12 [INFO] CONFLICT @ 1237 item slot already occupied by [email protected] while adding [email protected] 07:49:12 [INFO] CONFLICT @ -41 item slot already occupied by [email protected] while adding [email protected] 07:49:12 [INFO] [ccSensors] INFO: Loading SensorModule: Buildcraft 07:49:12 [INFO] [ccSensors] INFO: Loading SensorModule: IndustrialCraft2 07:49:12 [INFO] [ccSensors] INFO: Loading SensorModule: Forestry 07:49:12 [INFO] [ccSensors] INFO: mod_Forestry not found - SensorModule is disabled. 07:49:13 [INFO] [ccSensors] INFO: Loading SensorModule: RedPower2 07:49:13 [INFO] [ccSensors] INFO: Loading SensorModule: EquivalentExchange 07:49:13 [INFO] [ccSensors] INFO: Loading SensorModule: APS 07:49:13 [INFO] [ccSensors] INFO: mod_BuildcraftAPS not found - SensorModule is disabled. 07:49:13 [INFO] [ccSensors] INFO: Loading SensorModule: APS 07:49:13 [INFO] [ccSensors] INFO: mod_ThaumCraft not found - SensorModule is disabled. 07:49:13 [INFO] CONFLICT @ -78 item slot already occupied by [email protected] while adding [email protected] 07:49:13 [INFO] CompactSolars: MinecraftForge minor version mismatch, expecting 3.2.x, may lead to unexpected behavior 07:49:13 [INFO] CONFLICT @ -204 item slot already occupied by [email protected] while adding [email protected] 07:49:15 [INFO] RedPowerCore: MinecraftForge minor version mismatch, expecting 3.1.x, may lead to unexpected behavior 07:49:15 [INFO] Starting BuildCraft 2.2.14 07:49:15 [INFO] Copyright (c) SpaceToad, 2011 07:49:15 [INFO] http://www.mod-buildcraft.com 07:49:16 [INFO] [IC2] Loading IC2 submodule: bcIntegration22x 07:49:16 [INFO] [IC2] BuildCraft integration module loaded 07:49:16 [INFO] [IC2] Loaded minor compatibility modules: none 07:49:16 [INFO] ComputerCraft: turtleBlockID 216 07:49:16 [INFO] CONFLICT @ -40 item slot already occupied by [email protected] while adding [email protected] 07:49:17 [INFO] Forge Mod Loader load complete, 38 mods loaded 07:49:17 [INFO] This server is running CraftBukkit version git-Bukkit-jenkins-CraftBukkit-173 (MC: 1.2.5) (Implementing API version 1.2.5-R4.1-MCPC-SNAPSHOT) 07:49:17 [INFO] Loading mod_RedPowerWorld vForgeMod 07:49:17 [INFO] Loading mod_IC2_ChargingBench vForgeMod 07:49:17 [INFO] Loading Balkon's WeaponMod vForgeMod 07:49:17 [INFO] Loading mod_BuildCraftBuilders vForgeMod 07:49:17 [INFO] Loading mod_IC2 vForgeMod 07:49:17 [INFO] Loading mod_ccSensors vForgeMod 07:49:17 [INFO] Loading mod_WirelessRedstoneRedPower vForgeMod 07:49:17 [INFO] Loading mod_BuildCraftCore vForgeMod 07:49:17 [INFO] Loading mod_IC2AdvancedMachines vForgeMod 07:49:17 [INFO] Loading mod_ComputerCraft vForgeMod 07:49:17 [INFO] Loading mod_EnderStorage vForgeMod 07:49:17 [INFO] Loading mod_ModularForceFieldSystem vForgeMod 07:49:17 [INFO] Loading mod_RedPowerMachine vForgeMod 07:49:17 [INFO] Loading mod_CCTurtle vForgeMod 07:49:17 [INFO] Loading mod_CodeChickenCore vForgeMod 07:49:17 [INFO] Loading mod_CompactSolars vForgeMod 07:49:17 [INFO] Loading mod_ImmibisCore vForgeMod 07:49:17 [INFO] Loading mod_WirelessRedstoneCore vForgeMod 07:49:17 [INFO] Loading mod_WirelessRedstoneAddons vForgeMod 07:49:17 [INFO] Loading mod_IC2NuclearControl vForgeMod 07:49:18 [INFO] Loading mod_IronChest vForgeMod 07:49:18 [INFO] Loading mod_BuildCraftTransport vForgeMod 07:49:18 [INFO] Loading mod_RedPowerWiring vForgeMod 07:49:18 [INFO] Loading mod_MinecraftForge vForgeMod 07:49:18 [INFO] Loading mod_RedPowerControl vForgeMod 07:49:18 [INFO] Loading mod_RedPowerLogic vForgeMod 07:49:18 [INFO] Loading mod_RedPowerLighting vForgeMod 07:49:18 [INFO] Loading mod_RedPowerCore vForgeMod 07:49:18 [INFO] Loading mod_PowerConverters vForgeMod 07:49:18 [INFO] Loading mod_BuildCraftEnergy vForgeMod 07:49:18 [INFO] Loading mod_BuildCraftFactory vForgeMod 07:49:18 [INFO] Loading mod_NetherOres vForgeMod 07:49:18 [INFO] Loading mod_NotEnoughItems vForgeMod 07:49:18 [INFO] Loading mod_ImmiChunkLoaders vForgeMod 07:49:18 [INFO] Loading mod_EE vForgeMod 07:49:18 [INFO] Loading mod_Railcraft vForgeMod 07:49:18 [INFO] Loading mod_AdditionalPipes vForgeMod 07:49:18 [INFO] Loading mod_TubeStuff vForgeMod 07:49:18 [INFO] Preparing level "world" 07:49:18 [INFO] Default game type: 0 07:49:18 [SEVERE] Exception in thread "Thread-9" 07:49:18 [SEVERE] com.google.gson.JsonSyntaxException: java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 7 07:49:18 [SEVERE] at com.google.gson.internal.bind.ReflectiveTypeAdapterFactory$Adapter.read(ReflectiveTypeAdapterFactory.java:180) 07:49:18 [SEVERE] at com.google.gson.Gson.fromJson(Gson.java:755) 07:49:18 [SEVERE] at com.google.gson.Gson.fromJson(Gson.java:694) 07:49:18 [SEVERE] at org.bukkit.craftbukkit.updater.BukkitDLUpdaterService.fetchArtifact(BukkitDLUpdaterService.java:44) 07:49:18 [SEVERE] at org.bukkit.craftbukkit.updater.BukkitDLUpdaterService.getArtifact(BukkitDLUpdaterService.java:27) 07:49:18 [SEVERE] at org.bukkit.craftbukkit.updater.AutoUpdater$1.run(AutoUpdater.java:77) 07:49:18 [SEVERE] Caused by: java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 7 07:49:18 [SEVERE] at com.google.gson.stream.JsonReader.expect(JsonReader.java:339) 07:49:18 [SEVERE] at com.google.gson.stream.JsonReader.beginObject(JsonReader.java:322) 07:49:18 [SEVERE] at com.google.gson.internal.bind.ReflectiveTypeAdapterFactory$Adapter.read(ReflectiveTypeAdapterFactory.java:168) 07:49:18 [SEVERE] ... 5 more 07:49:19 [INFO] Registering world world, dimension 0, of providertype [email protected](0) with Minecraft Forge 07:49:19 [INFO] Registering world world_the_end, dimension 1, of providertype [email protected](0) with Minecraft Forge 07:49:19 [INFO] Registering world world_nether, dimension -1, of providertype [email protected](0) with Minecraft Forge 07:49:19 [INFO] Preparing start region for level 0 (Seed: 1530878175892299605) 07:49:21 [INFO] Preparing spawn area: 0% 07:49:22 [INFO] Preparing spawn area: 24% 07:49:23 [INFO] Preparing spawn area: 56% 07:49:24 [INFO] Preparing spawn area: 97% 07:49:24 [INFO] Preparing start region for level 1 (Seed: -5020703990991370870) 07:49:25 [INFO] Preparing spawn area: 40% 07:49:26 [INFO] Preparing spawn area: 52% 07:49:27 [INFO] Preparing spawn area: 93% 07:49:27 [INFO] Preparing start region for level 2 (Seed: -5020703990991370870) 07:49:28 [INFO] Preparing spawn area: 16% 07:49:29 [INFO] Preparing spawn area: 52% 07:49:30 [INFO] Preparing spawn area: 89% 07:49:30 [INFO] Server permissions file permissions.yml is empty, ignoring it 07:49:30 [INFO] Done (12.555s)! For help, type "help" or "?" 07:49:31 [INFO] [Railcraft] Loaded 0 saved Anchors