tekkit legends
[Tekkit legends 1.7.10]Arcade Mafia[Factions]

2 posts in this topic

Hi Guys!


Are you looking for a Tekkit Legends Factions server to play on with your friends or make new friends? Then this is your change.

ArcadeMafia has a server for you! It's a tekkit legends server. It's online 24/7! We are making use of factions. If you'd like to join our server and play with friends or other players on the server use this IP:


We also have our own discord server. with over 1000 people and many more different games!


I hope to see you soon in the discord and MineCraft server!



Arcade Mafia



Edited by MiniKoelkast

Share this post

Link to post
Share on other sites

read the Server Guidelines and edit your title with the missing information

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By JetroNL
      Hi, am I am unable to launch TEKKIT Legends. I'm not able to launch Attack of the B-team either. After installing the pack, I'll press Play, there'll be some activity and then the Technic Launcher pops up again as if nothing happened.
      I'm running Windows 10 Pro 64-bit, the latest Java version downloaded this evening prior to my last 3 attempts to get things working and MineCraft 1.12.2 (which runs fine). I have reinstalled the Technic Launcher as well, deleting the .technic folder and activating the Technic Launcher which then reinstalls (I assume) everything it needs.
      In the hope that someone can help me identify and resolve the issue, I have attached the TEKKIT Legends log.
    • By hperd
      Edit: I just tested to only run Minecraft without the Server, going into a Single Player World and the RAM usage is going up contunously. I set the RAM usage in the Technic Launcher to 4GB, why is it then going higher than that?
      So I'm running a Server with the Mod Pack "After Humans" and I provided the start.bat with the Java Arguments "-Xmx 4G -Xms-1G" and in the Technic Launcher I set the maximum RAM usage to 4GB.
      When the Server is running it is taking around 2.5GB to 3GB of RAM in maximum but the strange thing is, when Minecraft itself is running it's starting at 2GB and is going continously up? Yesterday for example it went to around 8.6GB RAM? If I'm pressing inside Minecraft F3 to see the usage of RAM it says it's using 1.3 to 1.6GB of 4096MB but in the Task Manager it's going continuesly up... Why is that?
      Is Java just adding the Arguments from TL and Server.bat up to one (8GB)?
      Everytime Java is using all my RAM my computer starts to bug out (black monitors / explorer is crashing / can't see my desktop symbols anymore / ...).
      I hope someone can help me out.
      My System is as follows: 16GB RAM, i7-4770, GTX 1060, Win 10 64 bit
    • By Wyattagum
      First Modpack Uploaded on My Account
      A Simple Collection of Fine and Top Rated Agriculture Mods Combined to Make Farming, and by Farming I mean ALL of the
      Farm, more Realistic!
                                                                            Mods in this ModPack
      Pam's HarvestCraft credit Pamela Collins (MatrexsVigil) and Rhodox of the Painterly Pack Fast Leaf Decay AgriCraft [SBM] Wooden Shears Terraqueous Roost ExpandedBonemeal


    • By Bruv
      Hi, I am playing on Windows 10 and have Vanilla MC and the Tech-launcher up to date. Vanilla works fine but every mod pack on this site has no audio whatsoever when I'm playing. Please help. Thanks.