Archived

This topic is now archived and is closed to further replies.

  • 0
nollmiki

Crash on world loading AOTBT

Question

Hi pls somebody help! 

After several hours of play the game unexpectedly crashed during exploration the world (new chunks generated). Now it can't load the world anymore, but instantly crashes every time I try to load it. No issues with other worlds.

Reinstall the Attack of the B team modpack didn't help.

Crashlog:

https://paste.ubuntu.com/24569802/

 

Share this post


Link to post
Share on other sites

4 answers to this question

2 hours ago, nollmiki said:

Hi pls somebody help! 

After several hours of play the game unexpectedly crashed during exploration the world (new chunks generated). Now it can't load the world anymore, but instantly crashes every time I try to load it. No issues with other worlds.

Reinstall the Attack of the B team modpack didn't help.

Crashlog:

https://paste.ubuntu.com/24569802/

 

Did you turn the generation of villages on? In this case, delete the villages.dat and, if you want to keep it on, rename the biomes o' plenty jarfile to "z%whateveritiscalled%", yes, just a z before the name.

Share this post


Link to post
Share on other sites
7 hours ago, JaariAtmc said:

Did you turn the generation of villages on? In this case, delete the villages.dat and, if you want to keep it on, rename the biomes o' plenty jarfile to "z%whateveritiscalled%", yes, just a z before the name.

I replaced the level.dat, level.dat_mcr and level.dat_old files from another save  - in this case all the stuff from my inventory was lost. Than I set the position of my caracter back to my cave with MCEdit. When I mix both these techniques sometimes I manage to start the world (with my inventory), but upon exploring it keeps crushing.

The initially setups on world generation were:

  • Game mode: Survival
  • More World Options:
    • Generate Structures: ON
    • World Type: Biomes' O Plenty
    • Alloww Cheats: ON
    • Bonus Chest: OFF
    • no seeds were used

We play this world with my two friend sometimes via Hamachi-LAN.

Is there an incompatibility with generating structures and Biomes' O Plenty world type?? If yes, can I set the structure generation off?

Nothing happens when I delete villages.dat. There is a BOPTemple.dat and BOPVillage.dat as well as a Mineshaft.dat in the same \data directory. Should I delete them as well?

Very weird  to do so, but the biomes o' plenty jarfile is now zbiomesoplenty-universal-1.6.4-1.2.1.434. However I noted a zchisel-1.6.4-1.5.0fix, so even with the 'z' its not the last one in the directory (if that would be the goal).

Keep crushing, keep crushing.

Here's the newest crashreport:

https://paste.ubuntu.com/24572602/

Share this post


Link to post
Share on other sites
8 hours ago, nollmiki said:

I replaced the level.dat, level.dat_mcr and level.dat_old files from another save  - in this case all the stuff from my inventory was lost. Than I set the position of my caracter back to my cave with MCEdit. When I mix both these techniques sometimes I manage to start the world (with my inventory), but upon exploring it keeps crushing.

The initially setups on world generation were:

  • Game mode: Survival
  • More World Options:
    • Generate Structures: ON
    • World Type: Biomes' O Plenty
    • Alloww Cheats: ON
    • Bonus Chest: OFF
    • no seeds were used

We play this world with my two friend sometimes via Hamachi-LAN.

Is there an incompatibility with generating structures and Biomes' O Plenty world type?? If yes, can I set the structure generation off?

Nothing happens when I delete villages.dat. There is a BOPTemple.dat and BOPVillage.dat as well as a Mineshaft.dat in the same \data directory. Should I delete them as well?

Very weird  to do so, but the biomes o' plenty jarfile is now zbiomesoplenty-universal-1.6.4-1.2.1.434. However I noted a zchisel-1.6.4-1.5.0fix, so even with the 'z' its not the last one in the directory (if that would be the goal).

Keep crushing, keep crushing.

Here's the newest crashreport:

https://paste.ubuntu.com/24572602/

There is a conflict between Biomes o plenty and minecraft vanilla village generation in "this" version of Bteam. This causes a crash similar to yours. The "z" is just an old trick to, well, trick the system to load things a moment later. That fixed issues in my test. It is pretty weird though.

You'd be try to remove the BOPtemple and BOPvillage .dat, yes.

Share this post


Link to post
Share on other sites

  • Similar Content

    • By drinkmybritishtears
      I'm not sure if this is under the right topic, but-
      Ever since I updated my laptop, the Minecraft Diaries mod-pack crashes after 2/7 (Phase 1), before that it was fine and ran well. I've tried re-installing the pack and the technic launcher itself, nothing new has happened and I'm not sure what to do.
      (I'm not sure if it counts as a custom seen as i myself didn't make it, but I think it's fan-based)
      ((MOD-PACK -- https://www.technicpack.net/modpack/tribute-to-aphmau.722351/about ))
       
    • By mochi
      Hello, I was trying to play a modpack and it would load but then put me back to the technic launcher. I have no idea can anyone help me?
    • By bonieboii
      Last night I was playing Minecraft. I put my pc into sleep mode (without closing Minecraft) and my power went out. Today, I booted up my PC, launched Minecraft, opened my world, and it gets stuck on the loading screen. The game crashes at this point, but still eats up all of my memory as usual. I've got the crash report attached as a file. Someone please help me with this, I was doing well on the world!
      crash-2018-06-04_15.53.08-server.txt
    • By KTheWolf
      So I made this modpack with alot of mods and I am trying to make a server to go with it and the server control panel appears when I click it but then it crashes and I've been trying to understand what's wrong in the crash report but I can't understand some of this and I've googled a bunch of stuff. It's probably not that complicated but I just can't figure it out.
      The Crash Report: https://pastebin.com/HBxxwrGb
       
    • By Boi123
      Hello, my game after I create new world and start it when it load it crashes and says this "A fatal error has been occured, this connection is terminated ". This happens in singleplayer and multiplayer.
      Modpack im playing "Mianite reborn"
      Does somebody has a solution