• 0
Sigorth

The game runs slow in technic launcher

Question

When playing vanilla minecraft through vanilla launcher, i get an avarage of 90fps with all settings maxed out and 22 chunks render distance. That's even when i haven't allocated any extra ram to it (so its at like 800mb or something). 

I think that it is safe to say that my gaming rig handles minecraft decently. It's only a budget gaming rig, but i am happy with it as it gives me 40+fps on games like the witcher 3. 

Well here comes the problem:

I want to play modded minecraft, and i liked tekkit and lapito's galacticraft modpack. I installed them and when i run tekkit, i recieve only 20fps. I thought that maybe all the mods was too intesive on my cpu, but i kept looking into it.. just running vanilla minecraft through the tekkit launcher only gives me 40fps and thats unstable as well, meaning i will sometimes see drops to 20fps. I have tried turning down the settings, allocating more ram. I feel like i have tried everything, but i cant seem to get the fps up. I think that my computer will be able to run the game with mods without lag, but maybe since its running java 64 bit it's being unstable? I tried running it through 32 bit, but then the game crashes and tells me i need to allocate more ram (the max is 1gb through 32gig java which i already allocated to it). 

I can turn down all my settings to barely playable and still have low fps, it doesn't seem to make any improvements at all. Even when in the vanilla game through the technic launcher.

Here are my specs:

 

-Amd athlon 4x 845 quad core 3,5ghz processor

-Ati rx 460 saphire 4gb video card

-8gb ram

-240gb ssd (dont know if this is necessary information)

-Windows 10 64bit

 

 

I hope there is someone out there that can help me. 

 

Btw, i have done these things already:

 

1. Tried to add the java.exe file in the modpack to the radeon settings so that it would be optimized, but this doesnt work.

 

2. I have allocated more ram (everything from 1gb to 6gb)

 

3. I have updated video card drivers

 

4. I have the newest versions of both 32 and 64bit java

 

Its worth mentioning that it looks like its the cpu that makes the fps drop. Its at 80-90% when running minecraft (both vanilla and modpacks) and 30-40% when running vanilla on vanilla launcher. The memory seems to be fairly stable at 1-2gb ram with modpack. 

Edited by Sigorth
Add information

Share this post


Link to post
Share on other sites

2 answers to this question

  • 0

Are you playing the same version of Minecraft on both vanilla and in Technic Launcher?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Zyecro
      Ok so technic launcher won't run minecraft at all when i put more than one gb
      it just reloads the modpack screen And also i have 3gb available but im doing 2 or 1.5 GB and its doing the same thing
    • By duskeoyun
      Hey Technic,
      My friends and I can't figure out why my Tekkit won't open. We have tried deleting the modpacks in .technic , re installed minecraft and technic launcher, change the memory size at Launcher Options and it still doesn't work. Can someone provide me with a solution to my issue. 
      Here is my log file: https://pastebin.com/EUpzJ55g
      Thanks.
    • By KoriksFlameKell
      So I've been trying to use Statues to create player skins but it's not working. Can anyone help me???
    • By MeepsterKH
      My custom modpack wont work at all launching and I sincerely dont know why this time, i checked for error mods and such but cant find any
      https://docs.google.com/document/d/1Slcn2umTk2eNpXwg35H2sBqyOYVrpwlaiBOkQIILIXI/edit?usp=sharing