• 0
Sigorth

The game runs slow in technic launcher

Question

Posted (edited)

When playing vanilla minecraft through vanilla launcher, i get an avarage of 90fps with all settings maxed out and 22 chunks render distance. That's even when i haven't allocated any extra ram to it (so its at like 800mb or something). 

I think that it is safe to say that my gaming rig handles minecraft decently. It's only a budget gaming rig, but i am happy with it as it gives me 40+fps on games like the witcher 3. 

Well here comes the problem:

I want to play modded minecraft, and i liked tekkit and lapito's galacticraft modpack. I installed them and when i run tekkit, i recieve only 20fps. I thought that maybe all the mods was too intesive on my cpu, but i kept looking into it.. just running vanilla minecraft through the tekkit launcher only gives me 40fps and thats unstable as well, meaning i will sometimes see drops to 20fps. I have tried turning down the settings, allocating more ram. I feel like i have tried everything, but i cant seem to get the fps up. I think that my computer will be able to run the game with mods without lag, but maybe since its running java 64 bit it's being unstable? I tried running it through 32 bit, but then the game crashes and tells me i need to allocate more ram (the max is 1gb through 32gig java which i already allocated to it). 

I can turn down all my settings to barely playable and still have low fps, it doesn't seem to make any improvements at all. Even when in the vanilla game through the technic launcher.

Here are my specs:

 

-Amd athlon 4x 845 quad core 3,5ghz processor

-Ati rx 460 saphire 4gb video card

-8gb ram

-240gb ssd (dont know if this is necessary information)

-Windows 10 64bit

 

 

I hope there is someone out there that can help me. 

 

Btw, i have done these things already:

 

1. Tried to add the java.exe file in the modpack to the radeon settings so that it would be optimized, but this doesnt work.

 

2. I have allocated more ram (everything from 1gb to 6gb)

 

3. I have updated video card drivers

 

4. I have the newest versions of both 32 and 64bit java

 

Its worth mentioning that it looks like its the cpu that makes the fps drop. Its at 80-90% when running minecraft (both vanilla and modpacks) and 30-40% when running vanilla on vanilla launcher. The memory seems to be fairly stable at 1-2gb ram with modpack. 

Edited by Sigorth
Add information

Share this post


Link to post
Share on other sites

2 answers to this question

  • 0

Are you playing the same version of Minecraft on both vanilla and in Technic Launcher?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Solivis
      I'm getting a problem where upon pressing play, the launcher dissapears and comes back again without any visible change
      I've included my error report below
      ---- Minecraft Crash Report ----
      // Don't be sad. I'll do better next time, I promise!
      Time: 21/11/17 11:40 AM
      Description: Initializing game
      org.lwjgl.LWJGLException: Pixel format not accelerated
          at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
          at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
          at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:244)
          at org.lwjgl.opengl.Display.createWindow(Display.java:306)
          at org.lwjgl.opengl.Display.create(Display.java:848)
          at org.lwjgl.opengl.Display.create(Display.java:757)
          at org.lwjgl.opengl.Display.create(Display.java:739)
          at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:449)
          at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:808)
          at net.minecraft.client.main.Main.main(SourceFile:101)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
          at java.lang.reflect.Method.invoke(Unknown Source)
          at net.minecraft.launchwrapper.Launch.launch(Launch.java:131)
          at net.minecraft.launchwrapper.Launch.main(Launch.java:27)

      A detailed walkthrough of the error, its code path and all known details is as follows:
      ---------------------------------------------------------------------------------------
      -- Head --
      Stacktrace:
          at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
          at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
          at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:244)
          at org.lwjgl.opengl.Display.createWindow(Display.java:306)
          at org.lwjgl.opengl.Display.create(Display.java:848)
          at org.lwjgl.opengl.Display.create(Display.java:757)
          at org.lwjgl.opengl.Display.create(Display.java:739)
          at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:449)
      -- Initialization --
      Details:
      Stacktrace:
          at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:808)
          at net.minecraft.client.main.Main.main(SourceFile:101)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
          at java.lang.reflect.Method.invoke(Unknown Source)
          at net.minecraft.launchwrapper.Launch.launch(Launch.java:131)
          at net.minecraft.launchwrapper.Launch.main(Launch.java:27)
      -- System Details --
      Details:
          Minecraft Version: 1.6.4
          Operating System: Windows 10 (amd64) version 10.0
          Java Version: 1.8.0_151, Oracle Corporation
          Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
          Memory: 1654796200 bytes (1578 MB) / 2058354688 bytes (1963 MB) up to 2058354688 bytes (1963 MB)
          JVM Flags: 3 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xms2048m -Xmx2048m
          AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
          Suspicious classes: FML and Forge are installed
          IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
          FML: 
          Launched Version: 1.6.4-Forge9.11.1.965
          LWJGL: 2.9.0
          OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.
          Is Modded: Definitely; Client brand changed to 'fml,forge'
          Type: Client (map_client.txt)
          Resource Pack: Default
          Current Language: ~~ERROR~~ NullPointerException: null
          Profiler Position: N/A (disabled)
          Vec3 Pool Size: ~~ERROR~~ NullPoint
    • By KromTvYt
      This is a new modpack called EclipseC , here you can play dragon block c (always updated) alone or with your friends in our server !
       
      the technic launcher link is :
      https://www.technicpack.net/modpack/eclipsec.1059818
    • By elvis8900
      I'm trying to run the Technic Launcher on mint linux 18.2. I can see the launcher. I just can't adjust the launcher window to access any mod packs.