challenger1_

My modpack seems to be having problems....

8 posts in this topic

Hello, So a couple of days ago, I decided it was finally time to update my modpack from 1.7.10 to 1.10.2. So, having created modpacks before and having updated to newer versions several times in the past, I did the same thing that I normally did to update my modpack - deleted all the mods and forge and redownloaded the newer version of them. Unsurprisingly, things did not all work perfectly the first time. But what was surprising was that pretty much nothing worked. When I had all my mods that I wanted and then launched the pack by replacing another pack's mods (obviously mc version 1.10.2) with my own mods, the technic launcher reopened as soon as it closed. There was no crash report, but there was some info in the latest log here. So I thought that was weird, but I figured I should try adding one mod at a time and see if it was a problem with certain mods. There were a couple of mods that would work, but pretty much anytime I got more than three mods, I always got a crash report that was something like this. Also, occasionally some of the mods would say that they needed another mod for them to work, but then wouldn't list another mod like here. Considering the number of mods that seem to have this problem, it made me wonder if it was something wrong with my minecraft forge. So I redownloaded forge but nothing changed. Confused at this point, I decided to try the unupdated version of my modpack, which worked perfectly fine. I then exchanged the mods from the updated and the un-updated, neither of which worked (unsurprisingly since they are different mc versions). Desperate for something to work, I redownloaded all of my mods, restarted from scratch and used Luke's modpack making guide from the very beginning, and even downloaded another modpack of the same version and tried using their mods (which worked in their modpack), but nothing changed the ultimate failure of my updated modpack. So, I want to know what in the world happened? Did I do something wrong? Did something about making modpacks change? Why does it seem like my modpack is the only one being dumb like this? I am continuing to run tests on just trying one mod at a time, but it seems random as to whether the game will crash, need another mod, or just quit as soon as it starts. Thanks a bunch to all who respond!

Share this post


Link to post
Share on other sites

Posted (edited)

Had a quick look at your first log you linked and saw this:  OpenBlocks-1.7.10-1.6.jar

Make sure ALL your mods are 1.10.2

provide a dropbox link to your modpack if you still need help

Edited by AetherPirate

Share this post


Link to post
Share on other sites

Here is a copy of the modpack, note that this is not the modpack I was testing with, but a copy of the bin, mods, coremods, and config folder. None of the other folders matter to my knowledge. 

But in response to the 1.7.10 mod, I don't know where I first heard this, but I thought that you were still able to put in mods of previous versions of minecraft in with a later version of minecraft (i.e. a 1.7.10 mod into 1.10.2 minecraft). Is this not true? Or is there some legitimacy to this, it just depends on the circumstances? 

Share this post


Link to post
Share on other sites

Ok, so i added in IC2, but COFHCore still said it needs another mod, and upon removing it and its mods, Galacticraft said it needs another mod, and upon removing it and its mods, IchunUtil said the same thing, then finally, I got something. It says Mantle needs Forge 12.18.1.2011 or above, and the fml-client-latest.log said similar:

"The mod mantle (Mantle) requires mod versions [[email protected][12.18.1.2011,)] to be available
[10:25:40] [Client thread/ERROR] [FML/]: net.minecraftforge.fml.common.MissingModsException: Mod mantle (Mantle) requires [[email protected][12.18.1.2011,)]"

When I downloaded Forge, I downloaded  version 12.18.3.2316

So now I will try downloading 12.18.1.2001 and see what happens

 

Share this post


Link to post
Share on other sites

So of course, I tried replacing the modpack.jar with the older version of forge, and now Tree Chopper says it needs a higher version of forge. So I got the slightly higher version, and the pack crashed. Here is the report, but the main thing is that it said that Progressive Automation does not have a class definition, so I tried downloading a different version of the mod and then it crashed again, but this time it was due to ExtraUtilities2 as seen here. So I again got an older version to try again and then it crashed, creating a similar crash report as the second one. This caused me to remove extrautilities. thenn..... IT WORKED!!!!! I started adding mods back one at a time, but the first one i added, galacticraft, also needed another mod. 

Upon further inspection of the fml-client-latest log i found this: 
"[11:07:55] [Client thread/ERROR] [FML/]: The mod galacticraftcore (Galacticraft Core) requires mod versions [[email protected][12.18.2.2171,)] to be available
[11:07:55] [Client thread/ERROR] [FML/]: net.minecraftforge.fml.common.MissingModsException: Mod galacticraftcore (Galacticraft Core) requires [[email protected][12.18.2.2171,)]"

So now I will individually add all the mods back and see if they are just needing a different version of Forge

Share this post


Link to post
Share on other sites

So, each mod that "needed another mod" actually just required a different version of forge, so I incrementally upgraded forge starting with the oldest version required and working my way up to the newest version required. Now it works with all the mods. So apparently I don't know why this was necessary, but apparently I just needed to use a little magic.

Share this post


Link to post
Share on other sites
23 minutes ago, challenger1_ said:

"[11:07:55] [Client thread/ERROR] [FML/]: The mod galacticraftcore (Galacticraft Core) requires mod versions [[email protected][12.18.2.2171,)] to be available

[11:07:55] [Client thread/ERROR] [FML/]: net.minecraftforge.fml.common.MissingModsException: Mod galacticraftcore (Galacticraft Core) requires [[email protected][12.18.2.2171,)]"

So now I will individually add all the mods back and see if they are just needing a different version of Forge

They usually do. Also this: FML: MCP 9.32 Powered by Forge 12.18.1.2017

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Pouhebert
      Any modpack I try to open at Technic does not open! I've tried several things like -Xmx512 and it still does not work
    • By peterbdude
      Hi so i dont know if this is the right place for this but,
      i made a custom mod pack which is a mix between tekkit and hexxit (never made a mod pack before), and it loads them in phase 1/7 saying "constructing mods" in the mojang screen but as soon as it goes to 2/7 it says "initializing mods phase 1" and crashes with no error message. The modpack is named "NRHS Mod pack" in minecraft version 1.7.10, Idk what to do from here so if someone could figure out why it keeps crashing and comment why i would be soooooo grateful. 
      Mods:
      https://docs.google.com/document/d/1sErCVa1CrChjL7RLfqG73PlQHTmZGaarGqmJZbpP244/view
    • By Thomasmr11
      Hi folks,
      I set up a tekkit legends server and, long story short, when I run the .bat file to launch it, it gets some way through the launch and then just crashes. Below is a copy of the crash report:
       
      http://paste.ubuntu.com/25527703/
       
      So if anyone is able to decipher that and explain whats going on, I would greatly appreciate it.
      Thanks, Tom