• 0
Simpy567

Why won't the technic launcher download on my Mac

Question

Every time I try to download the technic launcher it downloads the jar file then I open it up in downloads right click to open and then it expands the jar file into a folder called 'technic launcher' I went through the folder and there was nothing I could get from it. How do I get it to work someone help?!

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0

I'm having this problem on my MacBook as well. If someone knows how to fix this, it would be greatly appreciated!

Share this post


Link to post
Share on other sites
  • 0
On 2017-06-30 at 1:15 AM, Simpy567 said:

Every time I try to download the technic launcher it downloads the jar file then I open it up in downloads right click to open and then it expands the jar file into a folder called 'technic launcher' I went through the folder and there was nothing I could get from it. How do I get it to work someone help?!

ME TOOO!!!!

Share this post


Link to post
Share on other sites
  • 0

Download and install 64 bit java 8 and then restart your machine.

Do not install java 9.

Share this post


Link to post
Share on other sites
  • 0

I installed 64 bit java 8 and restarted my mac dozens of times but it has just been frozen on the logo.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Presto322
      So I made a custom modpack, but whenever I run it, it doesn't load the mods.
      Here's the dropbox link: https://www.dropbox.com/s/651qofj5ii60ros/mods.zip?dl=0
      Please Help!
      Thanks
    • By Kehlani
      The bug:
      Type of bug: Launcher bug. Reproduction rate: 10/10. Technic launcher keeps crashing on me when I'm in-game due to low memory. It also does lag a decent amount.
      Shader/Resource pack:
      I use shaders and an x32 pixel resource pack. I have the same setup in vanilla Minecraft and it works fine there. Technic will still crash even without a resource pack and shader.
      The issue in detail:
      I can't allocate more than 1gb of memory in the java settings in the technic launcher. I have tried to go to advanced system settings in system and checking out the environment variables. I cannot find "_JAVA_OPTIONS" in there. I can find "C:\Program Files (x86)\Common Files\Oracle\Java\javapath" in the system variables but that's it when it comes to java. I just downloaded technic launcher again after a long time (around 2 years). It used to work fine and I used to be able to allocate way more ram (I believe I used 4GB back then). Technic launcher is updated. My draw distance within minecraft is set to 8. 
      OS and Java version:
      I have an x64 bit operating system. I also have java downloaded for an x64 bit operating system. I have confirmed this by running vanilla Minecraft (not technic) and putting my view distance to far. According to this post  https://goo.gl/bpK4qw , if I had x34 bit java installed it would just give me an error message but that does not happen with me. I have also made sure to download the x64 bit version of java and I have updated it.
      ALL INFORMATION ABOUT COMPUTER SPECS + OS + LOGS + MC 
      System specs:  https://imgur.com/a/ryE71LV
      250gb SSD (60gb free space) + 2TB HDD (650gb free space) (I run technic from my HDD). 750W PSU. Windows and my graphics card driver is updated.
      LOG: I tried pasting the log into paste.ubuntu and pastebin but the log is too large and my browser can't handle it (the file size is 25MB). I pasted quite a bit of the end of the log. Sorry but that's the best I can do here and hopefully, it will provide some information of importance: https://paste.ubuntu.com/p/ZFGmBvcqh2/
    • By bigtruck35
      I've been trying to get technic to run on my computer for a couple months on and off, for some reason I can never get the .exe file downloaded off the platform to run. I've tried messing with Java and my own computer settings some but I can't find the issue. I also tried checking the FAQs to see if it was there bud found nothing. Here are my computer specs:
      Asus Vivobook Pro
      Windows 10
      Intel Core i7-67000HQ CPU - 2.60GHz
      8.00 GB RAM
      Any help would be amazing, 
      Thanks, Bigtruck35
       
    • By Crystogon
      So I've been trying to open the technic launcher but it won't load past the logo.