CalamityJane

Custom modpack only loads vanilla minecraft .jar

3 posts in this topic

Hopefully this is the right place to post this.

I'm completely befuddled as to what might be going on. I've created a custom modpack, which I've done before (not for a few months, maybe I've forgotten some key step). I'm hosting the files on dropbox. A link to the modpack is below. 

Here is what happens when I install the modpack:

* It installs fine, but if I look in the directories the bin directory has minecraft.jar which appears to be the vanilla jar, and a directory called jar has my custom jar in it (this is my forge jar). The modpacks I've created previously put the custom.jar file in the bin directory, it looks like. So I'm not sure what that means.

* When I load it, it only loads vanilla with no mods

* If I move the modpack.jar from the jar directory to the bin directory, Minecraft tries to load with the mods but then crashes after a while with a weird Mekanism error (Mekanism is one of the mods I'm using)

I have the actual modpack installed on my computer and it runs fine.

I experimented with putting modpack.jar in the root directory of my modpack's zip file in addition to the bin directory... doesn't seem to make a difference.

I'm not sure what to try next! Or what the issue is. 

Link to my modpack: http://api.technicpack.net/modpack/quantum-heart

Link to the logs that are created when it loads the vanilla .jar: https://pastebin.com/upeT23K9

Thank you in advance for any help or suggestions!

Share this post


Link to post
Share on other sites

Just wondering if anyone has any advice. I've tried republishing the modpack again as a different modpack, re-uploading my files to dropbox, everything I can think of and nothing works. Vanilla Minecraft keeps launching. The modpack is working on my computer with the same .jar file so I'm not sure what could be wrong.

Share this post


Link to post
Share on other sites
3 hours ago, Stormyweatherian said:

Just wondering if anyone has any advice. I've tried republishing the modpack again as a different modpack, re-uploading my files to dropbox, everything I can think of and nothing works. Vanilla Minecraft keeps launching. The modpack is working on my computer with the same .jar file so I'm not sure what could be wrong.

If you are the same person as Jane -> Rename the "jar" folder to "bin" and you are good to go.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now