Stazio

solder
Solder Plus - A fork of the TechnicSolder

2 posts in this topic

Posted (edited)

Hey there, I'd like to announce to you SolderPlus! A supercharged version of TechnicSolder (fork).

I made SolderPlus because of my frustrations with the original TechnicSolder, and because of how complex it is to setup, limiting the number of people who can use this amazing tool.

SolderPlus overall may not have fixed all of the bugs in the original TechnicSolder, but it did fix a lot of the workflow issues. Most importantly, you can now upload jar files and such without the need to make zip files, or folders!

I have plans to expand upon this further, and add more features, and if enough people want it, a community solder account everyone can use.

Get the latest version here! View the GitHub here!

Edited by Stazio

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Krosta8
      Hello,

      I would like to ask you about something with Technic Solder.

      I have succesfully installed all "perfectly", but I have problem with launcher. When I tried to download the modpack installed on Solder, I got an error "Invalid URL: ". https://ctrlv.cz/lP9S
      {"name":"ModpackName","display_name":"Modpack name","url":null,"icon":"http:\/ Problem is with the section "url":null, which caused the problem, i think. I have no idea, how to repair this.Everything is OK, just this caused problem.
      Here is the error from Technic Launcher console https://ctrlv.cz/ik5g

      Does anyone know, how to repair this? I tried to reinstall Solder, but it didn't help.

      I would be very grateful for any help.

      Thank you,
      Krosta8
    • By Phanta
      It's a nether pack. Expect lava.
      Show me the goods! 🡺
       
    • By AtomikMc
      So I recently got a Solder server and I am currently setting up my modpack with Solder. However, I have run into this issue.

      For some reason, the server returns code 400, but I can access it just fine without any bad request errors.
       
      Log:
      [B#349] net.technicpack.launchercore.exception.BuildInaccessibleException: An error was raised while attempting to read pack info for modpack atomic-season-1, build 1.2.2 (started solder): Server returned HTTP response code: 400 for URL: http://atomikpacks.pcriot.com/technicsolder/public/index.php/api/modpack/atomic-season-1/1.2.2 (started solder)/?cid=fff6e51b-cda1-41c3-9fa5-c7c6882251d0 [B#349] at net.technicpack.solder.http.HttpSolderPackApi.getPackBuild(HttpSolderPackApi.java:76) [B#349] at net.technicpack.solder.io.SolderPackInfo.getModpack(SolderPackInfo.java:149) [B#349] at net.technicpack.launchercore.modpacks.packinfo.CombinedPackInfo.getModpack(CombinedPackInfo.java:197) [B#349] at net.technicpack.launcher.launch.Installer.buildTasksQueue(Installer.java:264) [B#349] at net.technicpack.launcher.launch.Installer$1.run(Installer.java:122) [B#349] at java.lang.Thread.run(Unknown Source) [B#349] Caused by: net.technicpack.rest.RestfulAPIException: Error accessing URL [http://atomikpacks.pcriot.com/technicsolder/public/index.php/api/modpack/atomic-season-1/1.2.2 (started solder)/?cid=fff6e51b-cda1-41c3-9fa5-c7c6882251d0] [B#349] at net.technicpack.rest.RestObject.getRestObject(RestObject.java:157) [B#349] at net.technicpack.solder.http.HttpSolderPackApi.getPackBuild(HttpSolderPackApi.java:70) [B#349] ... 5 more [B#349] Caused by: java.io.IOException: Server returned HTTP response code: 400 for URL: http://atomikpacks.pcriot.com/technicsolder/public/index.php/api/modpack/atomic-season-1/1.2.2 (started solder)/?cid=fff6e51b-cda1-41c3-9fa5-c7c6882251d0 [B#349] at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source) [B#349] at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source) [B#349] at net.technicpack.rest.RestObject.getRestObject(RestObject.java:137) [B#349] ... 6 more  
      Is anyone else experiencing this, and how do I fix it?
    • By PT400C
      Hey,
      today I reinstalled my solder completely. But now, the tab in the browser has no icon.
      Picture:
      https://www2.pic-upload.de/img/32789825/Unbenannt.png
      Does anyone know, how to fix this?
      PT400C
    • By JohnyMuffinYT
      Hello
      I have been trying to setup Solder on a OVH vps running ubuntu 14.04 64-bit
      I have been successful up till it asks you to run the command: (php artisan migrate:install)
      When i try to run the command i get the following error message:
      http://pastebin.com/19zY7tpX
      Any help would be appreciated, thanks.