Thomasmr11

Tekkit Legends server crashes halfway through launch.

5 posts in this topic

Hi folks,

I set up a tekkit legends server and, long story short, when I run the .bat file to launch it, it gets some way through the launch and then just crashes. Below is a copy of the crash report:

 

http://paste.ubuntu.com/25527703/

 

So if anyone is able to decipher that and explain whats going on, I would greatly appreciate it.

Thanks, Tom
 

Edited by EvilOwl
user didn't read the rules

Share this post


Link to post
Share on other sites
13 hours ago, Thomasmr11 said:

Hi folks,

I set up a tekkit legends server and, long story short, when I run the .bat file to launch it, it gets some way through the launch and then just crashes. Below is a copy of the crash report:

Description: Exception in server tick loop

cpw.mods.fml.common.LoaderException: java.lang.NoClassDefFoundError: net/minecraft/client/gui/GuiScreen

So if anyone is able to decipher that and explain whats going on, I would greatly appreciate it.

Thanks, Tom

Ah, so you took the client modpack, and made it into a server huh? Why didn't you take the server pack instead? (You are crashing on the server trying to load clientsided-only mods.)

Share this post


Link to post
Share on other sites

JaariAtmic- Right that explains it. When you put it like that it sounds easy. Where can I find a file with the server mods for this pack? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Simi23
      Hello!
      My problem is the following: I want to make a hexxit server for my friends that I downloaded from technicpack.net, but when I click launch.bat it gives this error code:
      Exception in thread "main" java.lang.ClassCastException: java.base/jdk.internal. loader.ClassLoaders$AppClassLoader cannot be cast to java.base/java.net.URLClass Loader at cpw.mods.fml.relauncher.FMLRelauncher.<init>(FMLRelauncher.java:60) at cpw.mods.fml.relauncher.FMLRelauncher.instance(FMLRelauncher.java:52) at cpw.mods.fml.relauncher.FMLRelauncher.handleServerRelaunch(FMLRelauncher.java:45) at net.minecraft.server.MinecraftServer.main(MinecraftServer.java:1367) What can I do about this? I got the latest Java version.
    • By mjmcasio
      I have been trying to start a tekkit server with an additional mod inside the mod folder. The server does not want to load with the mod inside the mod folder, but when i take it out of the the folder the server works completely fine. I am getting stumped and have been trying to figure out why it wants to crash with the mod inside. the mod is Agent Agriculture, and just adds more crops and 3 mobs, and a few other things. thx
       
    • By EnderBluesGaming
      Alright, heres what's going on. I made my modpack, opened it, opened the server, used hamachi, jumped in, and i went through the creative menu to check out some of the mods, and i went to MC Heli's section and Theres no tanks in the tank menu, no  planes in the planes menu, and no helis in the heli menu. I really need help.
       
      I put a picture below to help you guys figure it out
      -Please help, Ender

    • By Toasti3s
      I was trying to start up my Tekkit server when I got an "Exception in server tick loop" error
      (full error here: https://pastebin.com/2eBy6URK)

      This has happened to two different servers of mine. The servers will start up and work perfectly fine.
      If I shut the server down the try to start it back up again I get nothing but that error.
      I can't find any solutions on how to fix this problem. 
      Thank you for any help!