• 0
Simi23

Hexxit server won't start up

Question

Hello!

My problem is the following: I want to make a hexxit server for my friends that I downloaded from technicpack.net, but when I click launch.bat it gives this error code:

Exception in thread "main" java.lang.ClassCastException: java.base/jdk.internal.
loader.ClassLoaders$AppClassLoader cannot be cast to java.base/java.net.URLClass
Loader
        at cpw.mods.fml.relauncher.FMLRelauncher.<init>(FMLRelauncher.java:60)
        at cpw.mods.fml.relauncher.FMLRelauncher.instance(FMLRelauncher.java:52)

        at cpw.mods.fml.relauncher.FMLRelauncher.handleServerRelaunch(FMLRelauncher.java:45)
        at net.minecraft.server.MinecraftServer.main(MinecraftServer.java:1367)

What can I do about this? I got the latest Java version.

Share this post


Link to post
Share on other sites

1 answer to this question

  • 0
10 hours ago, Simi23 said:

I got the latest Java version.

Which is the issue. You either have Java 9 or 10. You actually may need Java 7 for a Hexxit server.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By mjmcasio
      I have been trying to start a tekkit server with an additional mod inside the mod folder. The server does not want to load with the mod inside the mod folder, but when i take it out of the the folder the server works completely fine. I am getting stumped and have been trying to figure out why it wants to crash with the mod inside. the mod is Agent Agriculture, and just adds more crops and 3 mobs, and a few other things. thx
       
    • By EnderBluesGaming
      Alright, heres what's going on. I made my modpack, opened it, opened the server, used hamachi, jumped in, and i went through the creative menu to check out some of the mods, and i went to MC Heli's section and Theres no tanks in the tank menu, no  planes in the planes menu, and no helis in the heli menu. I really need help.
       
      I put a picture below to help you guys figure it out
      -Please help, Ender

    • By Toasti3s
      I was trying to start up my Tekkit server when I got an "Exception in server tick loop" error
      (full error here: https://pastebin.com/2eBy6URK)

      This has happened to two different servers of mine. The servers will start up and work perfectly fine.
      If I shut the server down the try to start it back up again I get nothing but that error.
      I can't find any solutions on how to fix this problem. 
      Thank you for any help!
    • By ErickThePresident
      Modpack Info:
      Welcome to Omega Adventure Pack page! This modpack is probably the biggest modpack that gives you a variety of options to choose from. If you like adventure, this modpack offers more than 40 dimensions to explore from which include planets, fantasy dimensions and much more. If you are a person into technology, this modpack offers several mods that focus on developing technology. If you enjoy decorating, we got you! We have mods like decocraft and several others that implement numerous ways that you can decorate your Minecraft home. If you enjoy fighting difficult enemies, this is the modpack for you! There are over 40 bosses, ranging from the easiest minibosses to the most difficult opponents. If you enjoy building your own empire, you can do that too! With mods like ancient warfare, you can create your own civilization. This modpack will never cease to disappoint your satisfaction. This modpack is probably one of the biggest that has ever been created. You will need to have at least 7gb of ram to run. Minimum Requirements: i5 2400 at least. To have the best experience you should have i5 4690 or better, and 12gb of ram to be on the safe side.

      Nerfs and Features:
      To prevent an imbalance of mods we have nerfed quite a few things.
      Here is a list of the nerfs:
      -Orespawn is a major component of the modpack and I have nerfed the rareness of the ores and I have weakened some of the weapons. It wouldn't make sense to have weapons that do 40+ damage, in the first place, since the mod pack offers 500+ weapons.
      -OreDictionaryConverter is included in this modpack to facilitate all of the repeated ores that other mods incorporate.
      -Biome configs are all unique, causing no entity spawn glitches.
      -Potion, enchantment, dimension, and other IDS are all unique as well.
      -We have made sure that all these mods are compatible with lan worlds. You can play this modpack with your friends if you would like, just use hamachi to connect.

      Where To Download:
      Here is the link to our tekkit page:
      https://www.technicpack.net/modpack/ericks-insane-adventure-pack.1186950/about

      Want to Support or Give Suggestions?
      Here's our discord link: https://discord.gg/bSeDKSb
      Mod list will be posted on the tekkit page soon!
    • By afchlam
      Hello!
      I have started a custom mod pack with these mods and whenever I load into the server I cannot craft or spawn non-vanilla objects and only vanilla mobs spawn. I have the gravestone mod installed, yet on death, I drop all items and no gravestones appear. Despite this, I can use NotEnoughItems for recipes and all items show up, vanilla and modded, when I use the /give command I cannot TAB and get other mod items through that. Whenever I attempt to spawn in a non-modded item it gives the error 'Item XXXX was not found.' I have looked up countless other places and all I can find is the configuration files are not the same, yet this error still occurs after an estimated 5 trials after copying the configuration files to the server. I have tested the exact same mod pack in survival and it works. Does anyone have any idea how this happens? This has to be an error with something server-side, maybe something is messed up in how I set up the files. I can also see the creative tabs and all of the item textures and even place the item in my inventory, but when I attempt to place it the item disappears from the inventory and does not place.
      I have the start-up batch file run off of the 'minecraft_server.1.7.10.jar ' file, but also tried running the forge file using my script file, which does not do anything, literally. I even attempted to run the 'minecraft_server.1.7.10.jar' file directly without a script file, same result.
      This is the script I have for my start-up script:
       
      Thank you in advance.