fdworkshop

Forge + Liteloader

2 posts in this topic

Hello people,

I already did my searching but came back here without any success.

I created a singleplayer minecraft modpack which runs on Forge+Liteloader. Question is: how can I create an "official" modpack to be uploaded on technick platform?

I'm okay with mods folder, everything works fine if I run it from minecraft loader, but I have no clue what to put inside the "bin" folder in order to make it run...

Any help would be very much appreciated!

This is the zip file containing the .minecraft folder running just fine with all the mods: https://drive.google.com/open?id=1if8UQaLOi9Dpt8S8iDjOm92ntXL1v4q4

Thanks,

F

Edited by fdworkshop

Share this post


Link to post
Share on other sites
3 hours ago, fdworkshop said:

Hello people,

I already did my searching but came back here without any success.

I created a singleplayer minecraft modpack which runs on Forge+Liteloader. Question is: how can I create an "official" modpack to be uploaded on technick platform?

I'm okay with mods folder, everything works fine if I run it from minecraft loader, but I have no clue what to put inside the "bin" folder in order to make it run...

Any help would be very much appreciated!

This is the zip file containing the .minecraft folder running just fine with all the mods: https://drive.google.com/open?id=1if8UQaLOi9Dpt8S8iDjOm92ntXL1v4q4

Thanks,

F

You need 3 main folders: bin, config and mods. Side folders may be things like Flan (Flans mod) or resourcepacks (should be obvious).

The mods folder you got, although you should download all mods from CurseForge.

The config folder should be self-explanatory. Just make sure the configs are actually included.

The bin folder just contains your used version of forge (forge universal) which you rename to "modpack". In case all files have their extensions visible, rename it to "modpack.jar" instead.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Lily5172
      FarmCraftia is a Farming-based Modpack for people looking for a great assortment of mods involving anything to do with Farming & Cultivating, Tech and Machines, Food & Cuisine, Magic & Adventure and Building. It is a great option for Singleplayer or a Multiplayer server, whether it be Creative or Survival with friends. The pack has notable mods such as Pam's Harvestcraft and Forestry for farming, Cooking for Blockheads and Bird's Food for Cooking,  Botania for Magic, Immersive Engineering for Tech, Decocraft  and Mr Crayfishes Furniture Mod for Building, Biomes O Plenty for Biomes, GalacticCraft and Twilight Forest for Adventure, Fun mods such as iChun's Hat Mod and Da Vincis Vessels and many more. FarmCraftia is the right pack for you if you are looking for a great overall Farming and Adventure experience!
      The pack will be updated over time with various new mods to make the experience even more fun.
      Pack Link: https://www.technicpack.net/modpack/farmcraftia.1316248
       
    • By ShrillBear52
      Since i'm able to launch my custom modpack i wanted to do a server as well for me and my friends. But after a few minuet when i join to my server it closes automatically for no reason.
      log:
      https://pastebin.com/14ARTv5f
      Also, the server crashes automatically if i put thaumcraft (1.12.2 version) to the mods folder.
      I would really appreciate any help
    • By sliggybiggy
      So I made a modpack, and it works, however, I also made a server package, that doesn't work.
      I followed some tutorials on the internet and none of them fixed the issue.
      Here's my log

       
    • By JustLisa
      Hi, i have big problem with server.
      Here is my console: 
       
      Console.txt
    • By diniboy
      Hi,
       
      After a few hours of playing I experienced a huge TPS lag on my two player server. If I try to break a block, it appears again... The TPS is usually 0,48... And even the server stopping takes ages...
       
      However in the nether, or even farer from my house everything is okay. How can I debug what block/entity/mod causes this?
       
      My PC is strong enough (I gave it 2-10 GB of RAM) and my Java 8 is 64 bits.
       
      Thanks!