• 0
Peacemaker06

Failed to Download: https://s3.amazonaws.com/Minecraft.Download/versions/1.12.2/1.12.2.jar

Question

I can't seem to find any solution to download minecraft using the Technic Launcher. I have tried disabling my anti-virus software (Kaspersky) and I was able to successfully download the file using the browser. I'm trying to use the mod Lapito's Galacticraft but even the Vanilla version isn't working which is an "Official Technic Modpack". 

 

Please help

 

 

Capture.JPG

Share this post


Link to post
Share on other sites

0 answers to this question

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By itstimeforadventure
      Hey well, I am just posting for a quick fix help.
      I am using a MAC and I do not have access to the actual minecraft launcher. So I use Technic, now I can go on to a server easy with it on vanilla and all but I can't see to join this one server. It says my version is outdated, though I could of sworn it updated 2 days ago when I was using minecraft. I wouldn't know any specifics on how to fix it myself so I was hoping for either, someone to ask me some questions and see if they know what I need to do or they already have seen this problem before.
      Also the server is a friends but it does not have a white list or anything extra to it, the server ping bar say 
      "Craft bukkit 1.7.8 X" to it meaning I can't use it. Then says outdate client, I also tried to redownload Technic.