Suolakeksi

BukkitForge - Getting Bukkit plugins on Tekkit Lite

482 posts in this topic

Hi!

Is Tekkitcustomizer compatible yet? I'm probably doing something wrong, but I'm getting this at server startup:

 

[iNFO] [me.ryanhamshire.TekkitCustomizer.TekkitCustomizer] [TekkitCustomizer] Enabling TekkitCustomizer v1.5.2<br />

[iNFO] [Minecraft] TekkitCustomizer: TekkitCustomizer enabled.<br />

[sEVERE] [bukkitForge] Error occurred while enabling TekkitCustomizer v1.5.2 (Is it up to date?)<br />

java.lang.ClassCastException: we cannot be cast to org.bukkit.inventory.Recipe<br />

at me.ryanhamshire.TekkitCustomizer.TekkitCustomizer.loadConfiguration(TekkitCustomizer.java:126)<br />

at me.ryanhamshire.TekkitCustomizer.TekkitCustomizer.onEnable(TekkitCustomizer.java:96)<br />

at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:217)<br />

at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:457)<br />

at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:390)<br />

at keepcalm.mods.bukkit.bukkitAPI.BukkitServer.loadPlugin(BukkitServer.java:931)<br />

at keepcalm.mods.bukkit.bukkitAPI.BukkitServer.enablePlugins(BukkitServer.java:915)<br />

at keepcalm.mods.bukkit.bukkitAPI.BukkitServer.<init>(BukkitServer.java:265)<br />

at keepcalm.mods.bukkit.asm.BukkitStarter.run(BukkitStarter.java:47)<br />

at java.lang.Thread.run(Thread.java:722)<br /> 

Thank you!

What type of tekkit modpack are you running and what minecraft version are you running the server on? If you could answer these I could more easily help you :)

Share this post


Link to post
Share on other sites

What type of tekkit modpack are you running and what minecraft version are you running the server on? If you could answer these I could more easily help you :)

Sorry. I'm running Tekkit Lite 0.6.5, Minecraft 1.4.7.

Tried this with TekkitCustomizer 1.6 (doesn't seem to be recognized at all) and 1.5.2 (I pasted the error code for this one).

Installed NoLag to check if Bukkitforge was ok - works just fine.

Thanks in advance!

UPD: Problem solved!

Turns out BukkitForge vs. Treecapitator issue was the culprit. Installing BukkitForge build 252 helped.

Share this post


Link to post
Share on other sites

I keep getting this when i run my game. I'm running it on 0.6.5 server files off the tekkit lite official page. any ideas what's going on? it gets stuck at that...

cp2p.jpg

Share this post


Link to post
Share on other sites

OS: Indows 7 64-bit

home hosted server

Java version: 7 update 25

Tekkit lite version: 0.6.5 direct from official website. (also tried with 0.6.1 with equal results)

BukkitForge version: multiple versions of 1.4.7 builds attempted. current build is 245 as it was discovered treecapitator has problems with build 246 and up

What did you add to the basic tekkit lite folders? bukkitforge inside the coremods folder, essentials and worldedit (version 5.5.5 at the moment) inside the plugins folder made in the root folder

The problems:

Server starts normally.

Nothing from essentials and worldedit shows up or is usable in game.

Every World edit command returns "Unknown command. Try /help for a list of commands."

/help returns the following:

ban, ban-ip, banlist, buildcraft help, ccdebug help, clear, cofh, debug, defaultgamemode, delete_all_links, delete_dim_data, delete_rifts, deop, difficulty, dimanc, ee3, enchant, f, freq help, gamemode, gamerule, give, help, kick, kill, list, logisticspipes help, me, myst-agebook, myst-create dimId, myst-permissions, myst-toggleworldinstability, namesculpture, op, pardon, pardon-ip, prune_pocket_dims, save-all, save-off, save-on, say, seed, spawnpoint, stop, tell, time, time, toggledownfall, tp, tpx, weather, whitelist, xp

/plugins returns an unknown command

trying various builds of bukkitforge does nothing

im stuck trying to figure this out :/

Share this post


Link to post
Share on other sites

This is odd. I can get the server to online status from the server's point of view but I can't actually log in (shows as offline in the launcher). It's a remote server running Java 7 with 0.6.5 and Bukkit 253. As I just testing to make sure I could log in without plugins first nothing else has been added. Any thoughts?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now