Sign in to follow this  
Followers 0
darkhoernchen

How to convert Tekkit Classic world to Tekkit lite !

193 posts in this topic

The IC2 Problem is this:

Old:

Block. Name: ic2.common.BlockBarrel. ID: 217

Block. Name: tile.blockCrop. ID: 218

Block. Name: tile.blockLuminatorD. ID: 219

Block. Name: tile.blockScaffold. ID: 220

Block. Name: tile.blockWall. ID: 221

Block. Name: tile.blockFoam. ID: 222

Block. Name: ic2.common.BlockMachine2. ID: 223

Block. Name: ic2.common.BlockMetal. ID: 224

Block. Name: ic2.common.BlockPersonal. ID: 225

Block. Name: tile.blockLuminator. ID: 226

Block. Name: ic2.common.BlockElectric. ID: 227

Block. Name: ic2.common.BlockCable. ID: 228

New:


Block. Name: ic2.core.block.BlockBarrel. ID: 217

Block. Name: tile.blockCrop. ID: 218

Block. Name: tile.blockLuminatorD. ID: 219

Block. Name: tile.blockScaffold. ID: 220

Block. Name: tile.blockWall. ID: 221

Block. Name: tile.blockFoam. ID: 222

Block. Name: ic2.core.block.machine.BlockMachine2. ID: 223

Block. Name: ic2.core.block.BlockMetal. ID: 224

Block. Name: ic2.core.block.personal.BlockPersonal. ID: 225

Block. Name: tile.blockLuminator. ID: 226

Block. Name: ic2.core.block.wiring.BlockElectric. ID: 227

Block. Name: ic2.core.block.wiring.BlockCable. ID: 228

You should fix it manually

Rename it in the old or the new file... (or both)

or search and replace in both files like this:

ic2.core.block.machine.BlockMachine2. = ic2.BlockMachine2.

I try to fix this problem into a new version.

Share this post


Link to post
Share on other sites

Hey Folks!

I was (or am) very excited to see this option. I *really* would rather not lose my world. I've followed the directions quite closely. I'm using miDas to try and convert my multiplayer server. When I select my "world" folder and attempt to start the conversion it says that there is an error and a log has been created. I cannot locate this log. Since, I have noticed that when I add the "world" savegame it shows up in red in the list.

Does anyone have any ideas? I've also tried "nether" and "the end" with both the same results. I'm using the versions of patch.txt and miDas gold that are the latest I can find.

Thanks!

Share this post


Link to post
Share on other sites

When i try to start the jar by clicking it , nothing happens , when I use the command given in the README file a cmd window opens and still no buttons appear , how exactly do I open the mIDasGold.0.2.3.jar file ?

Share this post


Link to post
Share on other sites

To anyone getting the Error message ""An error has occurred and a log has been created." No matter what you do, I managed to fix this really really easily, it seems to be a problem with the "add world" function. The simple way to fix this problem is to do the following:

1) Copy your Server "World" folder (nothing else is needed)

2) Go to your .minecraft folder in your app data (sorry non windows users I don't know where this is for you guys/gals).

3) Paste the server world folder in the saves folder. Rename as appropriate in order not to screw over your single player worlds.

4) Reopen the conversion app, you should now be able to use the drop down list and see your world. Select it.

5) Follow the original instructions as stated above and your world will convert.

6) Copy your newly converted world folder and paste it into your server (I found it best to put this in a clean server install)

Note you MAY lose one or two items you are carrying but everything in the boxes are there. Hope this helps.

Share this post


Link to post
Share on other sites

To anyone getting the Error message ""An error has occurred and a log has been created." No matter what you do, I managed to fix this really really easily, it seems to be a problem with the "add world" function. The simple way to fix this problem is to do the following:

1) Copy your Server "World" folder (nothing else is needed)

2) Go to your .minecraft folder in your app data (sorry non windows users I don't know where this is for you guys/gals).

3) Paste the server world folder in the saves folder. Rename as appropriate in order not to screw over your single player worlds.

4) Reopen the conversion app, you should now be able to use the drop down list and see your world. Select it.

5) Follow the original instructions as stated above and your world will convert.

6) Copy your newly converted world folder and paste it into your server (I found it best to put this in a clean server install)

Note you MAY lose one or two items you are carrying but everything in the boxes are there. Hope this helps.

Thanks, I will see what the problem is.

Share this post


Link to post
Share on other sites

Thanks, I will see what the problem is.

When I open the mIDasGold.jar this is what is printed in a cmd screen

C:\Users\Jigsaw\Downloads\mIDasGoldv0.2.3 (1)>java -jar mIDasGold.jar

Exception in thread "main" java.lang.NullPointerException

at com.sun.java.swing.plaf.windows.XPStyle.getTypeEnumName(Unknown Sourc

e)

at com.sun.java.swing.plaf.windows.XPStyle.getBorder(Unknown Source)

at com.sun.java.swing.plaf.windows.WindowsLookAndFeel$XPBorderValue.getX

PValue(Unknown Source)

at com.sun.java.swing.plaf.windows.WindowsLookAndFeel$XPValue.createValu

e(Unknown Source)

at javax.swing.UIDefaults.getFromHashtable(Unknown Source)

at javax.swing.UIDefaults.get(Unknown Source)

at javax.swing.MultiUIDefaults.get(Unknown Source)

at javax.swing.UIDefaults.getBorder(Unknown Source)

at javax.swing.UIManager.getBorder(Unknown Source)

at javax.swing.border.TitledBorder.getBorder(Unknown Source)

at javax.swing.border.TitledBorder.getBorderInsets(Unknown Source)

at javax.swing.border.AbstractBorder.getBorderInsets(Unknown Source)

at javax.swing.JComponent.getInsets(Unknown Source)

at javax.swing.BoxLayout.preferredLayoutSize(Unknown Source)

at java.awt.Container.preferredSize(Unknown Source)

at java.awt.Container.getPreferredSize(Unknown Source)

at javax.swing.JComponent.getPreferredSize(Unknown Source)

at java.awt.BorderLayout.preferredLayoutSize(Unknown Source)

at java.awt.Container.preferredSize(Unknown Source)

at java.awt.Container.getPreferredSize(Unknown Source)

at javax.swing.JComponent.getPreferredSize(Unknown Source)

at javax.swing.JRootPane$RootLayout.preferredLayoutSize(Unknown Source)

at java.awt.Container.preferredSize(Unknown Source)

at java.awt.Container.getPreferredSize(Unknown Source)

at javax.swing.JComponent.getPreferredSize(Unknown Source)

at java.awt.BorderLayout.preferredLayoutSize(Unknown Source)

at java.awt.Container.preferredSize(Unknown Source)

at java.awt.Container.getPreferredSize(Unknown Source)

at java.awt.Window.pack(Unknown Source)

at pfaeff.IDChanger.<init>(IDChanger.java:110)

at pfaeff.IDChanger.main(IDChanger.java:660)

Share this post


Link to post
Share on other sites

When I open the mIDasGold.jar this is what is printed in a cmd screen

...

Thanks although please don't copy paste stack traces into forum threads, use pastebin.

What version of java do you have?

Share this post


Link to post
Share on other sites

Thanks although please don't copy paste stack traces into forum threads, use pastebin.

What version of java do you have?

java version "1.7.0_09"

Java SE Runtime Environment (build 1.7.0_09-b05)

Java HotSpot Client VM (build 23.5-b02, mixed mode, sharing)

Share this post


Link to post
Share on other sites

java version "1.7.0_09"

Java SE Runtime Environment (build 1.7.0_09-b05)

Java HotSpot Client VM (build 23.5-b02, mixed mode, sharing)

I would suggest reinstalling Java. What OS are you using?

Share this post


Link to post
Share on other sites

I'm at a loss, here.

Been trying to convert my Tekkit Classic world to Lite.

http://pastebin.com/G1Y40JPP

That's a link to my error report. I've tried every fix so far in this thread, but, same result! Server seems to boot fine, but as soon as I log in the world is empty and I just fall to -1,0, and the server runs this error.

Any suggestions?

Share this post


Link to post
Share on other sites

Does anyone have a solution to the invisible pipes yet????

Its really annoying, the server I run cant yet update/convert to lite because everyone would lose their complex pipe systems. Considering getting everyone to break them down for now, then rebuild after converting to lite... But that would be a pain for many players and not something I really want to ask them to do. A proper solution should be made available.

Also! For those having the issue with mIDas not doing anything when the start button is pressed or making an error report at some undisclosed location - run mIDas with 32bit Java, NOT 64bit.

I had the same issue (64bit W7), was about to give up and thought Id manually start the program forcing it to use 32bit, and it worked straight away as Id expected it to initially.

Share this post


Link to post
Share on other sites

Does anyone have a solution to the invisible pipes yet????

Its really annoying, the server I run cant yet update/convert to lite because everyone would lose their complex pipe systems. Considering getting everyone to break them down for now, then rebuild after converting to lite... But that would be a pain for many players and not something I really want to ask them to do. A proper solution should be made available.

Also! For those having the issue with mIDas not doing anything when the start button is pressed or making an error report at some undisclosed location - run mIDas with 32bit Java, NOT 64bit.

I had the same issue (64bit W7), was about to give up and thought Id manually start the program forcing it to use 32bit, and it worked straight away as Id expected it to initially.

And how do i run it in 32 bit.

Share this post


Link to post
Share on other sites

My OS is 32 bit operating in Windows 7.

And how do i run it in 32 bit.

You must be running it in 32 bit if your OS is 32 bit.

Share this post


Link to post
Share on other sites

I have a multiplayer tekkit classic world that i have tried to covert to tekkit lite. I have followed the instructions but it simply doesn't work, when i try to join my server I get an internal server error, any help ?

Share this post


Link to post
Share on other sites

You must be running it in 32 bit if your OS is 32 bit.

Well , I am running it then in 32 bit and it still will print the error I posted previously,.

Share this post


Link to post
Share on other sites

Well, I've understood everything in a blink of an eye, if there are convert errors i could fix them myself but I've got another problem, it gives an error and said it made an errorlog, uhm where?

Share this post


Link to post
Share on other sites

For me i have issues with some parts of my map

After running this convert it will load for a couple of seconds

Afterward it gives me a crash screen with errors about something with redpower or mk3 collectors

My map is from my tekkit server and has lots of redpower items/pipes

many players play on it and i was trying to find out if it could be converted to tekkit lite

Share this post


Link to post
Share on other sites

Worked Excellently for me!

Downloaded Midas and Patch.txt, loaded in my world file and it converted fine, then loaded my nether and that converted fine. Downloaded the Tekkit Server Lite package, copied across my world files ran the server and logged in no issue. Yes, buildcraft pipes are still invisible, and one or two items in NEI are invisible or unnamed, but this method does work. Don't forget to stop the server then re copy your permissions and other configs you may need :)

Share this post


Link to post
Share on other sites

When I open the mIDasGold.jar this is what is printed in a cmd screen

C:\Users\Jigsaw\Downloads\mIDasGoldv0.2.3 (1)>java -jar mIDasGold.jar

Exception in thread "main" java.lang.NullPointerException

at com.sun.java.swing.plaf.windows.XPStyle.getTypeEnumName(Unknown Sourc

e)

at com.sun.java.swing.plaf.windows.XPStyle.getBorder(Unknown Source)

at com.sun.java.swing.plaf.windows.WindowsLookAndFeel$XPBorderValue.getX

PValue(Unknown Source)

at com.sun.java.swing.plaf.windows.WindowsLookAndFeel$XPValue.createValu

e(Unknown Source)

at javax.swing.UIDefaults.getFromHashtable(Unknown Source)

at javax.swing.UIDefaults.get(Unknown Source)

at javax.swing.MultiUIDefaults.get(Unknown Source)

at javax.swing.UIDefaults.getBorder(Unknown Source)

at javax.swing.UIManager.getBorder(Unknown Source)

at javax.swing.border.TitledBorder.getBorder(Unknown Source)

at javax.swing.border.TitledBorder.getBorderInsets(Unknown Source)

at javax.swing.border.AbstractBorder.getBorderInsets(Unknown Source)

at javax.swing.JComponent.getInsets(Unknown Source)

at javax.swing.BoxLayout.preferredLayoutSize(Unknown Source)

at java.awt.Container.preferredSize(Unknown Source)

at java.awt.Container.getPreferredSize(Unknown Source)

at javax.swing.JComponent.getPreferredSize(Unknown Source)

at java.awt.BorderLayout.preferredLayoutSize(Unknown Source)

at java.awt.Container.preferredSize(Unknown Source)

at java.awt.Container.getPreferredSize(Unknown Source)

at javax.swing.JComponent.getPreferredSize(Unknown Source)

at javax.swing.JRootPane$RootLayout.preferredLayoutSize(Unknown Source)

at java.awt.Container.preferredSize(Unknown Source)

at java.awt.Container.getPreferredSize(Unknown Source)

at javax.swing.JComponent.getPreferredSize(Unknown Source)

at java.awt.BorderLayout.preferredLayoutSize(Unknown Source)

at java.awt.Container.preferredSize(Unknown Source)

at java.awt.Container.getPreferredSize(Unknown Source)

at java.awt.Window.pack(Unknown Source)

at pfaeff.IDChanger.<init>(IDChanger.java:110)

at pfaeff.IDChanger.main(IDChanger.java:660)

Come on guys , when will you assist me? I have a server to upgrade.

Share this post


Link to post
Share on other sites

Thanks for this software :) !

Do you have an issue to launch your software on a Linux command line ?

I can download my map, but it size is more than 2 Go. If i convert it on my computer, i cannot upload it to the server (very shot Internet connexion).

Thanks.

Share this post


Link to post
Share on other sites

At everyone getting an error from mIDas, try removing your computer craft folder and RailCraft.jar. I was getting an error and removing those two things seems to have fixed it, although I'm not sure which one was the main issue. Of course every computer is different so this little work around might not work for everyone.

*Edit: Just did another conversion and it seems like RailCraft is one of/the problem. Don't know why, but that's the conclusion I've come to.

Share this post


Link to post
Share on other sites

So let me sum this up... unless I get some weird error and don't mind invisible pipes it's now possible to convert a Classic world to Lite?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0