Stone Rhino

Lagging out or crashing on joining? Try these steps

32 posts in this topic

Hello all you diggers and tree punchers!

I'd like to offer up a few suggestions for folks having the dreaded FPS drops and random crashes.

CanVox has pointed out that PermGen size option needs to be enabled in the launcher. Also suggested multiple times is the allocation of more RAM to the game. 2GB or more is highly recommended.

Hopefully the image here will give you a hand with this. You can get here by clicking the gear in the upper right corner, left of the red X box.

lj1Ok7l.png

The launcher will not allow you to allocate all available RAM installed in the machine. If you have exactly 2GB of ram, it will limit you to 1GB to 1.5GB depending on your machine. If you have 4GB, it will limit you to 3GB, and so on.

Enabling "Increase PermGen Size" has allowed me to finally play. Despite running on a 24 core Intel Xeon workstation with 48GB of RAM, this baffled me how it could simply run out of memory at 2GB of 16 allocated.

Enabling increase permgen also needs to be set server side as well or you will notice random crashing etc. on your server as you do with your client.

To enable this server side add "-XX:MaxPermSize=256M" (no quotes) to your startup batch file.

I hope this helps!

--EDIT--

If this doesnt help you, then make a thread and pastebin your logs.

Share this post


Link to post
Share on other sites

I kept forgetting to make a thread like this, so now you get to be forums-famous.

I'll leave this thread open for discussing the contents of the OP, but I'm gonna heavily infract anyone who just comes in here with random crash problems. Start your own thread for that stuff.

Share this post


Link to post
Share on other sites

I've found that anything more then 2GB is unnecessary and can actually degrade performance, this experience is from my private pack with 130+ mods on a server with about 15+ active members.

Really 1.5GB - 2GB seems to be the sweet spot even if you have 16GB+ memory in your system.

Enabling increase permgen also needs to be set server side as well or you will notice random crashing etc. on your server as you do with your client.

To enable this server side add "-XX:MaxPermSize=256M" (no quotes) to your startup batch file.

Share this post


Link to post
Share on other sites

If you're limited to 1.5GB of RAM (may be 1GB with the new launcher), you may have 32bit Java. There is no solution to this for 32bit computers, but if you have 32bit Java on a 64bit computer, consider switching to 64bit Java to use more RAM.

Just don't go overboard - too much RAM allocated can be just as detrimental to performance as too little. Try to stay below 5 maximum. 1.5 to 2GB is usually fine, and 3GB won't cause much problems.

Share this post


Link to post
Share on other sites

Correct, even in other mods via tekkit, I've had to cap the RAM at 3-4GB. So far, running great now for 1 hour!

Share this post


Link to post
Share on other sites

Thanks for this thread, it helped me a lot! I went from unplayable lag to no lag at all by switching to 64 bit Java and clicking the Permasize option.

Share this post


Link to post
Share on other sites

If you're like me and have plenty of RAM like a sheep farm (64bit only, mind you,) a good rule of thumb is to allocate no more than half your memory to Technic. Under certain hardware configurations, you can go right up to 75%, but that's pushing it as Java needs to flush its garbage collection regularly while running MC.

Share this post


Link to post
Share on other sites

To enable this server side add "-XX:MaxPermSize=256M" (no quotes) to your startup batch file.

Now, where would one put this in the launch.bat file? above the pause line?

Share this post


Link to post
Share on other sites

You would paste that inline, like this:

java -XX:MaxPermSize=1024M -Xmx8G -jar BigDig.jar nogui --log-limit 100000

I've increased the permgen size out of testing purposes. Please retain the 256M size

Share this post


Link to post
Share on other sites

You would paste that inline, like this:

java -XX:MaxPermSize=1024M -Xmx8G -jar BigDig.jar nogui --log-limit 100000

I've increased the permgen size out of testing purposes. Please retain the 256M size

Much appreciated. Thank you!

Share this post


Link to post
Share on other sites

That's only for a server Lucas. If you open the launcher and hit the little gear symbol at the top right there will be a checkbox and it says "Increase Perm Gensize" check that box and it'll be enabled.

Share this post


Link to post
Share on other sites

I have a 32bit operating system and 4GB of ram. I'm not able to go over 1GB on the settings. I recently completely wiped my computer. Before I did, I could run the technic pack excellently. After wiping and re-downloading I started playing big dig and it's slowly gotten worse as i continue to play it. I literally get 5-10 fps if I'm lucky.

Share this post


Link to post
Share on other sites

Hey, sorry to bother this thread but-

-I've Allocated 4 gigs(running 64bit system)

-Turned on permgen

-Switched to Java 64-bit on my computer

-I've even replaced the modpack url with this one supplied, but that didn't work

-Turned off firewall for 15mins (mcafee)

And I still keep getting a white screen.

I'm thinking this has something to do with LWJGL...

EDIT-Tried it again today, an as I'm waiting for it to load while watching the console, I'm seeing warnings about a LOT of missing textures.

And it just froze up again, I'm getting the log file on here so someone can tell me what'sgoing on.

EDIT-Fixed, turns out i can only run the latest build, not 1.3.9

Share this post


Link to post
Share on other sites

Jester2799. It is because Minecraft runs an internal server. Basically it runs a server just for you unless you open it to LAN. (Someone feel free to correct me if I am wrong.) Also not sure what the PermGen setting did but it allowed me toopen up my single player worlds again. Thanks!

Share this post


Link to post
Share on other sites

I've tried everything suggested here, and I'm still getting crashes as soon as I open a world. Here's the crash report I'm getting:

For some reason it seems to think that I'm playing multiplayer even though I'm playing singleplayer...

This seems to be happening with the tessellation crash for quite a few people. Try joining without any texture packs loaded.

Share this post


Link to post
Share on other sites

This seems to be happening with the tessellation crash for quite a few people. Try joining without any texture packs loaded.

im getting pretty much the same problem, but in mulltiplayer, only one one specific server, i tried to silver in a smelting machine, and ever since then my game dies

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now