GenPage

MCPC
Spigot/MCPC Server Bug

16 posts in this topic


 
Credit to Kobata for noticing and informing me of the tweet.
 
This is an issue that affects Spigot which is built into MCPC-Plus
 
This has been fixed in Spigot: http://www.spigotmc.org/threads/arrayindexoutofboundsexception.14826/
 
Just waiting on MCPC now.

 

The error that crashes your server will be a 

java.lang.ArrayIndexOutOfBoundsException

 
I will be following this closely as many seem to be having issues with players joining your servers.

 

UPDATE:

 

Build #251 of MCPC-Plus is now recommended. 

 

http://ci.md-5.net/job/MCPC-Plus-164/251/

 

Download this new jar, replace, restart

Edited by GenPage
Update - Fixed

Share this post


Link to post
Share on other sites

Im using the version you recommended, but then it fixed it only giving me a "failed to bind port error", but after a few times of turning on and off my server, the java.lang.ArrayIndexOutOfBoundsException: 4100 

 

This all started when two mods i was running on my server had an id confilct, i changed one of the id's to 4188888, and it gave me the java.lang.ArrayIndexOutOfBoundsException: 4188888 error. So i changed it to 4100 thinking that it was too much or something, and it still didnt work, i tried your recommendation, but it came back, and now it wont stop occuring no matter how many times i restart my server. Anyway i can solve this? And is there a way i would be able to fix the "Failed to bind port error?" here is the java.lang.ArrayIndexOutOfBoundsException: 4100 error: http://pastebin.com/9yhaPcDt

 

Please help.

Share this post


Link to post
Share on other sites

Oh, my. This belongs in Server Op Swap Shop. The bind port error is because you have an orphaned Java process still running. Bring up your task manager and kill it. The Index Out Of Bounds is because the highest worldgen block ID you can use is 4095.

Share this post


Link to post
Share on other sites

Ok, well those problems dont seem to be occuring anymore, but now i keep getting this new error: http://imgur.com/kCedfYQ

These are one of those errors that arent saved onto a file, so the only way to show them is through a picture. ^^^^^^^^^^

Share this post


Link to post
Share on other sites

Nevermind, i fixed it. But i need the mcpc+ 1.6.2 version (the 1.6.4 version is incompatible with turninator's95 moonquest modpack) but the webpage gives me a http 404 error when i go to it. Was the webpage moved? Or removed?

Share this post


Link to post
Share on other sites

If you are having troubles please start a new thread. I do not feel comfortable having a irrelevant conversation in a sticky forum post.

Share this post


Link to post
Share on other sites

The link is broken.

 

Too true. The MCPC+ project has been renamed to Cauldron and has a new dedicated website for both 1.6.4 and 1.7.2 versions:

 

Website: http://cauldron.minecraftforge.net/

 

Cauldron 1.6.4/1.7.21.7.10: http://files.minecraftforge.net/Cauldron/

 

MCPC+ 1.5.2: http://ci.md-5.net/job/MCPC-Plus-Legacy/

 

Please note that most versions now require the use of the installer in order to get the libraries and minecraft_server.jar as they no longer automatically get those on first startup.

Edited by plowmanplow

Share this post


Link to post
Share on other sites

Too true. The MCPC+ project has been renamed to Cauldron and has a new dedicated website for both 1.6.4 and 1.7.2 versions:

 

Website: http://cauldron.minecraftforge.net/

 

Cauldron 1.7.2: http://files.minecraftforge.net/Cauldron/

 

Cauldron 1.6.4: http://ci.md-5.net/job/CauldronLegacy/

 

Please note that both versions now require the use of the installer in order to get the libraries and minecraft_server.jar as they no longer automatically get those on first startup.

 dammit those links are 404s as well D: why does the minecraft community take away everything we need?

Share this post


Link to post
Share on other sites

First two are not, gun, third one is since they no longer host their files on md-5.net.....did you even bother trying...

Share this post


Link to post
Share on other sites

 

Credit to Kobata for noticing and informing me of the tweet.

 

This is an issue that affects Spigot which is built into MCPC-Plus

 

This has been fixed in Spigot: http://www.spigotmc.org/threads/arrayindexoutofboundsexception.14826/

 

Just waiting on MCPC now.

 

The error that crashes your server will be a 

java.lang.ArrayIndexOutOfBoundsException

 

I will be following this closely as many seem to be having issues with players joining your servers.

 

UPDATE:

 

Build #251 of MCPC-Plus is now recommended. 

 

http://ci.md-5.net/job/MCPC-Plus-164/251/

 

Download this new jar, replace, restart

 

You might want to update to remove that link. Due to the DMCA that link is no longer valid and I think anyone using MCPC, or any other "bukkit" based server is in limbo for now. Hopefully the mod dev's will see our pain and spigot 1.8 will rock.

 

 Apparently they disabled access to the second link as well.

Edited by CharZinta

Share this post


Link to post
Share on other sites

You might want to update to remove that link. Due to the DMCA that link is no longer valid and I think anyone using MCPC, or any other "bukkit" based server is in limbo for now. Hopefully the mod dev's will see our pain and spigot 1.8 will rock.

 

 Apparently they disabled access to the second link as well.

 

The ONLY problem I have with spigot is no forge based Mods. So you get Plugin's or Mods. Cauldron was the perfect solution till the DMCA. Now we all wait in purgatory hoping something comes along.  I like some of the talk on Sponge but some comments are good and some concern me. I won't cross link in here but you can google it :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By afchlam
      Hello!
      I have started a custom mod pack with these mods and whenever I load into the server I cannot craft or spawn non-vanilla objects and only vanilla mobs spawn. I have the gravestone mod installed, yet on death, I drop all items and no gravestones appear. Despite this, I can use NotEnoughItems for recipes and all items show up, vanilla and modded, when I use the /give command I cannot TAB and get other mod items through that. Whenever I attempt to spawn in a non-modded item it gives the error 'Item XXXX was not found.' I have looked up countless other places and all I can find is the configuration files are not the same, yet this error still occurs after an estimated 5 trials after copying the configuration files to the server. I have tested the exact same mod pack in survival and it works. Does anyone have any idea how this happens? This has to be an error with something server-side, maybe something is messed up in how I set up the files. I can also see the creative tabs and all of the item textures and even place the item in my inventory, but when I attempt to place it the item disappears from the inventory and does not place.
      I have the start-up batch file run off of the 'minecraft_server.1.7.10.jar ' file, but also tried running the forge file using my script file, which does not do anything, literally. I even attempted to run the 'minecraft_server.1.7.10.jar' file directly without a script file, same result.
      This is the script I have for my start-up script:
       
      Thank you in advance.
    • By Henrikero
      Hi, I was wondering if anyone wanted to create a small tekkit classic server together with me. Just a plain simple little community where we build stuff and have fun?
       
    • By zDorg4d0
      When I try to open a modpack the technic closes and after a while it opens again. Any solution?


       
    • By drinkmybritishtears
      I'm not sure if this is under the right topic, but-
      Ever since I updated my laptop, the Minecraft Diaries mod-pack crashes after 2/7 (Phase 1), before that it was fine and ran well. I've tried re-installing the pack and the technic launcher itself, nothing new has happened and I'm not sure what to do.
      (I'm not sure if it counts as a custom seen as i myself didn't make it, but I think it's fan-based)
      ((MOD-PACK -- https://www.technicpack.net/modpack/tribute-to-aphmau.722351/about ))
       
    • By BladefuryDev
      The Technic Launcher seems to crash every time I try to access the "Modpack Options".  Here is the error log the launcher generates after closing itself.
      Crash Log - Pastebin
      GIF of the problem