Skuli

Let's Test Hexxit for Minecraft 1.7.10!

Recommended Posts

battletowers are screwed up, theres no loot. whenever i go to the desert like 80 pharoahs spawn. betterdungeons dont spawn. extrabiomesXL bibliocraft items need FIRE BLOCKS to craft. thats just some of the bugs

Edited by robbyguy100

Share this post


Link to post
Share on other sites

Ok, so I've been having an issue that I think I have narrowed down to a crash of a survival character on the server thanks to spawners in the castles. I made it most the way through without an issue but now I have to delete my character's profile on the server once I get 80% through the castle or I can't even log in anymore. Going to the area in creative mode seems to be fine but if I go back to survival it's not long before I'm booted without an error code. Does anyone have a fix for this? I tried to update Waila but is 1.5.5 the newest or is this a new problem? Any help is appreciated.

 

Share this post


Link to post
Share on other sites

I doubt I'll be adding any more mob mods to the pack; it's tough enough balancing spawning rules with just the ones that are already here!

 

Well, except the chocobo mod; clienthax has taken over that and it'll be added to the next update.

Share this post


Link to post
Share on other sites

I don't know if anyone can help or point me in the right direction, but I pay for a minecraft server through Apex Minecraft hosting and I would love to get this Beta running on it for testing.  But, their servers require jar files to be in a jar folder and well a certain folder structure and try as I might, I am not able to get the server to run.  It crashes very early in the loading phase.  Any help is appreciated.

 

Skuli - THANK YOU SO MUCH for putting all this work into updating this mod pack.  I recently found Hexxit and we are loving it immensely and are chomping at the bit to play the new incarnation. 

 

Thanks!!

Share this post


Link to post
Share on other sites

Hey all. We've been having a lot of fun playing Hexxit with the kids and friends, first on 1.0 and now on 3.0b and c. I like the additional difficulty, but definitely seeing some bugs.

- (already mentioned) Mummy Pharaoh bug, there's about 75 of them out there in the desert.

- (already mentioned) Unable to shoot tinker's bows.

- Client crash bug when a tool auto-replaces due to wear when in the dual-wield slots.

- (already mentioned) In default setup, both sorting and switching between regular and dual-wield slots are bound to "R".

- (already mentioned) Shovels dig dirt and gravel instantly (may have to do with miner class), but digging dirt with grass on it is normal. Digs so fast its hard to get just 1 block.

 

The big one that I am trying to figure out is that we're not getting any non-vanilla loot, period. Chests, mobs, anywhere. No meteor material items, nothing from Infernal rare mobs, chocolate quest chests, nada. Mostly food in those chests. I haven't seen a battle tower yet (surprisingly) but i hear those are empty anyway. I'm looking into it and would be happy to help debug, I have the java. Let me know if you have any ideas.

 

EDIT: Copying the LycanitesMobs directory contents to the lycanitesmobs directory (linux) seems to have restored some balance to mobs and loot looks like its working now as well.

Edited by blats

Share this post


Link to post
Share on other sites

I have noticed you have to have regular arrows in your inventory to fire tinker's construct arrow from the tinker's bow, idk why.

Updating mount and blade seems to fix some bugs involving dual wield but I think Technic won't help support mod packs with added mods.

Finally I can also confirm the  no non-vanilla loot issue let me know if anyone has a fix cause if I kill another 500 hp super named lobber with wither to receive sub-par loot I think I will cry. However maybe  we were just spoiled by 1.0.   

Share this post


Link to post
Share on other sites

Where are the 3 hexxit armors? (scale, thief,...)

i miss them :(

Why aren't they included in 3.0?

some mods are not yet updated to MC 1.7x

the hexxit armours are Sct's mod, I'm guessing that he's busy developing the new Platform and Launcher.

Share this post


Link to post
Share on other sites

My girlfriend has had a few times while we've been playing where she'll connect to the server and find that it has reverted her character, sometimes back hours. It also just happened to her in a single player game, and in that case, it rolled the whole world back. Has anyone else had this happen?

Share this post


Link to post
Share on other sites

My friends and I have encountered a bunch of other issues with this 3.0.0c beta release after playing for several days.

 

- What we have dubbed the "Concapede invasion".  Not sure what the trigger is, there's no errors per se but every now and then, there's a huge amount of non-stop concapedes spawning around our little home made town.  The first time I had to use /cofh killall concapede to get the server from lagging (it removed 4909 concapedes).  Since then, it's happened 4-5 times where I've had to killall.

 

- Speaking of Concapedes, dual wielding against them and hitting with your offhand makes the client crash

 

- On the topic of dual wielding, there's something wrong with the option to move from the regular bar to dual-wielding and back.  Sometimes, you have to mash R repeatedly to get back to the normal bar. 

- Quantum computer created on the client side made the server crash last night (sorry no logs)

 

- COFH mineral generation isn't working (as discovered above...)

 

- Disabled the butterfly mod because it was throwing an exception here and there.

 

I've noticed several mods have gotten updates to them for 1.7.10.  Plan is to review the changes and see if I can't manually update some of them to correct these issues.

 

Related to concapedes, while I haven't experienced an invasion I've noticed crushing framerates (like.. FPS 8) after hours and hours of play.

 

I added Opis to help me troubleshoot and it seems that as concapeded segments are the culprit. Using Opis to kill them all (just the segments) brings my FPS back to around 40-50. Just singleplayer, not running a server.

Share this post


Link to post
Share on other sites

First off, thanks to those of you working on this kickass mod!  I've been hooked on MC since I first played it back in like 2010, played a ton of mods, have run a low-pop server forever... and Hexxit is my favorite!

 

Anyway, been doing 3.0.0c in SP to see if I can't help with the issues.

 

Sorry if any of this has already been listed/confirmed, I read this thread, but I may have missed something.  I also wanted to list things out in case it's not a bug or missing mod, and just something I am doing wrong.

 

Structures: Right now, I am seeing a lot of buildings that aren't spawning the walls.  Battle Towers (especially underground towers), some kind of square building in woodland biomes (?) and also a large cube I found in the desert... it covered a large area, but only had one zombie spawner, one skeleton spawner, and 2 double chests, offset from one another (odd for how large the cube was, I can't identify which mod it's from.)

 

Mobs: Some peaceful mobs seem to be going crazy and attacking when you get close... Ostriches, some elephants... mobs that I believe were peaceful the last time I played Hexxit anyway.  The game IS extremely challenging, I personally like that though... (my wife tires of the cussing).... it'd be nice if we could radiate difficulty higher the further you went from spawn... maybe increment every kilometer?  That would be awesome!

 

Items:  Only thing I have had a problem with so far is the "Traveller's" Belt from Tinker's Construct (Item 5251)  when you put it on and hit B to swap bars, it shows you a blank bar, then kind of wigs out... definitely not working as intended.

Share this post


Link to post
Share on other sites

Structures: Right now, I am seeing a lot of buildings that aren't spawning the walls.  Battle Towers (especially underground towers), some kind of square building in woodland biomes (?) and also a large cube I found in the desert... it covered a large area, but only had one zombie spawner, one skeleton spawner, and 2 double chests, offset from one another (odd for how large the cube was, I can't identify which mod it's from.)

 

Mobs: Some peaceful mobs seem to be going crazy and attacking when you get close... Ostriches, some elephants... mobs that I believe were peaceful the last time I played Hexxit anyway.  The game IS extremely challenging, I personally like that though... (my wife tires of the cussing).... it'd be nice if we could radiate difficulty higher the further you went from spawn... maybe increment every kilometer?  That would be awesome!

 

 

 

That's actually not a battletower, notice there aren't really chests laid out in the same pattern as there would be in a battletower. Anyway, the problem is with ruins mod. There are some templates that are old that need to be removed because they still use item IDs instead of item names so they don't parse correctly.

 

As for the mobs no longer being peaceful, this is something new with project zulu. Most mobs that were peaceful before now have an aggro setting in configuration file. So they attack on site.

Share this post


Link to post
Share on other sites

For anyone having issues with too many Concapedes, my girlfriend was having the same issue and found a solution. Go into the Lycanite's Jungle Mobs config file, and turn on Natural Despawning for the Concapedes. As it is now, they will never despawn, so they just build up more and more.

Share this post


Link to post
Share on other sites

Is there any way to get the amazing Hexxit music (title screen) to play in place of the stock MC stuff?  Love the MC music and all, but I've heard it 10,000 times.

 

(Edit: I've moved my game from a single-player instance to a localhost server, and the music is all the new stuff!  Is it something with SP that runs the classic music maybe?)

 

Also, it would appear that while both named "battletowers-1.7.10.jar" the one that ships with 3.0.0c is 1KB smaller than the one from the Battletowers page.

 

I'm running the larger one, and the loot is still borked, fwiw.

Edited by tunnelrat

Share this post


Link to post
Share on other sites

Is anyone running this SMP?  Have you noticed vanilla mobs not spawning, specifically the hostile mobs (skeletons/etc)?

 

I'm thinking there is a spawning issue here.

I've noticed that they don't spawn quite as often. Except Skeletons. They're everywhere. I think it's something to do with Lycanite's.

Share this post


Link to post
Share on other sites

I've noticed that they don't spawn quite as often. Except Skeletons. They're everywhere. I think it's something to do with Lycanite's.

 

I'm seeing tons of skeletons (specifically ones with exploding arrows... which I think should drop those arrows on death, imho)

 

Definitely spiders and zombies, but not quite as often.  Creepers are aplenty as well.

Share this post


Link to post
Share on other sites

Is anyone running this SMP?  Have you noticed vanilla mobs not spawning, specifically the hostile mobs (skeletons/etc)?

 

I'm thinking there is a spawning issue here.

Skuli,

 

I fixed the Lycanites folder capitalization issue on Linux server, copied in the cfgs to the properly named folder and got a much better mob balance. Started seeing vanilla mobs instead of being overrun with Lycanites. I'm still having trouble with chocolate and infernal mobs not dropping any high level loot just basic stuff.

Share this post


Link to post
Share on other sites

Related to concapedes, while I haven't experienced an invasion I've noticed crushing framerates (like.. FPS 8) after hours and hours of play.

 

I added Opis to help me troubleshoot and it seems that as concapeded segments are the culprit. Using Opis to kill them all (just the segments) brings my FPS back to around 40-50. Just singleplayer, not running a server.

I did the same, Opis showed the same, killed them off but they come back. 2000+ of them. Ended up disabling them in the cfg file for now.

Share this post


Link to post
Share on other sites

Skuli,

 

I fixed the Lycanites folder capitalization issue on Linux server, copied in the cfgs to the properly named folder and got a much better mob balance. Started seeing vanilla mobs instead of being overrun with Lycanites. I'm still having trouble with chocolate and infernal mobs not dropping any high level loot just basic stuff.

 

Ahhh... I am running this particular SMP instance on Windows, I wonder if that is why there is a difference.

 

However, the Nether is almost 100% Lycanites even on my server... 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.