Archived

This topic is now archived and is closed to further replies.

Varien_Dathemire

Tekkit Server/Port Forwarding Issue/Bug/Glitch/Problem-Whatever

28 posts in this topic

Please don't Lynch me for this.

I'm not exactly sure where this would go, seeing as I'm not quite sure what the problem is. Let me explain like a good little monkey.

I set up a Tekkit 2.1.1 Server, roughly when it came out, Port forwarded correctly, Server Properties was set correctly, Everything was ready to go. After some Minor Troubleshooting, It was up, it ran just fine with the occasional overload due to a nuclear explosion. Upon Revisiting Technicpack.net one day I stumbled upon the Tekkit Server 3.0.4 Update. Realizing I was completely outdated at the time, due to not playing Tekkit for a while, I downloaded the latest version, and edited the Server Properties accordingly.

Here's the Problem. It doesn't work. The Port forwarding was exactly the same as what was used for Tekkit 2.1.1. Which is why it confused me. The Properties file was edited exactly like the 2.1.1 file, so I wasn't sure why I wasn't able to get anyone to connect.

Now I'm not sure if I'm supposed to, or even if its okay to post Port Forwarding Information, so I'll just say it like this:

My Port is forwarded like this: ###.###.#.1

The Server Properties file had to be like this: ###.###.#.2

And that's just how it worked, I'm not sure why having Two, versus One made it as such. If the Properties file was set to One, or Three then It would display *FAILED TO BIND TO PORT* upon Starting the server.

With Version 3.0.4 however, I am restricted to putting in ###.###.#.2 as my IP to get on, the IP doesn't work, and not even localhost works, which confuses me further.

As a result, I attempted to Re-Portforward it, which I did successfully, and Identically to how it was done before. Yet it still doesn't work.

Could anyone offer insight to what to do to this, or refer me to a page on the Forum I can't find?

And any Mods who tell me where to move this topic to, I shall gladly do that.

Don't Lynch me for this, I'm new to the forum posting system, since I've usually been able to find what I need without being a Registered Member.

Share this post


Link to post
Share on other sites

Hello :)

As i read down and saw you said localhost does not even work i stopped to reply.

Firstly a few things (you might be aware, you might not!)

Port Forwarding will not fix the localhost issue, i say this because even without any ports fowarded you should still be able to gain access to localhost.

Could you possibly send us your whole server.properties file so we can see what it is?

Also, if you were blocking out 192.168.0.x IP's there, please dont bother as they are LAN Ip's which we cannot connect to :)

Share this post


Link to post
Share on other sites

Thanks for notifying me that LAN IP's don't have to be Censored. Fail on my part. Again I'm new to this forum in particular so All the Rules aren't Nailed into my head yet.

I've attached the Properties File, according to the Attach Button anyway.

As far as I know Its set up correctly, I could attach some Images of my Port Forwarding Page if that's Needed.

Share this post


Link to post
Share on other sites

Try changing your server-ip to just be blank.

Then you should be able to connect to localhost.

For example:

#Minecraft server properties

#Wed May 30 16:18:27 MDT 2012

allow-nether=true

level-name=world

enable-query=false

allow-flight=false

server-port=25565

level-type=DEFAULT

enable-rcon=false

level-seed=

server-ip=

max-build-height=256

spawn-npcs=true

white-list=false

spawn-animals=true

online-mode=true

pvp=true

difficulty=1

gamemode=0

max-players=20

spawn-monsters=true

generate-structures=true

view-distance=10

motd=A Minecraft Server



You can find what IP Address to port forward to by (Windows Vista/7):

[list type=decimal]

[li]Click Start[/li]

[li]Type cmd[/li]

[li]Type ipconfig[/li]

[li]Your IP is listed there :)[/li]

Share this post


Link to post
Share on other sites

This is again where the problem arises, Attached is a .png of my Command Prompt after typing ipconfig, It displays Two IP's, 192.168.0.1, and 192.168.0.2. My Port is currently set to the Former, as it was when I ran a 2.1.1 server, while the server.properties file is set to the latter, again as it was when i ran a 2.1.1 server.

When I set the server.properties file to list 192.168.0.1 It "Fails to bind to Port" though it doesn't display this on 192.168.0.2 . Again Localhost doesn't work but I don't care for that anyway, I connect Via my current IP, given by ipchicken.com, that way I know when its changed and when to Inform my friends of that little factoid. When the Server is running, set on 192.168.0.2, localhost doesn't work, and neither does the IP.

This is why I make the assumption that its something to do with how the Port is Forwarded, or Tekkit just hates me.

Share this post


Link to post
Share on other sites

192.168.0.2 is your computers IP Address, this is what you want to port forward to, and what you "can" put into server-ip=

192.168.0.1 is your modem/router device.

Do you have hamachi installed?

Share this post


Link to post
Share on other sites

Not anymore. Hamachi gravely destroys my internet connection for some reason. When i did use it, before I learned to Port Forward correctly, people would be disconnected all the time, so did I surprisingly, it would occasionally just crash, my internet would just Die, etc.

That's why I'm here, posting about how its being an issue.

Share this post


Link to post
Share on other sites

Okay, so you can connect to your server if you connect to 192.168.0.2?

if so, can you take a screenshot of the port forward configuration page of your router?

Share this post


Link to post
Share on other sites

You can leave the IP line in server properties blank, and in fact you should, it will then bind to all your local interfaces.

When you've done that make sure you can connect using a client from inside your network, or on the same machine.

Assuming your port forwarding is correct, do you have windows firewall turned on? If so check to make sure you have a rule to allow TCP port 25565 open for inbound connections.

Share this post


Link to post
Share on other sites

@AlienX I've attached a Few Pictures, One of the Port Forwarding Page, with little Notes added, and a second one just detailing the Localhost versus 192.168.0.2 IP use.

@Wendo, I'm afraid I don't quite understand what you mean with it Binding to local interfaces, does this mean its almost automatic in its setup, so long as its not restricted by say the Firewall?

Then

When you've done that make sure you can connect using a client from inside your network, or on the same machine
This I don't quite understand Either, as I'm not too familiar with how its set up, does this prevent someone from say, a town over from logging in? They obviously wouldn't be on the same machine, and I want to keep it public for my friends.

Share this post


Link to post
Share on other sites

@AlienX I've attached a Few Pictures, One of the Port Forwarding Page, with little Notes added, and a second one just detailing the Localhost versus 192.168.0.2 IP use.

@Wendo, I'm afraid I don't quite understand what you mean with it Binding to local interfaces, does this mean its almost automatic in its setup, so long as its not restricted by say the Firewall?

Then This I don't quite understand Either, as I'm not too familiar with how its set up, does this prevent someone from say, a town over from logging in? They obviously wouldn't be on the same machine, and I want to keep it public for my friends.

Do you have windows firewall turned on?
To my knowledge, no, or at least not in any way that it would impede with the Launcher, most of its settings are tuned down to a low degree. My uncle, who has an exceedingly large amount of knowledge as to how computers work, did some tuning to the firewall when I was first trying to get it to work correctly, since at the time it was actually having problems with the Firewall preventing people from connecting.

Share this post


Link to post
Share on other sites

I use No-IP so i dont have to give out my internet IP.

I then just give out my no-ip address and input into minecraft and works just fine. I leave the ip blank in the server config.

Share this post


Link to post
Share on other sites

By putting an IP address in the server.properties file, you are telling minecraft to ONLY bind to that IP address. Your server has at least two network interfaces, localhost and the physical network card. If you enter an IP address you are telling it to only bind to the physical network card.

In short, you should never ever need to enter an IP address in server properties. It won't fix anything to do so.

My question about firewall was not your router. Windows has it's own firewall, that's enabled by default. You will either need to disable it, or open the port there too (look in Control Panel for Windows Firewall)

Share this post


Link to post
Share on other sites

Your LAN IP Address is wrong in the router config.

Your practally telling your router to foward packets to itself.

Change the 192.168.0.1 to 192.168.0.2 in the router config :)

Share this post


Link to post
Share on other sites

@AlienX

When done, it responds in the same way it did previously, Localhost doesn't work, the Ip received by looking it up doesn't work, and only 192.168.0.2 Works for connection.

This is strange too because 2.1.1 was run exactly how it's shown in the Image, and I've had as much as Twelve people online at once, so the router must have been acting of its own will since I haven't changed anything until now.

@Wendo, I wasn't aware that it didn't need one, the sources I read off of at the time stated that it needed the IP to be input into it otherwise it remained impossible to connect to other than localhost, due to it not having something defined for it to be connected to.

I'd prefer to avoid Turning it off, but I wouldn't know how to open a Port within the firewall either, so I'm at a Blockade of a sort.

Share this post


Link to post
Share on other sites

Yeah localhost wont work as the socket is bound to 192.168.0.2 - localhost is 127.0.0.1.

Can i assume you have this totally fixed now and players can now join your server from the interwebnets?

Share this post


Link to post
Share on other sites

I have never, for either a Vanilla or Tekkit MC server, needed a server IP in the config file, but I've been running off Hamachi the whole time.

Share this post


Link to post
Share on other sites

You could make the assumption, but its incorrect. I changed the Port, as you said I should, yet it still doesn't work. This is why I'm posting the issue on the Forums, I'm genuinely Stumped as to why it won't work, I've tried multiple means of getting it to work, Three Different Port configurations, I've fiddled with the Server Properties IP setting, but nothing is working.

Share this post


Link to post
Share on other sites

If you are about tomorrow - around 4 hours before this post, maybe i can remotely assist you (as in using TeamViewer)

Share this post


Link to post
Share on other sites

At About 3:00 PM Tomorrow? Which is actually 1:00 PM for me, Yeah, I should be around. Not exactly sure what TeamViewer is, but Any and all Help I can get on this subject is greatly appreciated.

Share this post


Link to post
Share on other sites

1) First step, we should verify that the server was successfully able to get port 25565. Type this at a command prompt:

[tt]netstat -an | find "25565"[/tt]

If you get a result that says something like either of the following two lines:

[tt]TCP 0.0.0.0:25565 0.0.0.0:0 LISTENING[/tt]

[tt]TCP 192.168.0.2:25565 0.0.0.0:0 LISTENING[/tt]

Then the Tekkit/MineCraft side of things is all OK. I suspect that based on what you have put in your server.properties file, that you will get the second line.

2) Now we need to check your PC's firewall.

  • In the bottom right corner of the screen next to the time, there should be an icon of a screen with a plug over it - which when hovered over says "Network xx, Internet access". Click this once, and select "Network and Sharing Center".
  • In the bottom left of the screen, it should say "Windows Firewall". Select this.
  • Click "Advanced Settings".
  • Click "Inbound Rules".
  • Click "New Rule".
  • Select "Port", click Next.
  • Make sure "TCP" is selected, and in the "Specific local ports" box, enter "25565". Click Next.
  • Make sure "Allow" is selected, and click Next.
  • Make sure all boxes are ticked, and click Next.
  • Name the rule something like "Tekkit Server" and click Finish.

Then give it another try.

Share this post


Link to post
Share on other sites

Okay, I've followed each step, but the situation really hasn't changed, checking ipchicken.com again, I input the IP as it would be followed be :25565 as usual, and it says "Can't reach server" like usual. Same is said when localhost is used, but again when 192.168.0.2 is used it operates correctly.

Share this post


Link to post
Share on other sites

Sorry, skip that step - I forgot to take it out. I've amended the list of steps.

EDIT: Ah, so you got the firewall exception in OK? So Tekkit can now connect via 192.168.0.2 now?

Connecting to 127.0.0.1/localhost won't work while you have "server-ip=" has an IP listed in server.properties. I would personally remove the IP from that line so it just reads "server-ip=", and restart the server - then see how it goes.

Share this post


Link to post
Share on other sites

Okay, as is, Localhost and 192.168.0.2 both work, What do I do from here to make it available so that other people can join from a different computer, because that's a majority of my concern at this point. I attempted to sign in via my current IP, but it doesn't register the server.

Share this post


Link to post
Share on other sites