Sign in to follow this  
grinch51

help plz

Recommended Posts

so ive been trying to run a pack on technic launcher but i have linux and for some reason because it takes a while to load when its saying mojang after a while it will close and go back to the technic launcher please help

Share this post


Link to post
Share on other sites

All issues belong on the tracker, following the template, so please take it there.

To diagnose your problem, we could use the >crash reports, so make sure to include them.

 

Before you do that, you could make sure that you are not having this extremely common problem.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Similar Content

    • By NebelC0meback
      Hello people of the Technic community, I've had this problem for around 3 weeks now, and after countless hours of research i couldn't get it to work.
      I've got the following problem:
      I've been using Ubuntu (PoPOS) for around 2 months now, and i got really familiar with it. I got minecraft from the repositories no problem whatsoever. But as i wanted to play with mods, My old friend Technic Launcher came to my mind again, so i tried to install it and play some modpacks.
      Problem:
      I've installed the correct java version (OpenJDK 8 ) and put the techniclauncher.jar as an executable. Now when i run the launcher, the installation screen pops up, everything normal. Now when i install it as a portable or just normally, it creates the directory and the installer dissapears. Everything ok until now: When i try to launch Technic again, it just crashes. The java process is running, but starts dissapearing. So i tried again with oracle Java 11. Same problem. It just crashes. When i launch it over Terminal, it gives me this:
       
      [email protected]:/home/muenzlpsaveyourinternet# java -jar '/home/directory/TechnicLauncher.jar' '/home/directory/TechnicLauncher.jar'
      Settings for exe: /home/directory/TechnicLauncher.jar
      Portable settings dir: /home/directory/technic
      Setting up logging
      And nothing else happens, the terminal doesnt continue launching, same with launching without terminal.Nothing opens , just the process i can see in my system manager
      I tried and tried, i uninstalled the runtimes, 8 and 11, tried and tried but nothing worked. I found no answer, now after 2 weeks of trying, I decided to post this here to get some answers from nice people who like to help in the community.
      If you like to help me, just post solutions or suggestions in the section down, please stay simple with ubuntu stuff since i am really new to linux and just getting started. Thanks for any response.
      (replaced my install directory with directory because its pretty much useless for help and might confuse people)
       
    • By Caminon
      Whenever I try to run the sh in the server folder in the terminal, this happens:
      A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException
              at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
              at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
              at java.base/java.lang.reflect.Method.invoke(Method.java:564)
              at cpw.mods.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:48)
              at cpw.mods.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:17)
      Caused by: java.lang.ClassCastException: java.base/jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to java.base/java.net.URLClassLoader
              at net.minecraft.launchwrapper.Launch.<init>(Launch.java:33)
              at net.minecraft.launchwrapper.Launch.main(Launch.java:27)
              ... 6 more

      I'm running on Debian, just installed java fresh on this computer. I can't seem to figure out why it won't work.
    • By elvis8900
      I'm trying to run the Technic Launcher on mint linux 18.2. I can see the launcher. I just can't adjust the launcher window to access any mod packs.
    • By Rigby293
      Technic Launcher crashes while trying to install, when trying to reinstall (without deleting .technic) it immediately crashes.
      [B#347] 2016/10/21 13:28:30 [INFO] Console Mode Activated
      [B#347] 2016/10/21 13:28:30 [SEVERE] java.io.FileNotFoundException: File '/home/owner/.technic/assets/launcher/OpenSans+Cyberbit.ttf' does not exist
      [B#347] 2016/10/21 13:28:30 [SEVERE]     at org.apache.commons.io.FileUtils.openInputStream(FileUtils.java:299)
      [B#347] 2016/10/21 13:28:30 [SEVERE]     at net.technicpack.ui.lang.ResourceLoader.getFontByName(ResourceLoader.java:76)
      [B#347] 2016/10/21 13:28:30 [SEVERE]     at net.technicpack.ui.lang.ResourceLoader.getFont(ResourceLoader.java:318)
      [B#347] 2016/10/21 13:28:30 [SEVERE]     at net.technicpack.ui.lang.ResourceLoader.getFont(ResourceLoader.java:314)
      [B#347] 2016/10/21 13:28:30 [SEVERE]     at net.technicpack.launcher.autoupdate.TechnicRelauncher.buildUpdaterTasks(TechnicRelauncher.java:114)
      [B#347] 2016/10/21 13:28:30 [SEVERE]     at net.technicpack.autoupdate.Relauncher.runAutoUpdater(Relauncher.java:97)
      [B#347] 2016/10/21 13:28:30 [SEVERE]     at net.technicpack.launcher.LauncherMain.main(LauncherMain.java:193)
      [B#347] 2016/10/21 13:28:30 [WARNING] Unable to load users from /home/owner/.technic/users.json because it does not exist.
      [B#347] 2016/10/21 13:28:31 [INFO] Starting download of http://launcher.technicpack.net/resources/OpenSans+Cyberbit.ttf, with 3 tries remaining
      [B#347] 2016/10/21 13:28:40 [INFO] Expected MD5: 94a9d4cbcb9ceaa25000fa303fa81acc Calculated MD5: 94a9d4cbcb9ceaa25000fa303fa81acc
      [B#347] 2016/10/21 13:28:40 [INFO] Starting download of http://launcher.technicpack.net/resources/Raleway+FireflySung.ttf, with 3 tries remaining
      [B#347] 2016/10/21 13:28:49 [INFO] Expected MD5: b62087eb4b11746987c800c0512890ef Calculated MD5: b62087eb4b11746987c800c0512890ef
      [B#347] 2016/10/21 13:28:49 [INFO] Starting download of http://mirror.technicpack.net/resources/aether-dep.jar, with 3 tries remaining
      [B#347] 2016/10/21 13:28:52 [INFO] Expected MD5: EBF34784444ABCB976F77C9E23692057 Calculated MD5: ebf34784444abcb976f77c9e23692057
      [B#347] 2016/10/21 13:28:52 [INFO] OS: linux
      [B#347] 2016/10/21 13:28:52 [INFO] Identified as linux
       
    • By gdgriffiths
      Not sure if anyone else has this problem or knows how to resolve this issue but I seem to have an odd problem with modpacks on Linux Mint 17.3
      Im running an Intel Core i7 8GB RAM and an nVidia Geforce 840M graphics card. I have installed proper java 8 instead of OpenJDK that ships with mint and I also had this problem on Java 7 but basically whenever i launch a pack the launcher closes and about 3-5 mins later Minecraft actually starts up. Once it starts it loads fast, it plays full speed no problem but that initial launch is so slow!
      Any ideas? My GoogleFu has been weak on this topic and i can't find anything about it!