Sign in to follow this  
Kevinrs1982

Oil Refinary issue

Recommended Posts

So I just started playing tekkit and I create a pump for the oil field which pumps it into a tank, no issues there.

When I pump the oil into the refinary and it fills up both tanks on the refinary all the way it refuses to start even with electricty going to it from the combustion engines and I look at the power that ther refinary has and it is capped out with full power.

 

If I drop one bucket of oil in a empty refinary it will work but the more oil I dump the slower it gets until it stops all togther.

Another weird thing I noticed is if I manually dump oil into the refinary then try to connect a pipe to it the pipe no longer pumps oil into the refinary, the oil just stops at the end of the pipe.

But when I destroy the existing refinary and place a new refinary the oil goes into it without a issue.

Is this a bug?

Share this post


Link to post
Share on other sites

I assume you are still using all the old Buildcraft stuff. Most people have moved on towards newer mods for liquid transfer, namely Thermal Expansion Fluiducts. Try setting it up with those, but keep in mind that you need to wrench the output connection to extract mode and apply a redstone signal, or alternatively install a Pneumatic Servo and configure it to extract without a signal. It takes some getting used to, but it handily beats the old system with Wooden Pipes and Redstone Engines for every bloody export.

 

Buildcraft Refineries are the only reliable Fuel producers in current Tekkit - and they sure work, if you wire them correctly. However, I'm not entirely sure if Refineries accept all sides as inputs or outputs. My working configuration usually had power going into the backside, oil pumped into the left and fuel pumped out of the right side. Or vice versa, but always from the sides.

 

If your setup still fails with these hints, try to share pictures.

Edited by Curunir

Share this post


Link to post
Share on other sites

I used the Technic launcher and updated using the Tekkit mod, so you are saying I need to install a additional mod called Thermal Expansion Fluiducts?

I am at work right now so I cant check but is this also incuded with the Tekkit package?

 

I tried pumping the oil from the left side and to have the fuel pump out from the right but that causes it to stall/not work I also tried to pump it in from the right with the same results.

 

But like in my OP it is weird when I dont pipe anything in but manually add oil the refinary kicks off without a problem, but then the pipes stop pumping oil into the refinary.

However when I pump the oil in first the refinary never starts at all and both tanks on the refinary is 100% full and I check the power intake to the refinary and it is at 1000.

 

 

When I get home I will record a video of it to show what I am dealing with.

Edited by Kevinrs1982

Share this post


Link to post
Share on other sites

even if it also should work with combustion engines, I admit changing to TE Dynamos instead, they produce RF instead of MJ energy and that can be transferred with TE conduits.

 

my setup was to connect power to the back, fill oil from the bottom/top and extract the fuel from bottom/top... worked just fine...

 

PS: I used the BC Refinery, not the one from the Galacticraft mod (the one from BC is the red one with mostly glass)

 

the speed of the refinery mostly depends on the amount of power you put in, if the 2 sticks on the front side are moving up and down, it generally works, but they also indicate how fast they are, if they are bright green, thats most output you can get ;)

Share this post


Link to post
Share on other sites

When I get home I will record a video of it to show what I am dealing with.

Please do us all a favour and only make screenshots.

 

These should be enough to determine where you went wrong. My guess is that you are using vastly outdated pipes and not following all of the (convoluted) rules that they are imposing. Also, observe that the MJ power system, which Combustion Engines are part of, is just as outdated and not too reliable. Supplying your Refinery with a Redstone Flux (RF) network is preferable, as HeatHunter hinted. To do that, use at least a Hardened Energy Cell, supply it power with Steam Dynamos and hook the Cell up to the Refinery with Conduits.

 

If this is all new to you, maybe you will find some parts of my >starter guide useful.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this