Jump to content

Recommended Posts

I don't know how to make a modpack. I tried making one which has the mods below and I find that I am suffering from huge lag even though I have played mod packs with alot more mods installed. Can someone help me get it working and realivitly lag free?

Note:If you have any questions just ask, IDK if I provided enough info or not...

Mods I Want:

Minecraft Forge -1.7.10

Veinmeiner -1.7.10

NEI Not Enough Items 1.7.10

Minefactory Reloaded -1.7.1

Minecraft Comes Alive 1.7.0

Backpacks -1.7.10

CodeChickenCore -1.7.10

Inventory Tweaks-1.7.10

Thaumcraft - 1.7.10

Tinker Construct-1.7.10

Twilight Forest -1.7.10

Blood Magic -1.7.10

Witchery -1.7.10

Ars Magica 2 -1.7.10

Biomes O Plenty -1.7.10

BuildCraft -1.7.10

Ender I0 -1.7.10

Galactic Craft -1.7.10

WAILA - 1.7.10

Lycanite's Mobs -1.7.10

Magical Crops-1.7.10

Mekanism -1.7.10

Morph-1.7.10

Hats -1.7.10

Mob Amputation -1.7.10

MystCraft - 1.7.10

Pam's Harvestcraft -1.7.10

Thermal Expansion - 1.7.10

Thermal Foundation -1.7.10

Fossils and Archaeology Revival Build -1.7.10

Edited by Rokyle
Link to post
Share on other sites
  • Discord Moderator
  • Please provide the API URL (the URL you paste into the Launcher to add the pack) when requesting assistance for any custom modpack.
  • Please provide relevant logs by using a pastebin service (don't paste huge logs here).
  • The black font you have used is nearly impossible to read.
  • I would agree that the mods listed there are fairly tame and should not be causing much lag on any system which can run larger packs. The implication is that there is either some odd incompatibility between two or more mods, or that something odd is going on with your system. More information about system specs and configuration would help determine where the issue might be arising.
Link to post
Share on other sites

 

  • Please provide the API URL (the URL you paste into the Launcher to add the pack) when requesting assistance for any custom modpack.
  • Please provide relevant logs by using a pastebin service (don't paste huge logs here).
  • The black font you have used is nearly impossible to read.
  • I would agree that the mods listed there are fairly tame and should not be causing much lag on any system which can run larger packs. The implication is that there is either some odd incompatibility between two or more mods, or that something odd is going on with your system. More information about system specs and configuration would help determine where the issue might be arising.

 

 

 

  • This is a custom modpack that I am making for personal use so there is no API URL but, I can easily make one if needed.
  • http://pastebin.com/U2iRpPJQ - This a log I found and I believe it is relevant but I'm no expert.
  • Here are some specs:

Processor: Intel® Core I7-3770 cpu @ 3.40gh

Installed memory (RAM): 6.00 GB (5.86 Usable)

System type: 64-bit Operating System, x64-based processor

Edited by Rokyle
Link to post
Share on other sites
  • Discord Moderator

Please provide the API URL for your custom modpack, or at least a download link for the pack itself if you don't have an API URL yet. I'll take a look and see what might be up. I wouldn't think you should have to increase permgen space on a pack of that size. Something is up.

Link to post
Share on other sites

Please provide the API URL for your custom modpack, or at least a download link for the pack itself if you don't have an API URL yet. I'll take a look and see what might be up. I wouldn't think you should have to increase permgen space on a pack of that size. Something is up.

http://www.technicpack.net/api/modpack/the-miz-pack

 

- I didn't know how to fully incorporate forge. (so I did my best)

-I appreciate you going this far to assist me too... :D

Link to post
Share on other sites
  • Discord Moderator

Client Pack:

  • You should uncheck the box labeled "Force Directory Change" in your pack settings page.
  • The bin folder should contain one file named "modpack.jar". This file is simply the correct version of the Forge universal binary JAR file renamed to modpack.jar. Get that file here: http://files.minecraftforge.net/
  • The Forge installer JAR should not be in your mods folder.
  • Your ChickenBones mods are very out of date. Make sure you are using the Latest versions from here: http://chickenbones.net/Pages/links.html
  • Your modpack archive contains no config files. This is always bad.

Client Only Mods (must be removed for the server):

  • MobAmputation
  • WailaHarvestability

After making the above changes I was able to create a Forge #1240 server and connect with your client. I experienced no noticeable lag even after teleporting around, other than the normal worldgen lag after teleporting to a new location with no generated chunks. You noted that your system has 6G of ram. This probably isn't sufficient (at least on Windows) to run both the server and the client at the same time.

Link to post
Share on other sites
  • Discord Moderator
  • You have changed your modpack archive but not changed the pack version number in your settings page. The Launcher will not recognize that an update is available until that version number is changed/incremented and the Launcher is restarted.
  • Your pack settings are configured to be MC 1.7.10, and all your mods are for 1.7.10. However, your Forge version is MC 1.6.4. You need to get the correct version of forge (the binmodpack.jar file).

Give that a shot.

Link to post
Share on other sites
  • Discord Moderator

I have updated the version and the forge. However, I'm still a little confused about the config do I just add it in the modpack archive?

Yes. The config files generated in your testing folder for your modpack (which you should also be tweaking and tuning) should be included in your modpack archive.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Nyrab
      I'm trying a new modpack
      The version is 1.10.2
      I tried to remove some mods and still don't work
       
      Modpacklog.zip
    • By zoezp
      I am new to making modpacks and this is the first one I ever made so I watched some youtube tutorials and it worked well until I tried to launch the modpack and It started as vanilla but when I checked the modpack options it had the mods installed and they were all in the folder. I tried to fix it and tried out things like renaming the files but nothing worked for me so thats why I am here asking for your help.
      I don't know what the problem is at this points so I would really like some help.
      Here is the dropbox link I used to upload the modpack: https://www.dropbox.com/s/u2qfs8zuco8fh39/pixelmon fun.zip?dl=1
      Here is the modpack download link: https://www.technicpack.net/modpack/pixelmon-2780956.1833394
       
      If any more info is needed just ask and I'll provide it if I can.
      Thanks in advance! 
    • By bradleybrand
      I am asking on behalf of my friend with autism.
      So we downloaded the Minecraft Launcher from the official website, installed and ran. It experienced issues download/installing the latest version of Minecraft.
      Luckily, from my computer, I backed up the need Minecraft files into a .zip file and shared that with him. Vanilla Minecraft works and runs.
      From there, went on Technic Launcher. Vanilla Minecraft won't download and install. Neither will my modpack.
      His Technic Launcher has an issue actually downloading and installing modpacks. Even the official ones.
      ---
      We have turned firewall off. We have uninstalled and reinstalled Minecraft Launcher. We have deleted Minecraft and Technic files from %appdata%, as well as using CCleaner to remove any extras. We have uninstalled 64-bit Java and redownloaded and reinstalled 64-bit Java. ---
      What could be a possible fix for this issue?
      Has anyone else experienced such an issue?
    • By Zilverrr
      Whenever me or my friends try to download my modpack https://www.technicpack.net/modpack/minecraft-steden-oorlog.1830815 it only runs vanilla 
      can someone help me with this ?
    • By FlameOregu
      I'm trying to play a modpack with my little brother and all of a sudden it only launches vanilla! Please help quick. I'm using FHM Stoneblock 2 if that helps.
×
×
  • Create New...