ruarc88

Attack of the B-Team 1.7.10

Recommended Posts

Alright, looks like Thermal Dynamics is essentially ready (ducts and stuff) so I'll be trying to push for the final beta build by the end of this weekend. Is there anything in the current build that anyone thinks should change or be tweaked?

Regarding Tropicraft, the 1.7.x version is still in the works and I also am still waiting on a response regarding permissions so unfortunately, it will not be included at release. This also means that should it be added later, it may result in a world reset. This will be thoroughly tested before it gets pushed (if it gets pushed).

Beyond that, I think the pack is basically ready to go. So if I don't hear about any tweaking needed, I'll release the final beta this weekend and if nothing bad happens, 1.0 release will happen shortly after that.

And yes, AE2 will be added and configured in this next build

Share this post


Link to post
Share on other sites

Alright, 0.3.1 is now up and tested with the launcher. AE2 is in and configured with mostly defaults. Generation was SLIGHTLY increased to account for the nature of the pack without giving you instant end-game storage. With any luck this will be the last beta build before release! :D

Things that should be tested, mainly, AE2 progression. I have not played with AE2 at all myself so I'm really not sure what to look for so just need some confirmation that with current configs there's no blocks related to config settings that make certain features impossible to use. And also power is set to RF, so should be no problems there.

Other thing is dimensional generation just to be sure that any mod changes don't have incorrect generation in other dimensions (Ex, flowers and vegetation on the moon and Mars).

Also, I did get a working server build working for 0.2.3 and there will be a server pack attached to the pack at release as this is what I'll be using for my server.

Timeline, providing nothing goes wrong, release will be in 2-3 weeks, at this point, I'm hoping 4 weeks will be the absolute most.

Share this post


Link to post
Share on other sites

Hi! Love to see someone creating a modpack with all the mods from Attack of the B Team. However, I do like to point out several problems that I hope you can add it into your next update.

*Having problems with the Flans Mod. It seems everything of the mod is gone. The weaponry, vehicles and other stuff do not appear. Somehow this problem causes the whole Minecraft to crash, and I could not play Minecraft using this mod at the moment. The error is as follows:

at com.flansmod.common.BlockFlansWorkbench.func_149691_a(BlockFlansWorkbench.java:47)
    at net.minecraft.client.renderer.RenderBlocks.func_147787_a(RenderBlocks.java:8232)
    at net.minecraft.client.renderer.RenderBlocks.func_147800_a(RenderBlocks.java:8175)
    at net.minecraft.client.renderer.entity.RenderItem.renderItemIntoGUI(RenderItem.java:446)
    at net.minecraft.client.renderer.entity.RenderItem.func_82406_b(RenderItem.java:565)
    at net.minecraft.client.gui.GuiIngame.func_73832_a(GuiIngame.java:955)
    at net.minecraftforge.client.GuiIngameForge.renderHotbar(GuiIngameForge.java:206)
    at net.minecraftforge.client.GuiIngameForge.func_73830_a(GuiIngameForge.java:141)
    at net.minecraft.client.renderer.EntityRenderer.func_78480_b(EntityRenderer.java:1038)
    at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:989)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:887)
    at net.minecraft.client.main.Main.main(SourceFile:148)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

Tried to reinstall Flans Mod, but of no avail could I play Minecraft.

This is the only problem I've spotted out so far. Hope I could see the addition of Maps mod and others soon!

Share this post


Link to post
Share on other sites

Hi! Love to see someone creating a modpack with all the mods from Attack of the B Team. However, I do like to point out several problems that I hope you can add it into your next update.

*Having problems with the Flans Mod. It seems everything of the mod is gone. The weaponry, vehicles and other stuff do not appear. Somehow this problem causes the whole Minecraft to crash, and I could not play Minecraft using this mod at the moment. The error is as follows:

at com.flansmod.common.BlockFlansWorkbench.func_149691_a(BlockFlansWorkbench.java:47)
    at net.minecraft.client.renderer.RenderBlocks.func_147787_a(RenderBlocks.java:8232)
    at net.minecraft.client.renderer.RenderBlocks.func_147800_a(RenderBlocks.java:8175)
    at net.minecraft.client.renderer.entity.RenderItem.renderItemIntoGUI(RenderItem.java:446)
    at net.minecraft.client.renderer.entity.RenderItem.func_82406_b(RenderItem.java:565)
    at net.minecraft.client.gui.GuiIngame.func_73832_a(GuiIngame.java:955)
    at net.minecraftforge.client.GuiIngameForge.renderHotbar(GuiIngameForge.java:206)
    at net.minecraftforge.client.GuiIngameForge.func_73830_a(GuiIngameForge.java:141)
    at net.minecraft.client.renderer.EntityRenderer.func_78480_b(EntityRenderer.java:1038)
    at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:989)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:887)
    at net.minecraft.client.main.Main.main(SourceFile:148)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

Tried to reinstall Flans Mod, but of no avail could I play Minecraft.

This is the only problem I've spotted out so far. Hope I could see the addition of Maps mod and others soon!

​Flans was updated from 4.8.0 to 4.9.0 in the 0.3.x update. I will check this if I get a chance this weekend. Did you try running the pack without Flans installed? Could you try throwing in 4.8.0 to see if you get the same issue? Preferably by using the Flans Workbench since that's the troublesome block. Keep in mind that there are 3 content packs in there as well. If memory serves, titans, modern weapons, and simple parts packs.

Unfortunately, Flans is just one of those mods you have to expect crashes with. I was really hoping it'd be somewhat stable for 1.7 but it doesn't look like that's happening.

Thanks for the input! :)

Share this post


Link to post
Share on other sites

The problem is fixed when you don't touch the "fire" and "flat rectangular objects" (preferable if the additional duplicated "fire" and "flat rectangular objects" are removed from NEI or TMI). I've added the three mods and some other cool mods of Flan's counterpart and it does really look good. Would love to see an update to FutureCraft compatible to the latest version of Flan's Mod because such items don't exist when I put the older version. (Remember the Flan's parts and other stuff of Flan's Mod should be put into the Flans folder, not the mods folder)

Another problem I've found is that the prolonged problem that the original AotB team has already had - the ore dictionary problem with copper and tin. This time, the GC ingots are converted to TE blocks (e.g. 9 GC copper ingots give a single TE (Thermal Expansion) copper block). Don't know if you can fix it in the forge editor or somewhat else. Would be pleased if you can fix the problem.

Mods that can be updated:

iChunUtil

Mods that may be important:

Coroutil

EDIT: I've added almost all the mods that Attack of the B-team and no glitch occurred. The Map Writer mod is working perfectly fine at the moment.

EDIT: Do you have any ideas what's up with Tropicraft now? I don't see a 1.7.10 released though.

Share this post


Link to post
Share on other sites

Yep, found that as well with the fire objects. Trying to find a way to remove them from NEI but having a bit of trouble finding it. Did not know that about flans components. Thanks a lot. Next update will be fixed there.

Ore dictionary, I'm assuming it's an issue of just having ingots and blocks from every mod that's the issue? If so, I'll try forcing just Thermal foundation ores, ingots, and blocks if at all possible.

iChunUtil was looking at the 5.0.0 version which is the 1.8 version. Will double check though in case there's a newer 4.x.x version.

Map Writer was originally crashing on me when I tried adding it. Will try it again.

Haven't heard a word on Tropicraft. As far as I can tell, they are working on a new version, whether or not it'll be 1.7 or 1.8 remains a mystery.

Thanks for all the input :D

Share this post


Link to post
Share on other sites

I've used VoxelMap to replace MapWriter, and it's working perfectly fine. Although the map is much blurrier, it's still very good. The coordinates are embedded in the game, so I think it's still a fair replacement of MapWriter.

The blog did say they are going to release 1.7.10 for Tropicraft.

There is a way to edit the ore dictionary, but I don't know how even there is a tutorial about it. It's better to separate the blocks and ingots. Like GC ingots make GC blocks, TE ingots make TE blocks, TC ingots make TC blocks etc. in order to prevent confusion and recipe conflict or unable to make objects.

Also, the modpack makes diamonds and redstones very rare. I recommend increasing the cluster number. I think that may help increase the number of diamonds and redstones. (EDIT: Sorry, I found that it is the additional EnviroMine Mod which limited the spawn rate.)

Thanks by the way! My friend loves your modpack so much (including some additional mods I've added haha)

Share this post


Link to post
Share on other sites

I've made a my own take on a 1.7.10 B-Team called A-Team's Revenge. It is a bit closer to the original B-Team mod list with only a few "contextually relevant" changes (so, no AE2rv2). I've made the ore generation the same as it was in B-Team by disabling the mod's own oregen and using custom CoFH worldgen. The amount/cluster/etc. of ores and resources is set directly from the B-Team configs. You can check out my CoFH (and other mods) configs for examples if you want.

A-Team's Revenge: http://technicpack.net/modpack/a-teams-revenge.625630

Share this post


Link to post
Share on other sites

I've made a my own take on a 1.7.10 B-Team called A-Team's Revenge. It is a bit closer to the original B-Team mod list with only a few "contextually relevant" changes (so, no AE2rv2). I've made the ore generation the same as it was in B-Team by disabling the mod's own oregen and using custom CoFH worldgen. The amount/cluster/etc. of ores and resources is set directly from the B-Team configs. You can check out my CoFH (and other mods) configs for examples if you want.

A-Team's Revenge: http://technicpack.net/modpack/a-teams-revenge.625630

​Mmm... It seems I have to manually download some java files of Forge Modloader. I don't know where to put. :/

I will try again later some time to see if this problem is existent in the modpack.

EDIT: The problem is fixed in the newest version.

Edited by Wildoneshelper

Share this post


Link to post
Share on other sites

I've made a my own take on a 1.7.10 B-Team called A-Team's Revenge. It is a bit closer to the original B-Team mod list with only a few "contextually relevant" changes (so, no AE2rv2). I've made the ore generation the same as it was in B-Team by disabling the mod's own oregen and using custom CoFH worldgen. The amount/cluster/etc. of ores and resources is set directly from the B-Team configs. You can check out my CoFH (and other mods) configs for examples if you want.

A-Team's Revenge: http://technicpack.net/modpack/a-teams-revenge.625630

​This is actually exactly what I did but it seems there's interference. Gonna reference this and disable Artifice ores if possible.

Share this post


Link to post
Share on other sites

I've made a my own take on a 1.7.10 B-Team called A-Team's Revenge. It is a bit closer to the original B-Team mod list with only a few "contextually relevant" changes (so, no AE2rv2). I've made the ore generation the same as it was in B-Team by disabling the mod's own oregen and using custom CoFH worldgen. The amount/cluster/etc. of ores and resources is set directly from the B-Team configs. You can check out my CoFH (and other mods) configs for examples if you want.

A-Team's Revenge: http://technicpack.net/modpack/a-teams-revenge.625630

​Hello. I'm testing your modpack since yesterday and, with server version, it seems there is a problem with two mods. Lauching server is fine but once I try to join it in Minecraft (of course, on localhost for testing purpose), game stops and dispays a short message saying "FML rejects More Planets and IChun". Simply that.

I've removed the first and upgrade the second to 4.2.2 version ; all works fine now, so I guess it's only a version issue for IChun. For More Planets, I can't say. If you want, I'll send log next time for details.

Share this post


Link to post
Share on other sites

Sorry for the lack of activity, spent the past 3 weeks trying to find any way that the problem items could be removed from NEIs list at the config level but having no such luck so, both Flans and Artifice may need to be removed (Artifice has 1 glowing ore variety that shows up and corrupts the world in a similar fashion) unless by some miracle updates to either corrects the issue.

Share this post


Link to post
Share on other sites

FYI, I found exactly what the issue is by accident. It's a problem with the renderer only, wherever that actually lies in a Forge setup, and higher block IDs using sub IDs with multiple textures. Gonna draw up a chart below since words fail me in explaining this:

# of bits    |    ID range    |    Bits reserved for sub IDs    |    Sub ID range    |    Mod using this range    |    # of sub IDs/mod    |    # of different textures

     8                  0-255                              4                                    0-15 (16)                                                                                

     9                 256-511                          3                                      0-7 (8)                            Artifice                                           9                                  9

     10              512-1023                         2                                      0-3 (4)                                 

    11             1024-2047                           1                                     0-1 (2)                             Flans                                   16                                     16

 

So basically, each step up in the block ID ladder, you're allowed half of the sub IDs and it only affects the renderer so you can still have 16 sub IDs, but you can only have 8, 4, 2, or 1 different sub texture cause the renderer doesn't know what to do with the others.

Flans actually has 2 IDs affected but only 1 of them has 16 different textures. The other only has 1 so it works no problem and it is all of the spawner pads.

I've let Shukaro know about this on the Artifice side, I'm still trying to find how to let flan know. In the meantime, does anyone know if this is an issue with Minecraft or with Forge? I'm not updating Forge beyond 1291 until I know for sure that every mod is compatible with the new version (things got changed) so if this is an issue with Forge that isn't yet known, it'll be quite a while before that update comes around.

Share this post


Link to post
Share on other sites

You could just use MineTweaker to remove them from NEI (trivial). There are so many things which need fixed using MineTweaker anyway that making those changes shouldn't be a burden.

For example:
 

# Remove broken items (or improperly indexed items) from NEI
import mods.nei.NEI;

NEI.hide(<Artifice:tile.artifice.oreredstone.glowing:9>);
NEI.hide(<Artifice:tile.artifice.oreender.glowing:9>);
NEI.hide(<flansmod:flansWorkbench:3>);
NEI.hide(<flansmod:flansWorkbench:4>);
NEI.hide(<flansmod:flansWorkbench:5>);
NEI.hide(<flansmod:flansWorkbench:6>);
NEI.hide(<flansmod:flansWorkbench:7>);
NEI.hide(<flansmod:flansWorkbench:8>);
NEI.hide(<flansmod:flansWorkbench:9>);
NEI.hide(<flansmod:flansWorkbench:10>);
NEI.hide(<flansmod:flansWorkbench:11>);
NEI.hide(<flansmod:flansWorkbench:12>);
NEI.hide(<flansmod:flansWorkbench:13>);
NEI.hide(<flansmod:flansWorkbench:14>);
NEI.hide(<flansmod:flansWorkbench:15>);

 

Edited by plowmanplow

Share this post


Link to post
Share on other sites

I actually haven't even used MineTweaker yet. I've relied on MC 1.7.10 using block names instead of IDs and so far, apart from these few blocks, it's worked well.

So far, I've updated all of the mods, just have to run it to make sure they all work and to generate the added config files and edit them.

I also want to remove the possibility of these particular Artifice ores from generating since if my theory is correct, there are 5 different variations of Artifice's ores with 5 glowing varieties so if the fifth version generates and gets a block update (sub ID 8) it'll turn to the glowing variety (sub ID 9) which is what's corrupting the world. Think I just found out why Artifice is generating ores as well. It seems to be any vanilla ores are pulling from the ore dictionary instead of just the vanilla block so it's randomly pulling whichever variety is in the ore dictionary for said ore. Fixing this should help with diamonds and redstone being rare as well.

Thanks for all of the help

Share this post


Link to post
Share on other sites

It could, of course, be coincidental, but I've yet to have a world corruption from Artifice worldgen. I suspect the NEI issue is just some index out of bounds deal (happened with Biomes O' Plenty too).

Share this post


Link to post
Share on other sites

Sometime in the next 24 hours Technic will show version 0.3.3. Corrupting items are removed from NEI, Artifce limestone/marble/stuffs have been disabled and chisel's marble variety has been enabled. For some strange reason redstone and diamonds are not generating above their default 16 limit, judging by the logs it looks to be that cofhcore isn't even trying to read the config file for them. It found the thermalfoundation file no problem, but there's no reference to the vanilla config file. Will be looking in to this, any theories are welcome

Share this post


Link to post
Share on other sites

I'm talking about my update. Think I may have found the problem. Was verifying the json configs before contacting teamcofh and found the cofhcore.json is failing on the first line so theoretically the issue is it's not even getting to the line where you can enable vanilla ore overriding which is why it's not even trying to look at Vanilla.json (default would be not to override). Will rebuild this config with the current version of cofh core after work and test.

Share this post


Link to post
Share on other sites

No, I'm not. This project is the result of having my world corrupt from AotBT and having to wait for over 6 months for an update to be "tested" (still not ready as far as I can tell). This way, I control the pack (it's going on my server), I can update/change things at will, etc.

Technic, has nothing to do with AotBT development. I doubt the 1.6 author is going to update the current pack at this point and I've been told that a 1.7 pack is currently in development with no news or eta.

On to the issue at hand, it turns out that 1 of the cofh updates in the past couple versions change the name and location of the ACTUAL config files and I've been working with obsolete ones. The current configs have vanilla ore overriding disabled. I'll fix and update tonight. For reference, the current core configs are in config\cofh\core. I was working with the ones in config\cofh.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By deathplayer43
      so my modpack has 5mb of memory allocated but it only uses like 700mb is there a way to fix this
    • By deathplayer43
      Everytime i open up attack of the b team i always  get low frames and i set all my graphics to the lowest setting and use optifine and when i move it drops to 0 is there any way i can fix this
    • By awesomeman100
      I am using the portable version of the technic launcher on mac (on an sd card) and this morning I was playing lapito's galacticraft, closed it, then I reopened the technic launcher a few hours later, and it only showed the official technic modpacks, but even they weren't downloaded, I check the technique folder, all the modpacks are still there, and the saves too. I don't know what to do.
      help apreciated
    • By Omeruin
      I wasn't going to have this modpack on Technic, but, I want to play with all the chosen mods on there just in case my friends want to join me at anytime.
      ---
      I've uploaded a different modpack before, personal like this one, and it worked out just fine. This one does have wayyy more mods so something different is definitely going on. Downloading the modpack is fine, it is hosted on Dropbox. However, when I try to 'play' the modpack, it loads a few things before Minecraft assets, then waits a bit, the Launcher disappears, and then the launcher reappears; meaning something crashed/is not loading right.
      Here is the crash log from Technic: { https://pastebin.com/rz39VrR3 }
      Any help would be appreciated. I tried to skim through the log myself, but it is definitely confusing for me.
      Sorry if this is in the wrong topic, or that something isn't right, I'm typing as fast as I can before I go to work (I'll be able to respond within 8-9 hours from now).
    • By Expresen
      So I am new to mopacks and I have no idea what I'm actually doing but I followed some tutorials on how to do it and I managed to create a modpack that I could run and my mods are in the folder for my modpack. The problem is that whenever I play the mopack in the Technic launcher it only starts up the vanilla version of minecraft and my mods are nowhere to be seen. I did check the modpack options in the technic launcer to see if I could see the mods there, in the folder, and I could, they were all there....

      I don't know what the problem is and I would love some help.
      Here is the dropbox link I used to upload the modpack: https://www.dropbox.com/s/y1nq6botjssakg0/ModpackV1.zip?dl=1
      Here is the modpack download link: http://api.technicpack.net/modpack/rt-modpack

      If any more info is needed just ask and I'll provide it if I can.
      Thanks in advance! ❤️