Sign in to follow this  

DeVco | TPPI 1.1.2a | Open | PvP | 24/7 | Pex | Quickshop | MyTown

Recommended Posts

DeVco TPPI 1.1.2

Click to visit our website

Server Specs:

Processor: Intel Xeon E3 1240v3 (4 cores / 8 Threads) Haswell

Frequency: 3.4GHz+ (3.8GHz Turbo Boost)



Our Server Rules

Full listing of banned items based on ranks

General Info:

Thank you for visiting our server promotion thread. We are a brand new community on a new server recently started by a well experienced staff team. They know their stuff and are easily approachable!


  • We are using MyTown to protect your land
  • PVP survival server. PVP is not allowed in towns.
  • Quickshop is installed for easy shopping. Be sure to checkout the /warp shops
  • Voting for our server rewards you with points to spend in the server reward store
  • Server donation shop with a diverse set of kits/ranks to choose from
  • Several ranks in game which unlock banned items and more commands. Promotions are automated based on play time
Edited by devryb

Share this post

Link to post
Share on other sites

Well like all the other DevCo servers that i have been on this one does not fail to deliver yeah they say banned item pfff you dont even notice that there are banned items the game is not hampered by a super restricted ban list like a lot of other servers or make you have to grind just to be able to get some cool gear the ban list of items are just things that limit the lag and game killing over the top stuff. This place is a great community to be around always fun and the best thing is the lack of greif you don't find huge areas of the map that are just destroyed the staff is always on their game keeping things fresh and the place lag free. This place really offers a limitless opportunity to build and do things there is always players on and never any lag this place is one of the best servers i have ever been on and i plan on staying here so i will see you in game :D    -ale

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By deathplayer43
      so my modpack has 5mb of memory allocated but it only uses like 700mb is there a way to fix this
    • By deathplayer43
      Everytime i open up attack of the b team i always  get low frames and i set all my graphics to the lowest setting and use optifine and when i move it drops to 0 is there any way i can fix this
    • By awesomeman100
      I am using the portable version of the technic launcher on mac (on an sd card) and this morning I was playing lapito's galacticraft, closed it, then I reopened the technic launcher a few hours later, and it only showed the official technic modpacks, but even they weren't downloaded, I check the technique folder, all the modpacks are still there, and the saves too. I don't know what to do.
      help apreciated
    • By Omeruin
      I wasn't going to have this modpack on Technic, but, I want to play with all the chosen mods on there just in case my friends want to join me at anytime.
      I've uploaded a different modpack before, personal like this one, and it worked out just fine. This one does have wayyy more mods so something different is definitely going on. Downloading the modpack is fine, it is hosted on Dropbox. However, when I try to 'play' the modpack, it loads a few things before Minecraft assets, then waits a bit, the Launcher disappears, and then the launcher reappears; meaning something crashed/is not loading right.
      Here is the crash log from Technic: { }
      Any help would be appreciated. I tried to skim through the log myself, but it is definitely confusing for me.
      Sorry if this is in the wrong topic, or that something isn't right, I'm typing as fast as I can before I go to work (I'll be able to respond within 8-9 hours from now).
    • By Expresen
      So I am new to mopacks and I have no idea what I'm actually doing but I followed some tutorials on how to do it and I managed to create a modpack that I could run and my mods are in the folder for my modpack. The problem is that whenever I play the mopack in the Technic launcher it only starts up the vanilla version of minecraft and my mods are nowhere to be seen. I did check the modpack options in the technic launcer to see if I could see the mods there, in the folder, and I could, they were all there....

      I don't know what the problem is and I would love some help.
      Here is the dropbox link I used to upload the modpack:
      Here is the modpack download link:

      If any more info is needed just ask and I'll provide it if I can.
      Thanks in advance! ❤️