Derpologist

Way to leave OS 10.10 users in the hole...

Recommended Posts

Ok so good job, Calclavia! Gene-ous

Quickly: My computer: Brand new (like 4 days or so) 15" MacBook Pro with Retina Display; Core i7 2.5 GHz (4 cores, turbo boost to 4.0GHz). 16GB DDR3 RAM, Nvidia GeForce 750m with 2GB GDDR5 memory, and 512GB of PCIe SSD goodness. Dual external monitors through HDMI and MDP, external keyboard and gaming mouse, and the mac not in clamshell mode (open) I have tried this on my dads machine (the exact same, just a bit older) with no external monitors, and it doesn't have any of the issues I'm about to 'showcase'.

 

Now on to the issue, as you can see my computer is fully capable

 

Lets put it plainly. Mac OS X now does not function with any of the launcher versions after launcher 2. With the Launcher 3, It just pulls up a windows Saying: Technic Launcher (which is new) and when the bar finishes loading, it says you need to install a Java 7 Runtime Environment, Trust me I have downloaded and installed the exact thing it leads me to at least three times. So I try to go to the latest Launcher, IT MUST BE BETTER, I thought. 

 

No, even worse

 

All it says (I've tried it on there different downloads) is: The Application Technic Cannot be opened. Might I add, apps from external developers are allowed on my machine. I have gotten the old launcher to boot once and when I do, I get another hellish move of bad programming. 

I haven't tried volts yet, but this is the Minecraft Wars Pack, found here, on Technic. 

If I can get it to boot (1/20 or so) every ten seconds exactly the framerate tanks from 30FPS to 2. Settings are: Smooth Lighting: off. V-sync: off. Aniscoptic (how ever you spell that ^-^) to off. Render distance: 4 chunks, and brightness to max, and max FPS at 30. Tried it with 60+ and It wouldn't even get there. 

 

None of these issues happen on my dads machine...this 'aint right.

 

In the comments, please don't post stupid little things like: Were you in creative, or Was it raining, because I have tried all things like that, so save yourself some time so you don't get carpel tunnel as fast as I do whilst trying to get this thing to work. 

 

​Don't forget us Mac OS X users, Calclavia 

Share this post


Link to post
Share on other sites

What version of java are you using?
Could we please get a log from the client?
What build of the client are you using?

Have you tried using the beta builds of the launcher?

Share this post


Link to post
Share on other sites

Ok so good job, Calclavia! Gene-ous

Quickly: My computer: Brand new (like 4 days or so) 15" MacBook Pro with Retina Display; Core i7 2.5 GHz (4 cores, turbo boost to 4.0GHz). 16GB DDR3 RAM, Nvidia GeForce 750m with 2GB GDDR5 memory, and 512GB of PCIe SSD goodness. Dual external monitors through HDMI and MDP, external keyboard and gaming mouse, and the mac not in clamshell mode (open) I have tried this on my dads machine (the exact same, just a bit older) with no external monitors, and it doesn't have any of the issues I'm about to 'showcase'.

 

Now on to the issue, as you can see my computer is fully capable

 

Lets put it plainly. Mac OS X now does not function with any of the launcher versions after launcher 2. With the Launcher 3, It just pulls up a windows Saying: Technic Launcher (which is new) and when the bar finishes loading, it says you need to install a Java 7 Runtime Environment, Trust me I have downloaded and installed the exact thing it leads me to at least three times. So I try to go to the latest Launcher, IT MUST BE BETTER, I thought. 

 

No, even worse

 

All it says (I've tried it on there different downloads) is: The Application Technic Cannot be opened. Might I add, apps from external developers are allowed on my machine. I have gotten the old launcher to boot once and when I do, I get another hellish move of bad programming. 

I haven't tried volts yet, but this is the Minecraft Wars Pack, found here, on Technic. 

If I can get it to boot (1/20 or so) every ten seconds exactly the framerate tanks from 30FPS to 2. Settings are: Smooth Lighting: off. V-sync: off. Aniscoptic (how ever you spell that ^-^) to off. Render distance: 4 chunks, and brightness to max, and max FPS at 30. Tried it with 60+ and It wouldn't even get there. 

 

None of these issues happen on my dads machine...this 'aint right.

 

In the comments, please don't post stupid little things like: Were you in creative, or Was it raining, because I have tried all things like that, so save yourself some time so you don't get carpel tunnel as fast as I do whilst trying to get this thing to work. 

 

​Don't forget us Mac OS X users, Calclavia 

Know what you're talking about. I use the exact same MacBook Pro w/ Retina you have (16 GB RAM, GT 750M, etc.) as my daily driver and it pisses me off that Technic's been beta tested for months and this .app issue and others have not been fixed for OS X Yosemite users.

Share this post


Link to post
Share on other sites

Where exactly do you get a beta launcher build? The website is filled with stuff about the latest build.

There is no log, as the launcher doesn't create a file, its all just stuff from my old computer, I just synced over the Technic file. 

 

Java I've tried 6 and 7

Share this post


Link to post
Share on other sites

Know what you're talking about. I use the exact same MacBook Pro w/ Retina you have (16 GB RAM, GT 750M, etc.) as my daily driver and it pisses me off that Technic's been beta tested for months and this .app issue and others have not been fixed for OS X Yosemite users.

I think I got it

http://support.apple.com/kb/DL1572

Download that and install and when I opened the older launcher it told me to open it again, and I did, its currently opening, and I have some other stuff but will be back later. Peace, hope this works!

Share this post


Link to post
Share on other sites

I think I got it

http://support.apple.com/kb/DL1572

Download that and install and when I opened the older launcher it told me to open it again, and I did, its currently opening, and I have some other stuff but will be back later. Peace, hope this works!

 

 

Know what you're talking about. I use the exact same MacBook Pro w/ Retina you have (16 GB RAM, GT 750M, etc.) as my daily driver and it pisses me off that Technic's been beta tested for months and this .app issue and others have not been fixed for OS X Yosemite users.

 

 

What version of java are you using?

Could we please get a log from the client?

What build of the client are you using?

Have you tried using the beta builds of the launcher?

 

I've figured it out. I think

When you download the latest launcher, it shows up as a .app-right click and navigate to more info. Remove the .app to make it a folder. hit enter and close that window, then on your desktop (or wherever the .app was) there will be a folder called technic-Click on this and navigate the following path:

 

Contents/Java/TechnicLauncher.jar

 

double click this and the launcher will open. 

If anybody more adept to code a script that opens that, go ahead, It would be something around:

 

~Users/(user)/Desktop/Technic/Contents/Java/TechnicLauncher.jar

and then an open command. If anybody wants to do a tutorial or a github on that, I would pray on the ground you walk on.

 

Cheers, Modders. I just solved the equivalent to world hunger for Minecraft. yay!

Share this post


Link to post
Share on other sites

I've figured it out. I think

When you download the latest launcher, it shows up as a .app-right click and navigate to more info. Remove the .app to make it a folder. hit enter and close that window, then on your desktop (or wherever the .app was) there will be a folder called technic-Click on this and navigate the following path:

 

Contents/Java/TechnicLauncher.jar

 

double click this and the launcher will open. 

If anybody more adept to code a script that opens that, go ahead, It would be something around:

 

~Users/(user)/Desktop/Technic/Contents/Java/TechnicLauncher.jar

and then an open command. If anybody wants to do a tutorial or a github on that, I would pray on the ground you walk on.

 

Cheers, Modders. I just solved the equivalent to world hunger for Minecraft. yay!

 

This looks like it worked for me. Frustrating issue! Just bought a new mac mini to save my laptop battery while I play on my tv at home. Was amazed that I couldn't launch the new platform. Hopefully someone will get a better fix eventually, as it'd be awesome to keep technic in my app folder rather than on my desktop :P. But meanwhile, thanks for the fix so I can at least play!

Share this post


Link to post
Share on other sites

All of that's unnecessary, just grab the Linux version (.jar) and run that. I'm just pissed because I like having it in my Applications folder.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By NanoByte
      I can't allocate more than 1 GB of RAM to my technic launcer, and before you comment you need to know that I have a 64bit Win10 and 64 bit Java 8 latest version. I also have plenty of memory available (16 more precise) and a pretty nice pc, my only problem is that I can't load any pack because of the Ram restriction 
    • By TBGS_Destroyer
      So i got Technic and i thought it would be cool yea alot of modpacks and stuff ... so i downloaded pixelmon so i can play with a friend and i clicked play  it loaded then it closed the  launcher and re-opened the launcher saying nothing and i tried this for several modpacks its the same for all of them my java is up tp date 64-bit and i dont know why anything isnt loading??
    • By faithifel
      Hello, I've just downloaded the Technic Launcher and downloaded the Pixelmon Modpack today.

      When I tried to press play it shows the loading bar and loads for a few seconds and then closes the Technic Launcher. After a few seconds it reopens the launcher acts like nothing happened and minecraft doesn't appear at all.
      I uploaded the launcher log file and also have a paste bin just in case https://pastebin.com/E2neKAGU
       
      techniclauncher_2019-08-16.log
    • By Jacko_TR
      Every time i try to download this game the downloader always gets stuck in this stage it doesnt go forwards i have waited for hours and reformated my computer twice i dont know what to do anymore please help
      techniclauncher_2019-08-04.log
    • By JokeInABox
      Hi All,
      when i install a modpack and click play, all it dose is close launcher then minecraft appears in the taskbar takes a few seconds then switches to the name of the mod im trying to play (Legands) then dose nothing, wont let me click on it and when i hover over its just a blank white box. 
      I have tried a Couple of different things to get it to work but to no avail.
      Reinstalled minecraft and launcher
      restart PC 
      Changed to 64bit java and set to 4GB ram 
      checked to see if my NVIDA was up to date 
       
      all help would be greatly appreciated.
      link to my logs https://pastebin.com/rNEDnvKb