Jump to content

Technic solder on Win Server 2012?


FrostyZaij
 Share

Recommended Posts

  • Discord Moderator

The fact that the JSON response is missing the version number (it's blank) indicates that either the platform isn't connecting to the database properly, that the database is not set up correctly, or something isn't configured correctly. Other than to state the obvious, that you did not properly follow the installation procedures, I'm not sure what else to suggest. I'm not trying to be snarky or critical. I followed the instructions precisely as written on a new installation for WIndows and everything worked as expected, but I have decades of application deployment experience so I may be subconsciously doing something not specified in the instructions.

Link to comment
Share on other sites

I'll try to reinstall it again then, and hope it works now XD

git clone https://github.com/TechnicPack/TechnicSolder.git

Then

composer install

Then

 

configure the database and the repo location

 

Then

php artisan migrate:install

 

and php artisan migrate

 

and lastly php artisan up

 

that should be it right or am I missing a step?

Link to comment
Share on other sites

okay, so after installing it (in those steps I wrote above) I get this when I try to login in..

 

 

exception 'ErrorException' with message 'Undefined offset: 1' in W:xampphtdocsTechnicSolderapplibrariesUpdateUtils.php:124
Stack trace:
#0 W:xampphtdocsTechnicSolderapplibrariesUpdateUtils.php(124): IlluminateExceptionHandler->handleError(8, 'Undefined offse...', 'W:xampphtdocs...', 124, Array)
#1 W:xampphtdocsTechnicSolderapplibrariesUpdateUtils.php(81): UpdateUtils::getLocalChangeLog()
#2 W:xampphtdocsTechnicSolderappcontrollersDashboardController.php(16): UpdateUtils::getChangeLog()
#3 [internal function]: DashboardController->getIndex()
#4 W:xampphtdocsTechnicSoldervendorlaravelframeworksrcIlluminateRoutingController.php(231): call_user_func_array(Array, Array)
#5 W:xampphtdocsTechnicSolderbootstrapcompiled.php(5834): IlluminateRoutingController->callAction('getIndex', Array)
#6 W:xampphtdocsTechnicSolderbootstrapcompiled.php(5822): IlluminateRoutingControllerDispatcher->call(Object(DashboardController), Object(IlluminateRoutingRoute), 'getIndex')
#7 W:xampphtdocsTechnicSolderbootstrapcompiled.php(5027): IlluminateRoutingControllerDispatcher->dispatch(Object(IlluminateRoutingRoute), Object(IlluminateHttpRequest), 'DashboardContro...', 'getIndex')
#8 [internal function]: IlluminateRoutingRouter->IlluminateRouting{closure}()
#9 W:xampphtdocsTechnicSolderbootstrapcompiled.php(5385): call_user_func_array(Object(Closure), Array)
#10 W:xampphtdocsTechnicSolderbootstrapcompiled.php(5052): IlluminateRoutingRoute->run(Object(IlluminateHttpRequest))
#11 W:xampphtdocsTechnicSolderbootstrapcompiled.php(5040): IlluminateRoutingRouter->dispatchToRoute(Object(IlluminateHttpRequest))
#12 W:xampphtdocsTechnicSolderbootstrapcompiled.php(715): IlluminateRoutingRouter->dispatch(Object(IlluminateHttpRequest))
#13 W:xampphtdocsTechnicSolderbootstrapcompiled.php(696): IlluminateFoundationApplication->dispatch(Object(IlluminateHttpRequest))
#14 W:xampphtdocsTechnicSolderbootstrapcompiled.php(7812): IlluminateFoundationApplication->handle(Object(IlluminateHttpRequest), 1, true)
#15 W:xampphtdocsTechnicSolderbootstrapcompiled.php(8419): IlluminateSessionMiddleware->handle(Object(IlluminateHttpRequest), 1, true)
#16 W:xampphtdocsTechnicSolderbootstrapcompiled.php(8366): IlluminateCookieQueue->handle(Object(IlluminateHttpRequest), 1, true)
#17 W:xampphtdocsTechnicSolderbootstrapcompiled.php(11029): IlluminateCookieGuard->handle(Object(IlluminateHttpRequest), 1, true)
#18 W:xampphtdocsTechnicSolderbootstrapcompiled.php(657): StackStackedHttpKernel->handle(Object(IlluminateHttpRequest))
#19 W:xampphtdocsTechnicSolderpublicindex.php(49): IlluminateFoundationApplication->run()
#20 {main}

Edited by FrostyZaij
Link to comment
Share on other sites

I get some text saying

 

"commit 16351adba696d4c09d586c2f4747729bf74be11d
author: genpage <some e-mail adress>
Date: Sun Jan 4 01:15:21 2015 -0500

added help-blocks that the donation field is currently only used by official" something

 

and a few more of that, I guess that is the changelog right?

Edited by FrostyZaij
Link to comment
Share on other sites

  • Discord Moderator

Correct. The error you are getting is being generated because the code parsing the formated log output (around line 124 in UpdateUtils.php) is failing to explode the output correctly and the array index isn't what's expected. However, This may be because you have one of the path setting misconfigured or something is being mis-detected and the git command is running from the wrong location. Might be time to take this to the IRC channel and ask GenPage.

Link to comment
Share on other sites

I'll try to reinstall everything and see if that helps, should I install all the programs on my C drive instead of the W one I use now?  and setup the locations that I host from on my W drive? I also, doubt they will help me with a windows installation since in the Wiki it says it is not supported.. :/

Link to comment
Share on other sites

Okay, that is good to know, I thought that it maybe had something to do with that, maybe the firewall or something is blocking it? I saw a thing on the issues site that it was someone having almost the same problem and it was the host blocking something, I'll try to disable the firewall and the Anti-virus software and see if it works then...

Link to comment
Share on other sites

  • 2 weeks later...

The reason for the "Undefined offset: 1" error is due to the fact that the git command Solder is trying to execute through PHP is not returning what it is suppose to. I have code in development to rectify this issue and many others. I'd like to note that Windows is not supported, meaning that support is not guaranteed for Solder on the Windows operating system. I have decided not to pursue Windows compatibility testing until later down the road to save myself the stress of trying to fix so many bugs.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By Omega_Volta
      I was planning on using some mods, but when I opened the modpack I intended to use, it just shut down and sent me back to the launcher screen. 
      I've tried removing the mods, uninstalling and reinstalling the modpack, updating my launcher, updating java, and restarting my computer, to no avail.
      Down below is the log in pastebin:
      https://pastebin.com/y64AeY0t
    • By M3veronMast3r
      Hello, I didn't know where to put this Thread, sorry for that.
      My Problem is that i want to create more than only 5 Modpacks. I have different Packs in different Version and i need them all and i dont want to create constantly an new account just to create a new Modpack. I dont understand why this Action is limited to 5 Modpacks. It makes no sense to me. Is there any way to create more than only 5?
      Hope you can help me. ~M3veronMast3r
    • By 4net_E
      LAUNCHER VERSION: v4.664
      OPERATING SYSTEM: macOS 10.14.6
      JAVA VERSION: Oracle 1.8.0_261 64-Bit
      ANTIVIRUS: none
      recently I tried to play some modpacks, but i couldnt start any of them. Every time I wanted to launch them, icon of the modpack showed up in taskbar, window popped up, but after approximately a second, it had crashed.
      I tried to solve this problem by myself, but I didnt manage to success. The closest Ive got to solution was in this thread :
      However, there is a solution linked on another forum thread, but that link is probably corrupted or something, as it just redirected me to the same thread all over again. Thus Im stuck and seek help. This is a log after one of the unsuccessful launch attempts: https://pastebin.com/Md4yW3yw
      For any kind of suggestions or additional information request I'd be very thankful
      Okay, fortunately under this post's recommended threads I've found another new thread which stated a similar problem: 
       
      The solution right there seems to do the job (at least temporarily), but still, I'd like to know the core of the problem, for example - why 8u251 works and 8u51 doesn't?
      Hope this helps someone someday
    • By Capio13
      So I have been working on a modpack of mine lately, recently switched computers to a higher end one, and here I am working on the first update I have done for this modpack since I got the new pc. I make sure to test to make sure all the mods work together in a test pack, and then I decide to zip up the mods,scripts(for crafttweaker), llibrary, coremods, config, cache, bin, and the .mixin.out folder into one neat folder like I have done in the past. So here i go and upload the folder onto dropbox and test downloading the update through the technic launcher, instead of the name of the folder, it starts downloading a folder with the name of the version it is on the website, and when I launch it, it is just a fresh install of forge with none of the mods or anything. I don't know what went wrong in the process, but I need some help. Here's the DL Link and the modpack link.
      DL link: https://www.dropbox.com/s/nn2zia9l4g9u6sa/EOI 0.2.0.zip?dl=0
      Modpack Link: https://www.technicpack.net/modpack/eoi-devbuild.1783065

      TLDR; It is defaulting to a fresh install of forge with no mods even though I have done the exact same thing I did in the past.
    • By Zvery
      Hi, My modpack seems to not be opening whenever I press play. It takes me out of the Technic screen at first then it goes back to the Technic screen here are my logs
      cX8tNvDL (3).txt
×
×
  • Create New...