Jump to content

My server wont start up because of an insta-crash.


Recommended Posts

Hello, I don't know where else to put this so here we go...

My modpack server keeps crashing every time I launch it up. My pack is called Industacraft if the mod list is not apparent in the bottom part of the crash.

Any help would be cherished, thanks in advance!

 

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109 ---- Minecraft Crash Report ----
// Don't do that.

Time: 2/13/15 3:51 AM
Description: Exception in server tick loop

cpw.mods.fml.common.MissingModsException
    at cpw.mods.fml.common.Loader.sortModList(Loader.java:239)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:476)
    at cpw.mods.fml.server.FMLServerHandler.beginServerLoading(FMLServerHandler.java:86)
    at cpw.mods.fml.common.FMLCommonHandler.onServerStart(FMLCommonHandler.java:351)
    at ho.c(DedicatedServer.java:86)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:613)
    at fy.run(ThreadMinecraftServer.java:16)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- System Details --
Details:
    Minecraft Version: 1.4.7
    Operating System: Linux (amd64) version 3.13.0-30-generic
    Java Version: 1.7.0_67, Oracle Corporation
    Java VM Version: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 543541168 bytes (518 MB) / 1012727808 bytes (965 MB) up to 3160211456 bytes (3013 MB)
    JVM Flags: 8 total; -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:ParallelGCThreads=7 -XX:+AggressiveOpts -XX:MaxPermSize=256M -Xms1G -Xmx3G
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Suspicious classes: FML and Forge are installed
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    CraftBukkit Information:
Running:
Failed to handle CraftCrashReport:
java.lang.NullPointerException
    at org.bukkit.Bukkit.getName(Bukkit.java:68)
    at org.bukkit.craftbukkit.v1_4_R1.CraftCrashReport.call(CraftCrashReport.java:19)
    at l.a(CrashReportCategory.java:103)
    at a.h(CrashReport.java:59)
    at a.<init>(CrashReport.java:41)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:661)
    at fy.run(ThreadMinecraftServer.java:16)

    FML: MCP v7.26a FML v4.7.35.556 Minecraft Forge 6.6.2.534 0 mods loaded, 0 mods active
    mcp [Minecraft Coder Pack] (minecraft.jar) Unloaded
    FML [Forge Mod Loader] (coremods) Unloaded
    Forge [Minecraft Forge] (coremods) Unloaded
    ae2tech [AE2 Tech Add-On] (AE2TechAddOn-1.7.10-1.0-b73-universal.jar) Unloaded
    BiblioCraft [biblioCraft] (BiblioCraft[v1.7.5][MC1.7.10].jar) Unloaded
    CarpentersBlocks [Carpenter's Blocks] (Carpenter's Blocks v3.3.4.2 - MC 1.7.10 (2).jar) Unloaded
    chisel [Chisel] (Chisel-1.7.10-1.5.6b.jar) Unloaded
    CoFHCore [CoFH Core] (CoFHCore-[1.7.10]3.0.0B6-32.jar) Unloaded
    colorblocks [Color Blocks] (Color-Blocks-Mod-1.7.10.jar) Unloaded
    ComputerCraft [ComputerCraft] (ComputerCraft1.65.jar) Unloaded
    CraftHeraldry [CraftHeraldry] (CraftHeraldry 1.1.3.jar) Unloaded
    customnpcs [CustomNpcs] (CustomNPCs_1.7.10b.jar) Unloaded
    flansmod [Flan's Mod] (Flans-Mod-1.7.10.jar) Unloaded
    GrygrFlzr_GlowstoneWire [Glowstone Wire] (GlowstoneWire-1.7.x-1.0.2.113.jar) Unloaded
    inventorytweaks [inventory Tweaks] (InventoryTweaks-1.59-dev-152.jar) Unloaded
    Mantle [Mantle] (Mantle-1.7.10.jar) Unloaded
    MineFactoryReloaded [MineFactory Reloaded] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatAppliedEnergistics [MFR Compat: Applied Energistics] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatAtum [MFR Compat: Atum] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatBackTools [MFR Compat: BackTools] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatBuildCraft [MFR Compat: BuildCraft] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatChococraft [MFR Compat: Chococraft] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatExtraBiomes [MFR Compat: ExtraBiomes] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatForestry [MFR Compat: Forestry] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatForgeMicroblock [MFR Compat: ForgeMicroblock] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatIC2 [MFR Compat: IC2] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatMystcraft [MFR Compat: Mystcraft] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatPams [MFR Compat: Pam's Mods] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatProjRed [MFR Compat ProjectRed] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatRailcraft [MFR Compat: Railcraft] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatRP2 [MFR Compat: RP2] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatSufficientBiomes [MFR Compat: Sufficient Biomes] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatThaumcraft [MFR Compat: Thaumcraft] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatThermalExpansion [MFR Compat: Thermal Expansion] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatTwilightForest [MFR Compat: TwilightForest] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    MineFactoryReloaded|CompatVanilla [MFR Compat: Vanilla] (MineFactoryReloaded-[1.7.10]2.8.0RC3-591.jar) Unloaded
    cfm [?6MrCrayfish's Furniture Mod] (MrCrayfishFurnitureModv3.3.5(1.7.10).jar) Unloaded
    NetherOres [Nether Ores] (NetherOres-[1.7.10]2.3.0RC3-84.jar) Unloaded
    RedstonePasteMod [Redstone Paste] (RedstonePasteMod-1.7.10-1.6.2.jar) Unloaded
    securitycraft [securityCraft] (SecurityCraft v1.6.0 for 1.7.10.jar) Unloaded
    Thaumcraft [Thaumcraft] (Thaumcraft-1.7.10-4.2.0.1.jar) Unloaded
    ThermalExpansion [Thermal Expansion] (ThermalExpansion-[1.7.10]4.0.0B6-16.jar) Unloaded
    ThermalFoundation [Thermal Foundation] (ThermalFoundation-[1.7.10]1.0.0B3-8.jar) Unloaded
    VoltzEngine [Voltz Engine] (VoltzEngine-1.7.10-0.0.0b50-dev.jar) Unloaded
    appliedenergistics2 [Applied Energistics 2] (appliedenergistics2-rv0-stable-10.jar) Unloaded
    BuildCraft|Silicon [bC Silicon] (buildcraft-6.2.0.jar) Unloaded
    BuildCraft|Core [buildCraft] (buildcraft-6.2.0.jar) Unloaded
    BuildCraft|Transport [bC Transport] (buildcraft-6.2.0.jar) Unloaded
    BuildCraft|Builders [bC Builders] (buildcraft-6.2.0.jar) Unloaded
    BuildCraft|Energy [bC Energy] (buildcraft-6.2.0.jar) Unloaded
    BuildCraft|Factory [bC Factory] (buildcraft-6.2.0.jar) Unloaded
    Growthcraft|Apples [Growthcraft Apples] (growthcraft-apples-1.7.10-2.1.0.jar) Unloaded
    Growthcraft|Bamboo [Growthcraft Bamboo] (growthcraft-bamboo-1.7.10-2.1.0.jar) Unloaded
    Growthcraft|Bees [Growthcraft Bees] (growthcraft-bees-1.7.10-2.1.0.jar) Unloaded
    Growthcraft|Cellar [Growthcraft Cellar] (growthcraft-cellar-1.7.10-2.1.0a.jar) Unloaded
    Growthcraft [Growthcraft] (growthcraft-core-1.7.10-2.1.0a.jar) Unloaded
    Growthcraft|Fishtrap [Growthcraft Fishtrap] (growthcraft-fishtrap-1.7.10-2.1.0a.jar) Unloaded
    Growthcraft|Grapes [Growthcraft Grapes] (growthcraft-grapes-1.7.10-2.1.0.jar) Unloaded
    Growthcraft|Hops [Growthcraft Hops] (growthcraft-hops-1.7.10-2.1.0.jar) Unloaded
    Growthcraft|Rice [Growthcraft Rice] (growthcraft-rice-1.7.10-2.1.0a.jar) Unloaded
    mcheli [MC Helicopter] (mcheli) Unloaded
    secretroomsmod [The SecretRoomsMod] (secretroomsmod-1.7.10-4.7.1.372.jar) Unloaded
    warstuff [WarStuff] (warstuff-1.4.jar) Unloaded
    Profiler Position: N/A (disabled)
    Is Modded: Definitely; Server brand changed to 'mcpc,craftbukkit,forge,fml'
    Type: Dedicated Server (map_server.txt)

 

Link to post
Share on other sites
  • Discord Moderator

Something is gravely wrong:

Minecraft Version: 1.4.7
CoFHCore [CoFH Core] (CoFHCore-[1.7.10]3.0.0B6-32.jar) Unloaded

All your mods are for 1.7.10, and it looks like your pack settings are for MC 1.7.10, and the version of Forge in your pack (/bin/modpack.jar) is for 1.7.10. However, the crash report states it is launching Forge for 1.4.7. You must have the wrong version of Forge which you are using to start your server.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Nyrab
      I'm trying a new modpack
      The version is 1.10.2
      I tried to remove some mods and still don't work
       
      Modpacklog.zip
    • By zoezp
      I am new to making modpacks and this is the first one I ever made so I watched some youtube tutorials and it worked well until I tried to launch the modpack and It started as vanilla but when I checked the modpack options it had the mods installed and they were all in the folder. I tried to fix it and tried out things like renaming the files but nothing worked for me so thats why I am here asking for your help.
      I don't know what the problem is at this points so I would really like some help.
      Here is the dropbox link I used to upload the modpack: https://www.dropbox.com/s/u2qfs8zuco8fh39/pixelmon fun.zip?dl=1
      Here is the modpack download link: https://www.technicpack.net/modpack/pixelmon-2780956.1833394
       
      If any more info is needed just ask and I'll provide it if I can.
      Thanks in advance! 
    • By FlameOregu
      I'm trying to play a modpack with my little brother and all of a sudden it only launches vanilla! Please help quick. I'm using FHM Stoneblock 2 if that helps.
    • By YTDannydan
      So i made a modpack, and i have tried linking my file on several different websites, dropbox, MediaFire and Google Drive. but the modpack settings keep saying: "The modpack location you specified is not a valid zip file." can someone please help me? i want to make a server of this modpack in future but for the last couple days i have been struggling!
    • By seraphicsong
      I have a folder, inside are config, mods, and bin folders. The mods are in the mods folder, I have a forge installer renamed to modpack.jar inside the bin folder. I zip the config, mods, and bin folder and then upload them to dropbox. I take the download link from dropbox, and change the end number from 0 to 1. I put it in the modpack location of the edit modpack on the technic website. However, when i try to install the modpack from technic launcher, I get vanilla Minecraft when it opens. Please help!
×
×
  • Create New...