Jump to content

Help Modpack Won't Open


AlexPyro
 Share

Recommended Posts

openblock mod needs a coremod called openmodlib and some of the jar files look funky to me. make sure all the mods are up to date with ur forge and make sure that you download them at reputable site. and carefully read the install directions for the mod. i had trouble with that when i was making my modpack. i also tried every mod one at a time as i added them to my mods folder to make sure everything was compatible. its a slow process but i learned alot about which mods dont fit well together. hehe Good Luck. Cant wait to play ur pack!! :)

Link to comment
Share on other sites

  • Discord Moderator
  • Copy.com links need to have "?download=1" (without quotes) appended to them in order to function properly.
  • Your pack version is 1.0. Make sure you are incrementing this when you update your modpack archive.
  • Forge for MC 1.7.10 does not use a /coremods/ folder in any way. All mods belong in or below the /mods/ folder.
  • You have only one of the three required mods files for Galacticraft. You need GalacticraftCore, GalacticraftPlanets, and MicdoodleCore
  • You need to get your IC2 build from the developers: http://ic2api.player.to:8080/job/IC2_experimental/
  • You need to get your ChickenBones mods from the author: http://chickenbones.net/Pages/links.html
  • Your ProjectRed is woefully out of date.
  • REI Minimap crashes with some mods. I recommend a combination of LiteLoader and VoxelMap.
  • You should update to AE2rv2

Fix these issues and come back if you are still having troubles.

Link to comment
Share on other sites

 

  • Copy.com links need to have "?download=1" (without quotes) appended to them in order to function properly.
  • Your pack version is 1.0. Make sure you are incrementing this when you update your modpack archive.
  • Forge for MC 1.7.10 does not use a /coremods/ folder in any way. All mods belong in or below the /mods/ folder.
  • You have only one of the three required mods files for Galacticraft. You need GalacticraftCore, GalacticraftPlanets, and MicdoodleCore
  • You need to get your IC2 build from the developers: http://ic2api.player.to:8080/job/IC2_experimental/
  • You need to get your ChickenBones mods from the author: http://chickenbones.net/Pages/links.html
  • Your ProjectRed is woefully out of date.
  • REI Minimap crashes with some mods. I recommend a combination of LiteLoader and VoxelMap.
  • You should update to AE2rv2

Fix these issues and come back if you are still having troubles.

 

how do i know what version the IC2 mods are from the website link you provided? I apologise if i am being incredibly stupid.

Link to comment
Share on other sites

  • Discord Moderator

how do i know what version the IC2 mods are from the website link you provided? I apologise if i am being incredibly stupid.

 

The only real way is to keep abreast of the change log so you notice when they switch to a new version. That being said, the current version is for 1.7.10. The page I linked is the build server for the developers so always current and up to date.

Link to comment
Share on other sites

The only real way is to keep abreast of the change log so you notice when they switch to a new version. That being said, the current version is for 1.7.10. The page I linked is the build server for the developers so always current and up to date.

 

 

i did all the stuff, i completely removed redpower for now, i will re add it later i just couldnt be arsed right now, i also removed reis mini map and removed the coremods folder but it made a new one so i assume its supposed to be there or atleast the technic pack wants it to be

Link to comment
Share on other sites

  • Discord Moderator
  • You haven't fixed your download URL.
  • You haven't incremented your pack version even though you changed the modpack archive.
  • You are now including too much stuff in your pack archive. It should only contain the folders: bin, config, Flan, mods. The /bin/ folder should only contain the file modpack.jar.
  • You haven't moved the contents of /coremods/ over to /mods.
  • You have a 1.6.4 version of CoFHCore in the /coremods/ folder.
  • CoFHLib is for mod developers only and shouldn't be in a pack.
  • You haven't updated AE2.
  • Your Forestry mod is out of date.
  • You have MFFS but none of the dependency mods which Calclavia requires.
  • You have Numina but not Modular Powersuits, the only mod which uses it.

Please address all the points I have made in both posts before continuing.

Link to comment
Share on other sites

 

  • You haven't fixed your download URL.
  • You haven't incremented your pack version even though you changed the modpack archive.
  • You are now including too much stuff in your pack archive. It should only contain the folders: bin, config, Flan, mods. The /bin/ folder should only contain the file modpack.jar.
  • You haven't moved the contents of /coremods/ over to /mods.
  • You have a 1.6.4 version of CoFHCore in the /coremods/ folder.
  • CoFHLib is for mod developers only and shouldn't be in a pack.
  • You haven't updated AE2.
  • Your Forestry mod is out of date.
  • You have MFFS but none of the dependency mods which Calclavia requires.
  • You have Numina but not Modular Powersuits, the only mod which uses it.

Please address all the points I have made in both posts before continuing.

 

thanks sorry i feel incredibly stupid

Link to comment
Share on other sites

 

  • You haven't fixed your download URL.
  • You haven't incremented your pack version even though you changed the modpack archive.
  • You are now including too much stuff in your pack archive. It should only contain the folders: bin, config, Flan, mods. The /bin/ folder should only contain the file modpack.jar.
  • You haven't moved the contents of /coremods/ over to /mods.
  • You have a 1.6.4 version of CoFHCore in the /coremods/ folder.
  • CoFHLib is for mod developers only and shouldn't be in a pack.
  • You haven't updated AE2.
  • Your Forestry mod is out of date.
  • You have MFFS but none of the dependency mods which Calclavia requires.
  • You have Numina but not Modular Powersuits, the only mod which uses it.

Please address all the points I have made in both posts before continuing.

 

okay i addressed all those issues, and changed from copy.com to dropbox, so if theres a problem unzipping it thatll be it. when it installs it creates more folders in the bin and possibly a coremods folder so I dont know about that. i also incremented the version. http://api.technicpack.net/modpack/alacticraft

Link to comment
Share on other sites

  • Discord Moderator
  • Your OpenBlocks and OpenModsLib versions don't match and it looks like your OpenBlocks mod isn't from the mod author.
  • You have the IC2 API instead of the actual mod. You need the mod, not the API.
  • Modular Force Fields (MFFS) requires Resonant Engine (which is clearly stated on the mod author's download page). You also have two different MFFS JAR files in your /mods/ folder.
  • You still haven't properly updated your AE2. You should be using AE2rv2_beta8
  • Your TeamCoFH mods do not match versions. (CoFHCore, MFR, NetherOres, ThermalExpansion, ThermalFoundation)

Please read over the follow posts for more information about the process of getting mods and building your pack:

I stopped testing at this point. Please go over all your mods again after reading those posts and address any issues as you go long. Come back here after that if you are still having troubles.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By NVRGP22
      Hello there. I have been fighting this issue for a while now, but now im mad enough to make a forum post about this. After 2 weeks, i still cannot find any way to solve this issue.
      I have updated windows, used DDU to delete my gpu driver, reinstalled my gpu driver, updated my bios, deleted then reinstalled every version and instance of minecraft, java and every launcher, Set the technic launcher to the newest version of java, oldest version of java. Tried running the program from an ssd, checked with another gpu, still nothing. I have sent the logs to the discord bot, but it found nothing out of the ordinary [ Im Matt Moody#0101 ]. I have no idea what is happening now.

      DxDiag.txttechniclauncher_2021-07-24.log
    • By 4net_E
      LAUNCHER VERSION: v4.664
      OPERATING SYSTEM: macOS 10.14.6
      JAVA VERSION: Oracle 1.8.0_261 64-Bit
      ANTIVIRUS: none
      recently I tried to play some modpacks, but i couldnt start any of them. Every time I wanted to launch them, icon of the modpack showed up in taskbar, window popped up, but after approximately a second, it had crashed.
      I tried to solve this problem by myself, but I didnt manage to success. The closest Ive got to solution was in this thread :
      However, there is a solution linked on another forum thread, but that link is probably corrupted or something, as it just redirected me to the same thread all over again. Thus Im stuck and seek help. This is a log after one of the unsuccessful launch attempts: https://pastebin.com/Md4yW3yw
      For any kind of suggestions or additional information request I'd be very thankful
      Okay, fortunately under this post's recommended threads I've found another new thread which stated a similar problem: 
       
      The solution right there seems to do the job (at least temporarily), but still, I'd like to know the core of the problem, for example - why 8u251 works and 8u51 doesn't?
      Hope this helps someone someday
    • By CStan96
      I'm at a loss. I've been playing my modpack for a month now and after updating to 1.16.5, it fails to launch as it loads Minecraft assets. I managed to get it to launch once, but it was vanilla Minecraft.

      RAM: 8gb
      MC Version: 1.16.5
      Forge: forge-1.16.5-36.1.0-installer
       
      Pastebin won't work (404 error) so here's the error log:
       
    • By Capio13
      So I have been working on a modpack of mine lately, recently switched computers to a higher end one, and here I am working on the first update I have done for this modpack since I got the new pc. I make sure to test to make sure all the mods work together in a test pack, and then I decide to zip up the mods,scripts(for crafttweaker), llibrary, coremods, config, cache, bin, and the .mixin.out folder into one neat folder like I have done in the past. So here i go and upload the folder onto dropbox and test downloading the update through the technic launcher, instead of the name of the folder, it starts downloading a folder with the name of the version it is on the website, and when I launch it, it is just a fresh install of forge with none of the mods or anything. I don't know what went wrong in the process, but I need some help. Here's the DL Link and the modpack link.
      DL link: https://www.dropbox.com/s/nn2zia9l4g9u6sa/EOI 0.2.0.zip?dl=0
      Modpack Link: https://www.technicpack.net/modpack/eoi-devbuild.1783065

      TLDR; It is defaulting to a fresh install of forge with no mods even though I have done the exact same thing I did in the past.
    • By Zvery
      Hi, My modpack seems to not be opening whenever I press play. It takes me out of the Technic screen at first then it goes back to the Technic screen here are my logs
      cX8tNvDL (3).txt
×
×
  • Create New...