HenrikoMagnifico

My custom modpack won't open in the Technic Launcher.

Recommended Posts

So, I just made myself my first modpack yesterday (YaoPack). Everything seemed to go well, until I tried to download and play my modpack from the Technic Launcher. It loads the assets and everything, but it doesn't launch the game. It just closes and takes me back to the Technic Launcher! it starts up, but with no mods/forge installed! I have the link to the modpack here; http://www.technicpack.net/modpack/yaopack.617582

The download link that I used to upload the modpack: https://www.dropbox.com/s/2kj2zcuu8s4tgn5/YaoPack modpack.zip?dl=1

Anyone that knows what the problem is? :)

 

EDIT:
Also, the pack includes quite a few mods (I think it's 15). It might be one of them that are causing the problem, but I rather think it's something with my setup and if I placed all the files in their correct folders. Anyone who knows?

Share this post


Link to post
Share on other sites

This thread belongs in Platform Pagoda. Hopefully a forum mod/admin will move it.

  • The contents of your modpack archive are in a subfolder. The required folders (bin, config, Flan, mods, shaderpacks) must be at the top level of the folder structure inside the modpack archive.
  • The ZIP library used by the technic launcher does not like the character "§". You will need to remove that character from any file names (in the shaderpacks folder).
  • The shaderpacks folder contains another folder named shaderpacks under which the actual shader ZIP files exist. The ZIP files need to be moved up one folder.
  • Resource packs should not be included in the modpack archive and should always remain zipped (not extracted).
  • The legacyjavafixer mod is not required and should be removed.
  • The NEI mod should be updated to the latest 1.7.10 version available.

Share this post


Link to post
Share on other sites

This thread belongs in Platform Pagoda. Hopefully a forum mod/admin will move it.

  • The contents of your modpack archive are in a subfolder. The required folders (bin, config, Flan, mods, shaderpacks) must be at the top level of the folder structure inside the modpack archive.
  • The ZIP library used by the technic launcher does not like the character "§". You will need to remove that character from any file names (in the shaderpacks folder).
  • The shaderpacks folder contains another folder named shaderpacks under which the actual shader ZIP files exist. The ZIP files need to be moved up one folder.
  • Resource packs should not be included in the modpack archive and should always remain zipped (not extracted).
  • The legacyjavafixer mod is not required and should be removed.
  • The NEI mod should be updated to the latest 1.7.10 version available.

​Wow! Thank you very much!

I

Share this post


Link to post
Share on other sites

@Dwoops:

The correct folder structure inside the archive will look like this:

--- bin
     |
     --- modpack.jar
--- config
     |
     --- (all your config files)
--- mods
     |
     --- (all your mods)

Being in a subfolder means that the folders: bin, config, mods , are inside another top level folder. That would be bad.

Share this post


Link to post
Share on other sites

okay, i need help. I know barley anything about files and coding and i tried making a modpack.

Heres the download link:

https://dl.dropbox.com/s/6rlc3ryilaavnng/Vivo Pack.zip?dl=0

Heres the modpack link:

http://api.technicpack.net/modpack/vivos-buildcraft-pack

when i launch it, everything is good, the mojang logo appears then it crashes and takes me back to the launcher :(

i need help please and thank you!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Similar Content

    • By Underscore
      It was as simple as that. The game closed immediately after the world generated in the Shivaxi RLCraft modpack. The console says, "java.lang.OutOfMemoryError." I have no idea what is happening, I just want to play this modpack but nothing at all is working right anywhere. Your basic answers will probably not solve the issue.

    • By Gamen4Bros
      The launcher Console said this: 
       
      [B#456] SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
      [B#456] SLF4J: Defaulting to no-operation (NOP) logger implementation
      [B#456] SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
      [B#456] Starting download of https://www.dropbox.com/s/ic0nnif50zxe7f1/MangoCraft.zip?dl=1, with 3 tries remaining
      [B#456] File version.json not found in C:\Users\djtri\AppData\Roaming\.technic\modpacks\mangocraftpack\bin\modpack.jar
       
      Link to modpack: https://www.dropbox.com/s/ic0nnif50zxe7f1/MangoCraft.zip?dl=1
      modpack name: mangocraftpack
    • By JragonGamer
      My modpack won't launch and crashes when I hit play.
      Here's the log: https://pastebin.com/Xg18gxSg
    • By Leafzy
      hello lately when i wanna play a modpack it crashes it happens like this i can download every modpack no problem but when i click on play it loads en at the end of loading it stops  and crashes the modpacks just wont open i tried many things but nothing worked can somebody me pls 


      log files