Jump to content

HELP | Custom modpack running extremely slow


omrizod
 Share

Recommended Posts

I got my old modpack fixed thanks to the help of some people here in the forums, but now it runs really slow.

It runs in about 2 frames per seconds. It used to run pretty well, and I didn't really change anything since then (except fixes)

Also, the main menu is slow too. When I place the mouse cursore over an open (for example: join server) it changes the button to blue-ish only after about two seconds (which it should immediately).

And my friend can barely have it running, and his case is worse. It crashes for him.

I tried running it with pretty much nothing else open and playing on the lowest graphics settings, still the same.

 

My custom modpack: Modders In Space (by the way, it's hidden)

http://www.technicpack.net/modpack/modders-in-space.340368

 

I have 64 bit computer, windows, and java version(s), and 16 GB RAM, so those are not the problem.

I noticed it fills up my CPU pretty crazy-ly.

But again, my computer isn't the problem, because I used to run it pretty well while also having a server of it running at the same time, and a few friends with me.

Please help me.

Edited by omrizod
Forgot to add a link to my modpack
Link to comment
Share on other sites

  • Moderators

How much ram have you allocated to Java in the tekkit launcher settings?

iIf you're below 3GB, bump it up to that. Don't go crazy high, it's counter productive. 

If this isn't your issue, add the appropriate version of Fastcraft. 

Link to comment
Share on other sites

  • Discord Moderator
  • Why are you using old versions of some mods? Most (all?) 1.6.4 mods are frozen at this point so using a multi-verions-old copy of Treecapitator (for instance) is usually a bad idea.
  • You should probably turn off all the "udate checkers" in the configs for any mods you can since it they report updates which are for a newer version of MC/Forge.
  • I'm able to start your pack with 2G allocated in the Launcher (8G physical in the system). Responsiveness in the menus is what I would normally expect, and I get 35-60 FPS in the limited testing I did inside an SSP world. I suspect you have something going on with your graphics card or drivers.
Link to comment
Share on other sites

I have 4 GB set in the launcher. I also tried to run it with 7 GB, didn't help.

 

(to plowmanplow) Maybe I should vaccum clean my computer hardware again. Is there another way I can check about my graphics card before doing that?

And thanks a lot for the help :D

Link to comment
Share on other sites

  • Discord Moderator

If you are using an embedded (included in the motherboard) graphics card those can sometimes be too underpowered for complicated packs. If you have almost any add-in video card you shouldn't be seeing that poor performance.

Link to comment
Share on other sites

I think it's not part of my motherboard. Pretty sure it's by it's own (if that's how you say it). But again, I used to run it pretty smoothly, with a server and a few friends at the same time. I think I'm gonna vaccum clean my computer today. Also, I just finished cleaning up my desktop. I had a lot of files and shortcuts, and it might have effected the performence. But I'm not sure how much does it matter.

Wait, I just thought about something. My screen resolution is set to 125%, because I used my TV screen for my computer for a while until a few weeks ago. Maybe that can be a problem?

(I can't upload another photo because it weighs too much, so I uploaded it to dropbox)

https://www.dropbox.com/s/rrbrifpd4ri5da7/Screen Resolution Is Set To 125%.png?dl=1

Here's a screenshot of my graphic card's properties window:

Graphics_Card_Adapter_Information.thumb.

Edited by omrizod
Some unfunctional photos were at the bottom without purpose
Link to comment
Share on other sites

Ok, so I vaccum cleaned my computer today. I also updated Java to the latest 64 bit version, and tried to minimize the quality and maximize the performence with AMD's Catalyst Control Center. Maybe it got improved just a bit. But still, can't play like that. 1-3 frames per second. I tried playing Tekkify, runs pretty smoothly on the official server from the main menu, and the single player is a little slower, but still pretty acceptible. There was a mod in my in-game mod list, which was marked in red. I tried running the game without it, doesn't make it any better.

Please help me.

Link to comment
Share on other sites

AetherPirate - Yes.

Maybe it's because I used to have it on the old launcher, and there's some files left in the system, or something?

I'll try deleting it and redownloading.

Also, I played The Witcher 3 a few days ago. It run pretty smoothly. So I really don't think the hardware is the problem.

EDIT:

Doesn't help. I opened Task Manager on my second monitor, the CPU is always between 65-100, and there's nothing else open that takes CPU, I checked. Also, I'm running it on 7 GB RAM in the settings.

Edited by omrizod
Tested it. Now I have to update you
Link to comment
Share on other sites

I fixed that, I just had to delete Dynamic Lights from the server.

Now I can't use either "Save", "Stop", or "op *name*". The OP text file doesn't help either.

Please help me with that.

Also, I'll check about the Smart Moving mod.

Link to comment
Share on other sites

  • Discord Moderator

Please stop posting in the other thread. It is very distracting and I've already mentioned that before.

What is the context for you not being able to run those commands?

  • Where are you trying to use them? (client or server console?)
  • What are you using as your server binary?
  • Are you self-hosting this or is it running on some remote host?
  • What shows up in the server console when you try to use these commands?
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By 2Playerss
      Feel that the Magic of Sorrows are around us, We Live in Nature we Provide Air to You!
      This, Pack is very cool I hand picked all the mods myself and combined them to create "WitcherCraft" This pack is very small and lightweight, can run on any computer no matter if its a potato or office laptop.
      Technic Page - https://www.technicpack.net/modpack/witchercraft-12-beta.1893475 
      DIscord Page - https://discord.gg/hgnfhdS8vx

    • By Omega_Volta
      I was planning on using some mods, but when I opened the modpack I intended to use, it just shut down and sent me back to the launcher screen. 
      I've tried removing the mods, uninstalling and reinstalling the modpack, updating my launcher, updating java, and restarting my computer, to no avail.
      Down below is the log in pastebin:
      https://pastebin.com/y64AeY0t
    • By BloodScythe
      https://pastebin.com/kRLp5Y2Y These are the error msgs, I have already tried re installing the pack, restarting the launcher, updating the pack, any more ideas?
    • By M3veronMast3r
      Hello, I didn't know where to put this Thread, sorry for that.
      My Problem is that i want to create more than only 5 Modpacks. I have different Packs in different Version and i need them all and i dont want to create constantly an new account just to create a new Modpack. I dont understand why this Action is limited to 5 Modpacks. It makes no sense to me. Is there any way to create more than only 5?
      Hope you can help me. ~M3veronMast3r
    • By NVRGP22
      Hello there. I have been fighting this issue for a while now, but now im mad enough to make a forum post about this. After 2 weeks, i still cannot find any way to solve this issue.
      I have updated windows, used DDU to delete my gpu driver, reinstalled my gpu driver, updated my bios, deleted then reinstalled every version and instance of minecraft, java and every launcher, Set the technic launcher to the newest version of java, oldest version of java. Tried running the program from an ssd, checked with another gpu, still nothing. I have sent the logs to the discord bot, but it found nothing out of the ordinary [ Im Matt Moody#0101 ]. I have no idea what is happening now.

      DxDiag.txttechniclauncher_2021-07-24.log
×
×
  • Create New...