Jump to content

Help needed on installing soldier on windows

Recommended Posts

I need help installing soldier on windows. I am making a big modpack, but it would be a lot easier if I had soldier! Also, soldier adds some extra features that i would like. 

Edited by danclay

Share this post

Link to post
Share on other sites

Hi there

It is called solder (not soldier), if you refer to TechnicSolder.

There are very few people (check google and youtube) that installed TechnicSolder on Windows. I personally think that would be extra effort.
I have no windows experience, but installing WAMP or WNMP stack (Windows, Apache or NGNIX, MySQL and PHP) might be a good start. I personally would not use the MySQL part but the inbuilt database of TechnicSolder...would make it a little easier I'd guess.

Additionally...you really want a windows server being online and exposed to the internet 24/7?

Good luck anyway....sorry I cannot be of more help

Share this post

Link to post
Share on other sites

And i know it says,"


This application is intended for experienced system administrators and is not intended to be setup on a local home computer.

" I just want to "try" it! :roflolmao:  I might hold off on "trying" it. I want some people who have used solder to tell me more about it before i "try" it. 

Share this post

Link to post
Share on other sites

Yes, it is possible to get Solder running under Windows. No, it is not supported on that platform. On a lark I decided to set it up just to see what happens (some time ago). There are numerous points where things are different from the supported (Linux) platform instructions and without prior experience deploying service level applications on multiple platforms most users will not be successful.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By xPriority
      Hello, so today i got a new laptop and installed mc launcher on it and wanted to install some modpacks. When i clicked the modpacks section there was no info about any modpack as you can see in the picture I attached, nothing was happening if I was trying to install any of the modpacks. I tried searching for other modpacks but nothing as well. I hope there is a fix to this. Thanks!

    • By amvandreel
      A few days ago I downloaded Minecraft Java Edition in order to to play with Shivaxi RlCraft, with my friends.  I have been unable to launch RlCraft for this entire time, and have tried waiting up to 20 minutes each time.  I currently have 64-bit Java downloaded and 3.5 GB allotted.  I am not sure what else I can do to make this work, and I would love to know that I didn't waste $27 on this process.  Any help would be greatly appreciated.
    • By simovero
      Hi guys this is my very first post here and i wanted to ask you what was going on with the modpack i have created recently!!
      Whenver i try ti run minecraft the mods won't load and it will just be a vanilla minecraft. I have no idea of what i am supposed to do, hopefully i will get some help
      This is the link so you can check: https://www.dropbox.com/s/r4iw536knz7vb9v/redengineforgestock.zip?dl=0
      Sorry for my english since im not a native speaker.
    • By scooby9999
      I am very new to this platform, I got it today, so 
      Version: 4.534
      This is definitely a launcher problem. I sort of downloaded 4 versions of technic, which was probably my first mistake and sounds stupid, but here I am anyway. I opened up the first one I installed, and it was offline. It gets to the point where it says "Querying update stream 0%", stops there for a while, then opens the launcher. Upon opening, it says Discover is unavailable, news is a black screen, and it won't let me open modpacks on the launcher. I've read through like at least 8 different other columns on this help trying:
      -Uninstalling and reinstalling Technic.
      -Turning off my firewall for 10 minutes and restarting technic.
      -Using a VPN to install and boot up technic.
      -Running as administrator.
      -Restarting my computer/ Turning off my computer, waiting for 10 seconds, then turning back on.
      -Turning on beta streaming mode
      -A combination of any of these.
      My logs are really long, and I don't know where specifically I should be looking, so I can produce my logs if needed.
      I get this error every single time, and I just don't understand why. I've been searching through all the other posts about why this is happening, but nothing has worked. I had installed technic on a different computer a while ago that also ran windows 10, but now technic refuses to work.

    • By _Mikeatron_
      So today I came across this issue where my friends were suddenly unable to download my custom modpack this morning. Keep in mind I have not updated or changed anything about the modpack, it just stopped working. I attached the error in an image and this occurs when my friends try to update or download the modpack. Weirdly enough it does not affect me and I am successfully able to update  my modpack. Any help understanding this error would be appreicated. Also I tested the download link of both dropbox and onedrive. The same issue persist.

  • Create New...