Sign in to follow this  
Shikino

Towny Isnt Working with Tekkit? Urgent help needed

Recommended Posts

Alright, ill try and make this short. Ive been used to having normal vanilla servers for about 1½ years now, and i know how they work and how plugins work.

Its my first time playing around with tekkit, but i think i get the basic idea of it all. My tekkit server build is the 3.0.4 version (rec build ya?).

Now, the issue is, that i dont seem to be able to get Towny working, no matter what I try and do :/

Ive installed latest bukkit versions, same with tekkit ones, also tried downgrading (also the actual towny plugin), and it still dosent work at all >.<

I did a bit of researching and have therefor already tried to put the bypass bukkit check on towny, and that still dosent work. Towny jumps right into Safe Mode then :)

Anyone who would be able to give me a idea, or perhaps, guide me through what im doing wrong?

Id be really grateful!

Share this post


Link to post
Share on other sites

Okay, I'm guessing the issue here is that you're using 3.0.4 Tekkit and the latest version of the plugins.

FYI:

Tekkit 3.0.4 - Requires compatability with CB 1.2.5 R1.3

Tekkit 3.1.1 - Requires compatability with CB 1.2.5 R4

Tekkit 3.1.2 - Should be compatable with the latest as well

I'm assuming you're running into an issue with a R4 plugin that is not compatable with R1.3.

Personally, for ease of setup on your end, and to go ahead and be one-step closer to the latest in Tekkit (Works fine, I'm running it on a live server), I'd suggest at the minimum installing Tekkit 3.1.1.

Share this post


Link to post
Share on other sites

Ive tried with 3.1.1 and 3.1.2 already, and i got the same issues. Of what i recall atleast :o

So, youre saying, if i upgraded to 3.1.1 and installed the latest version of the Towny Plugin, put it on bypass, then i shouldnt have nay issues or what so ever?

Share this post


Link to post
Share on other sites

Well, I can't say that will specifically solve your issue as I don't actually use Towny myself. Just wanted to make sure you were aware that 3.0.4 would require backwards-compatible or older plugins.

Share this post


Link to post
Share on other sites

Yea, i just tried with a towny build running r1.0 (that would work if im not mistaken, on the 3.0.4 yea?), and i still get the same errors >.< and if i understood correctly, that shouldnt have been a problem?

Oh you dont use towny? is there like a really good alternative for it? Id just like something that makes protecting things for players easy, and perhaps a way users can tp to each others region with a /t spawn etc (as you do in towny), and a way for players to interact, if theres better solutions, im open for ideas :)

Share this post


Link to post
Share on other sites

Again, can't comment any further on the errors because I'm not familiar with Towny, but I do know that there are several servers here that run Towny sucessfully, so hopefully you'll get noticed by one of them.

As for alternative options, take a look at Factions and Residence and their respective addons to see if they might provide what you're looking for while you're waiting for an answer.

Share this post


Link to post
Share on other sites

Ill look into Residence, thats one ive never heard of yet. Been workin with Factions in the past, and it wasnt really my thing, and not entirely the kind of settup we're looking for, for the server we're planning on making! :D

thanks alot for the help, i appreciate it alot! :)

Share this post


Link to post
Share on other sites

Ive done that already. Managed to get it to work on 3.1.2.

Ive run into two issues though, when ever we claim stuff, towny comes up with a message; [Towny] This plot is locked!

What can i possibly do about that?

Second issue is, that anything "tekkit" related, such as things you can create that destroys blocks, dosent work at all. I tried disabling towny, and it would all work. So im thinkin its something that protect blocks in the towny config (or something else?) id need to disable, could anyone help me out perhaps? Or perhaps give me a working towny config? id appreciate that alot :D

Share this post


Link to post
Share on other sites

Ive done that already. Managed to get it to work on 3.1.2.

Ive run into two issues though, when ever we claim stuff, towny comes up with a message; [Towny] This plot is locked!

What can i possibly do about that?

Second issue is, that anything "tekkit" related, such as things you can create that destroys blocks, dosent work at all. I tried disabling towny, and it would all work. So im thinkin its something that protect blocks in the towny config (or something else?) id need to disable, could anyone help me out perhaps? Or perhaps give me a working towny config? id appreciate that alot :D

  1. Towny Version 0.81.0.0 Follow Steps 3-4 for Towny Version 0.80.1.0 or lower follow Everything From Step 2 onwards.
  2. Add Tekkit Mod FakeUsers as residents of the town set them up so they are NPCs if you are using mysql then u must add them to the sql database under towny_residents and then manually add the flags from an existing NPC player name which will appear if you set a town mayor to npc. The fake users you want are [industrialCraft], [RedPower], [ComptuerCraft], [buildCraft]
  3. Setup your permissions so that the FakeUsers have a special group/rank in which you will assign the permissons required to give the build and destroy override commands from Townys admin nodes for the machines. Optionally you can just OP the FakeUser names in Step 2
  4. Test the machine is working. If you have followed this correctly and you no longer get a message saying that the fake user does not exist as a resident or any more messages like you get now telling you the machine has no rights to operate in the plot then it should all work. I would test it with a IC2 Miner.

Now to get ComputerCraft turtles to function like mine and place the above will not help you due to the fact turtles are assigned a new fakeuser ID for each entity u place, we had to modify the towny.jar to make this work so turtles Enity ID were assigned to the player who placed them and thus our turtles obey Towny permissions and any other permission you can assign your players which in our servers case means turtles will not dig up blocks we don't let players dig up in wilderness.

I may share the Towny.jar for you which is based on Towny Version 0.81.0.0, this version has FakeUsers built into the config so you do need to add them as residents instead you can add any additional fake users from the new Tekkit mods in the special mods section of the Towny config. Be warned though that our Modified version may cause silly mysql errors when when the turtle cannot be found as a user anymore because our turtles get stored with towny player cache and are added to the players friends list which of course the cache is cleared when your server shutsdown but you can always re add the turtle ID using offline friend add command to fix any silly MySql error, Its not a perfect design but it works and you wont get the error much and it wont effect the server at all it just a warning saying the sql database doesn't know what that resident is as it doesn't exist.

I hope this information sorts out your problem. I can also assist you with Towny use as well if you require such information.

Share this post


Link to post
Share on other sites

Thanks alot for the usefull post! :) that most certaintly explains most of the issues we were having. If you would share that towny.jar with me, id be really glad, as it might make our life alot easier :P

- doing all that, will that also help us with the problem that towny seems to lock the plots? ( the [Towny] This plot is locked!)

Share this post


Link to post
Share on other sites

I'v never ever had any locked plot error not even without our custom towny.jar I don't know what that is about other than your permissions are not setup or something.

Also Here is the Towny.jar we modified. I also forgot to mention we wipped up a special label script for the turtles so that they would better remember the ID assigned to them this is needed to make our modifications run a little smoother.

if (turtle) then

end

label = os.getComputerLabel()

if (label == nil or label == "") then

os.setComputerLabel(os.getComputerID())

end

Just paste that into a new txt named lable and then place this script into "YourServer\mods\ComputerCraft\lua\rom\autorun"

Share this post


Link to post
Share on other sites

Thanks alot for that!

- okay, we have a few questions. Is it needed to put towny on MySql for this to work effectively? and are we NEEDED to do this mayor thing for every single new town being made, or is it a one time thing only?

Share this post


Link to post
Share on other sites

You don't need MySQL id only touch that if you were 100% on what how to maintain that database, and you don't have too do that for every single town you only need one npc and only once so you can copy the flags set in its resident config to the fakeusers resident config so it has the same rights as the npc does and in doing so you should set the fakeusers to an npc.

Share this post


Link to post
Share on other sites

First of all I would like to thank you ledhead900 for helping me get this far...

I am trying to setup a Towny based Tekkit server and would love it if you could share your Towny modification with me aswell!

I am quite fond of programming the little turtle guys but need Towny.

Share this post


Link to post
Share on other sites

I can confirm that the file is currently set to private, please please may you post a working link.

It would really help us, as the versions i have been using come with so many errors and turtles just dont work.

Thank you for your hard work.

Regards

Gmstorm

Share this post


Link to post
Share on other sites

Hi,

I have installed towny and its requierments (vault) for tekkit (1.2.5 mc) and configured it but in game when i do /pl it turns red and doesent work Help!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this