Sign in to follow this  
Sp0nge

CB++ upgrading (Tekkit 3.1.2)

Recommended Posts

Seems like someone made something ingame thats real CPU heavy. Do you have full EE enabled? EEflowers? I would gone to 2012-10-05 00:50:53 in the serverlog, put the server on a temp port (so only you can log on) then backtrack all the players logging in, going to theyre last known positions and watch console. Ofc, these players most likely have moved now, so you would have to do it on a fresh "disconnect". I would also recommend that you install a plugin to check for TPS, like LagMeter. You can also do /townyadmin ingame to get some idea on how many threads the CPU is at (its ofc not 100% accurate but you will get an estimation atleast).

I would say that most likely something is starting to use so much of the CPU that the server just falls behind on it selfe, threads stacking up, calculations put in que etc and eventually the server gets enough, kicks all players out so it can gather itselfe again.

Beside the EE Q, do you have chunkloaders enabled? If so, just try and run the server on another port for 30-50 minutes with noone logging in, see if the same happends again. CB++ also does mobspawning differently, have you done a /butcher -a and see how many mobs there infact are on your map?

Also you should post how much RAM and CPU specs for reference

And you can also test reverting back, see if its more stable then.

Share this post


Link to post
Share on other sites

EE is enabled, items that can cause grief or dupe are banned, power flower isnt.

Lagmeter: http://pastebin.com/G4id07uC

Townyadmin: Threads varying form 40 to 65

I talked to the hoster and he said they are not doing backups every 30mins.

Chunkloaders are banned. If i start a copy of the server on my local machine it doesnt happen. (logblock and votifer wont start local because of mysql)

I also tried to disable Logblock on the server for a few hours without success, and it seems when there are less people online it doesnt happen at all.

Butcher -a removed about 180 Mobs

What ive tried a few hours ago:

I replaced cb++ with the MCPC build from here: http://forums.spout.org/threads/1-3-2-spigot-v2-the-most-performance-savvy-craftbukkit-mod-out-there.3776/

no success - disconnectes still every 30mins

2GB - DDR3 RAM and Intel Xeon E3-1230 3.2GHz

Share this post


Link to post
Share on other sites

Ok i was so frustrated because of the disconnects every 30mins that i decided to change hosts.

At the same time i disabled BOSEconomy because Essentials can manage that too.

No more disconnects. The server runs smooth, i never saw TPS drop below 20 --> http://pastebin.com/dFyetKP9

Im using MPServ now.

So its either because i got rid of BOSE or the new host. I dont know.

edit: im also pretty sure it wasnt caused by BOSE but i wanted to mention it

Share this post


Link to post
Share on other sites

THANKS YOU SO MUCH! MY SERVER RUNS LIKE A BOSS NOW!

I AM TROLL, THIS TREAD IS L33T. CAPS FOR TEH WIZ

please, everybody can read your post perfectly without the caps. It's annoying.

Share this post


Link to post
Share on other sites

When I try to log in with Tekkit, it tells me that I am banned from the server. I have checked the banlist and the banip list and there is nothing in it. This also occurs with normal Tekkit. Does anyone know why this is happening?

Share this post


Link to post
Share on other sites

When I try to log in with Tekkit, it tells me that I am banned from the server. I have checked the banlist and the banip list and there is nothing in it. This also occurs with normal Tekkit. Does anyone know why this is happening?

Hello there thread necromancer! What does the ban has to do with BC++?

Share this post


Link to post
Share on other sites

When I try to log in with Tekkit, it tells me that I am banned from the server. I have checked the banlist and the banip list and there is nothing in it. This also occurs with normal Tekkit. Does anyone know why this is happening?

bukkit.yml

filter-unsafe-ips: false

Share this post


Link to post
Share on other sites

For anyone running a tekkit server hosted off of a company or even off your router, and is experiencing TPS/Any form of lag... This is your key to ultimate happiness... I installed the CB++75 and it worked perfectly! I recommend this to anyone resorting to last resources of fixing your TPS lag.

Share this post


Link to post
Share on other sites

be carefull with spigot, its generating assync errors for me, bont know if its a plugin, but it's killing my server random times, so i went back to cb++

Really?

I've not seen any of those...

Actually I've had fewer crashes now I've changed to Spigot than when I was on CB++...

Share this post


Link to post
Share on other sites

java.util.ConcurrentModificationException

[13:46:0] at java.util.ArrayList$Itr.checkForComodification(Unknown Source)

[13:46:0] at java.util.ArrayList$Itr.next(Unknown Source)

[13:46:0] at codechicken.wirelessredstone.core.WirelessBolt.vecBBDamageSegment(WirelessBolt.java:208)

[13:46:0] at codechicken.wirelessredstone.core.WirelessBolt.bbTestEntityDamage(WirelessBolt.java:243)

[13:46:0] at codechicken.wirelessredstone.core.WirelessBolt.onUpdate(WirelessBolt.java:353)

[13:46:0] at codechicken.wirelessredstone.core.WirelessBolt.update(WirelessBolt.java:381)

[13:46:0] at net.minecraft.server.WirelessRedstoneCore.onTickInGame(WirelessRedstoneCore.java:118)

[13:46:0] at net.minecraft.server.mod_WirelessRedstoneCore.onTickInGame(mod_WirelessRedstoneCore.java:22)

[13:46:0] at net.minecraft.server.BaseMod.doTickInGame(BaseMod.java:34)

[13:46:0] at cpw.mods.fml.common.modloader.BaseModTicker.sendTick(BaseModTicker.java:95)

[13:46:0] at cpw.mods.fml.common.modloader.BaseModTicker.tickBaseMod(BaseModTicker.java:83)

[13:46:0] at cpw.mods.fml.common.modloader.BaseModTicker.tickEnd(BaseModTicker.java:55)

[13:46:0] at cpw.mods.fml.common.SingleIntervalHandler.tickEnd(SingleIntervalHandler.java:22)

[13:46:0] at cpw.mods.fml.common.FMLCommonHandler.tickEnd(FMLCommonHandler.java:185)

[13:46:0] at cpw.mods.fml.server.FMLBukkitHandler.onServerPostTick(FMLBukkitHandler.java:631)

[13:46:0] at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:600)

[13:46:0] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:457)

[13:46:0] at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)

[13:46:0] Unexpected exception

not suhre if just wilreless redstone, or caused by some plugins

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this