Sign in to follow this  
Skuli

MFFS rev8 fix backported to rev7, fixes LWC playerinteract errors

Recommended Posts

As penance for my previous transgression I offer up this humble patch.

It adds the single line of code from MFFS rev8 that seems to fix the horrible LWC (and other plugin) errors caused by MFFS.

http://goo.gl/StFwa

I make no guarantees it will work on your server, but it appears to have no issues on my test box or production server...

Share this post


Link to post
Share on other sites

Tbh, ive never heard of this error before, whats it all about? We never had any issues with LWC and the short periode of time we had MFFS enabled.

Share this post


Link to post
Share on other sites

Tbh, ive never heard of this error before, whats it all about? We never had any issues with LWC and the short periode of time we had MFFS enabled.

On my server (and several others) LWC (and many other plugins) report errors and/or crash when someone tries to break a forcefield.

It gives ugly errors in the log about PlayerInteract and the users receive an error message abotu "Severe LWC error."

It completely crashes Monster Apocalypse...

Share this post


Link to post
Share on other sites

Is this just a bukkit plugin? Putting it into the server gives me a few errors.

This has the errors (seperated by ----) that occurred when I restarted the server. I put your jar into the plugins folder.

http://pastebin.com/6Xx422hW

Thanks

No, it goes in your MODS folder and replaces the existing MFFS file there.

Share this post


Link to post
Share on other sites

Thanks for that, I overwrote the original files with the files in the jar using winrar. Hope that's correct, thanks for your work

That will work, but really you just need to delete the old MFFS file and copy this one in.

Share this post


Link to post
Share on other sites

Hey, not meaning to dig up an old thread, i hope this fix is still valid

The download provided is a jar, my MFFS is a .zip, renaming the jar to .zip results in:

20.09 23:00:15 [server] SEVERE at cpw.mods.fml.server.FMLBukkitHandler.onLoadComplete(FMLBukkitHandler.java:142)

20.09 23:00:15 [server] SEVERE at cpw.mods.fml.common.Loader.initializeMods(Loader.java:618)

20.09 23:00:15 [server] SEVERE at cpw.mods.fml.common.Loader.modInit(Loader.java:263)

20.09 23:00:15 [server] SEVERE at cpw.mods.fml.common.modloader.ModLoaderModContainer.init(ModLoaderModContainer.java:351)

20.09 23:00:15 [server] SEVERE at mffs.mod_ModularForceFieldSystem.load(mod_ModularForceFieldSystem.java:121)

20.09 23:00:15 [server] SEVERE at mffs.BlockForceField.<init>(BlockForceField.java:38)

20.09 23:00:15 [server] SEVERE at net.minecraft.server.BlockContainer.<init>(BlockContainer.java:11)

20.09 23:00:15 [server] SEVERE at net.minecraft.server.Block.<init>(Block.java:201)

20.09 23:00:15 [server] SEVERE at net.minecraft.server.Block.<init>(Block.java:181)

20.09 23:00:15 [server] SEVERE java.lang.IllegalArgumentException: Slot 255 is already occupied by [email protected] when adding [email protected]

Is this still valid?

Thanks

Share this post


Link to post
Share on other sites

Hey, not meaning to dig up an old thread, i hope this fix is still valid

The download provided is a jar, my MFFS is a .zip, renaming the jar to .zip results in:

20.09 23:00:15 [server] SEVERE at cpw.mods.fml.server.FMLBukkitHandler.onLoadComplete(FMLBukkitHandler.java:142)

20.09 23:00:15 [server] SEVERE at cpw.mods.fml.common.Loader.initializeMods(Loader.java:618)

20.09 23:00:15 [server] SEVERE at cpw.mods.fml.common.Loader.modInit(Loader.java:263)

20.09 23:00:15 [server] SEVERE at cpw.mods.fml.common.modloader.ModLoaderModContainer.init(ModLoaderModContainer.java:351)

20.09 23:00:15 [server] SEVERE at mffs.mod_ModularForceFieldSystem.load(mod_ModularForceFieldSystem.java:121)

20.09 23:00:15 [server] SEVERE at mffs.BlockForceField.<init>(BlockForceField.java:38)

20.09 23:00:15 [server] SEVERE at net.minecraft.server.BlockContainer.<init>(BlockContainer.java:11)

20.09 23:00:15 [server] SEVERE at net.minecraft.server.Block.<init>(Block.java:201)

20.09 23:00:15 [server] SEVERE at net.minecraft.server.Block.<init>(Block.java:181)

20.09 23:00:15 [server] SEVERE java.lang.IllegalArgumentException: Slot 255 is already occupied by [email protected] when adding [email protected]

Is this still valid?

Thanks

You probably have two copies of the mffs force field mod in your MODS folder.

Share this post


Link to post
Share on other sites

As penance for my previous transgression I offer up this humble patch.

It adds the single line of code from MFFS rev8 that seems to fix the horrible LWC (and other plugin) errors caused by MFFS.

http://goo.gl/StFwa

I make no guarantees it will work on your server, but it appears to have no issues on my test box or production server...

The links dead..... anyone got another link for the download?

Share this post


Link to post
Share on other sites

I can't download the file. It just says "No Preview Available". Clicking file, edit, view, or help doesn't do anything. Can you post a MediaFire link or something like that?

Share this post


Link to post
Share on other sites

I just tried it, and there is a download button right underneath where it says no preview available.

There isn't for me. I've tried using Firefox, Safari, Opera, and Google Chrome. I'm on a Mac.

Share this post


Link to post
Share on other sites

I can't get this to work. I get this error when I start my server up:

17:30:46 [WARNING] Failed to load mod class mffs/mod_ModularForceFieldSystem.class in /Users/Grady/Desktop/Stuff/MinecraftStuff/Server/Tekkit/mods/mffs_rev7_for_1.2.5-bukkit.zip

17:30:46 [sEVERE] Zip file mffs_rev7_for_1.2.5-bukkit.zip failed to read properly

17:30:46 [iNFO] File mffs_rev7_for_1.2.5-bukkit.zip contained no mods

17:30:46 [iNFO] Directory weaponmod contained no mods

17:30:46 [sEVERE] A problem has occured during mod loading. Likely a corrupt jar is located in your mods directory

17:30:46 [sEVERE] cpw.mods.fml.common.LoaderException: cpw.mods.fml.common.LoaderException: java.lang.UnsupportedClassVersionError: mffs/mod_ModularForceFieldSystem : Unsupported major.minor version 51.0

17:30:46 [sEVERE]at cpw.mods.fml.common.Loader.load(Loader.java:436)

17:30:46 [sEVERE]at cpw.mods.fml.common.Loader.loadMods(Loader.java:606)

17:30:46 [sEVERE]at cpw.mods.fml.server.FMLBukkitHandler.onPreLoad(FMLBukkitHandler.java:134)

17:30:46 [sEVERE]at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:135)

17:30:46 [sEVERE]at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:438)

17:30:46 [sEVERE]at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)

17:30:46 [sEVERE] Caused by: cpw.mods.fml.common.LoaderException: java.lang.UnsupportedClassVersionError: mffs/mod_ModularForceFieldSystem : Unsupported major.minor version 51.0

17:30:46 [sEVERE]at cpw.mods.fml.common.Loader.loadModClass(Loader.java:527)

17:30:46 [sEVERE]at cpw.mods.fml.common.Loader.attemptFileLoad(Loader.java:562)

17:30:46 [sEVERE]at cpw.mods.fml.common.Loader.load(Loader.java:419)

17:30:46 [sEVERE]... 5 more

17:30:46 [sEVERE] Caused by: java.lang.UnsupportedClassVersionError: mffs/mod_ModularForceFieldSystem : Unsupported major.minor version 51.0

17:30:46 [sEVERE]at java.lang.ClassLoader.defineClass1(Native Method)

17:30:46 [sEVERE]at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)

17:30:46 [sEVERE]at java.lang.ClassLoader.defineClass(ClassLoader.java:615)

17:30:46 [sEVERE]at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)

17:30:46 [sEVERE]at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)

17:30:46 [sEVERE]at java.net.URLClassLoader.access$000(URLClassLoader.java:58)

17:30:46 [sEVERE]at java.net.URLClassLoader$1.run(URLClassLoader.java:197)

17:30:46 [sEVERE]at java.security.AccessController.doPrivileged(Native Method)

17:30:46 [sEVERE]at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

17:30:46 [sEVERE]at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

17:30:46 [sEVERE]at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

17:30:46 [sEVERE]at java.lang.ClassLoader.loadClass(ClassLoader.java:295)

17:30:46 [sEVERE]at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

17:30:46 [sEVERE]at java.lang.Class.forName0(Native Method)

17:30:46 [sEVERE]at java.lang.Class.forName(Class.java:247)

17:30:46 [sEVERE]at cpw.mods.fml.common.Loader.loadModClass(Loader.java:494)

17:30:46 [sEVERE]... 7 more

17:30:46 [sEVERE] Unexpected exception

cpw.mods.fml.common.LoaderException: cpw.mods.fml.common.LoaderException: java.lang.UnsupportedClassVersionError: mffs/mod_ModularForceFieldSystem : Unsupported major.minor version 51.0

at cpw.mods.fml.common.Loader.load(Loader.java:436)

at cpw.mods.fml.common.Loader.loadMods(Loader.java:606)

at cpw.mods.fml.server.FMLBukkitHandler.onPreLoad(FMLBukkitHandler.java:134)

at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:135)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:438)

at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)

Caused by: cpw.mods.fml.common.LoaderException: java.lang.UnsupportedClassVersionError: mffs/mod_ModularForceFieldSystem : Unsupported major.minor version 51.0

at cpw.mods.fml.common.Loader.loadModClass(Loader.java:527)

at cpw.mods.fml.common.Loader.attemptFileLoad(Loader.java:562)

at cpw.mods.fml.common.Loader.load(Loader.java:419)

... 5 more

Caused by: java.lang.UnsupportedClassVersionError: mffs/mod_ModularForceFieldSystem : Unsupported major.minor version 51.0

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)

at java.lang.ClassLoader.defineClass(ClassLoader.java:615)

at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)

at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)

at java.net.URLClassLoader.access$000(URLClassLoader.java:58)

at java.net.URLClassLoader$1.run(URLClassLoader.java:197)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

at java.lang.ClassLoader.loadClass(ClassLoader.java:295)

at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

at java.lang.Class.forName0(Native Method)

at java.lang.Class.forName(Class.java:247)

at cpw.mods.fml.common.Loader.loadModClass(Loader.java:494)

... 7 more

It doesn't work as a jar either. I get the same error.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this