Jump to content
  • 0

Launcher Crashing when 64-bit Java installed


McD285
 Share

Question

The launcher will not open if 64-bit Java has been installed, even if 32-bit Java is also installed.  32-bit Java has to be the only Java present on the system.  My one and only workaround for this at the moment is to install 64-bit Java on a thumb drive and plug it in AFTER I've opened the Technic Launcher, so that I can choose it in the Java settings and increase the max RAM available.  

If 64-bit Java is installed on the system, the launcher will load for less than a second and then close, and then a Java error report will be saved where the launcher is located.  Attached is one such error report along with a log file from the .technic roaming folder.

The Java version is jre1.8.0_65.  My OS in Windows 10, with 16GB RAM.  Let me know if you need any more information about my system to tackle this issue.

hs_err_pid11128.log

techniclauncher_2015-10-25.log

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Seems to be working so far.  I removed the thumb drive so there was no 64-bit Java present on the system, downloaded and installed 64-bit Java, rebooted, and started up Technic without the thumb drive plugged in.  I'm able to load up a modpack and play.

How did you know to remove RivaTuner?  

Thanks so much for the solution and quick replies!

Link to comment
Share on other sites

  • 0

Here is a Fix without removing RivaTuner:

  1. Open RIvaTuner Statistics Server
  2. Click "Add"
  3. Navigate to your Java directory f.e: (C:\Program Files\Java\Version\bin)
  4. Select "javaw.exe"
  5. Change "Application detection level" to "None"
  6. Start the Technic Launcher

sorry for adding to an old thread, but i thought it might be useful.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By βeta
      I am trying to play tekxit 3.14 Pi in a server with some friends. I’ve tested the modpack on my computer, and it worked just fine. I have tested with all my friend as well and both the modpack and the server work without any problem. However, one of my friends is having a lot of problems to launch the modpack. We even tried to upgrade her RAM from 6gb to 8gb and we set technic launcher / java settings / memory to 4gb, but nothing worked. We tried to set memory in java settings to 3, 3.5 and 5 as well, with no success. Java is up to date, by the way. She does not have a dedicated graphic card, but one other friend of mine does not have either ant it works fine, so that should not be the problem. And, to make matters worse, we tried to change the modpack, but it seems no modpack will launch at all. The modpack window does open and start to load, but it closes without any error message. Nothing seems to work, for some reason. Does anyone have an idea?
    • By bumblebray1
      When i try to load a pack a white bar pops up saying "You've selected Java 11.0.9.1, which is know to have issues with Minecraft, are you sure you want to contiune?" and when i click yes, technic closes then opens again. I understand that i need to install a different version of java but when i go into the settings for the java version on technic it opens a file, am i supposes to put the new java version there? It should be noted that im playing with linux on a chromebook. 
    • By Morthlog
      In order to allocate more than 1 gb of ram (cause the game kept crashing) i wanted to change to a 64bit- version. The only one available was 1.14 which was saying it is known for causing problems. I tried to lauch pixelmon reforged with it but i just wouldn't open. I tried to find a version (preferably 1.8) in .minecraft folder to get the version, but i could not find the javaw file it needed. Below is a picture with my version option. So what i need is either a guide or a link to get the needed file to get the 64-bit version of 1.8 to 1.12. Anything in between works for me
       
      Edit: The problem has been solved. This thread may be closed by the moderators

    • By Conex_0
      I'm tired and frustrated with this launcher. First it wouldn't even launch properly and I had to fix that, then it won't even detect 64 bit. I litteraly reinstalled the launcher and java multiple times, I even installed java online and offline, offline first, then when the launcher was open java online, and selected java online, and it still said it already had that in the launcher settings, still 32-bit. I just want to play a modpack with my friends on their server.
    • By AlexKoyomi
      When I click in install, it does something for a second and then just appear the options to "Delete modpack" and "install".
       
      https://pastebin.com/KpRY4efn
×
×
  • Create New...