Jump to content

Project Icarus EPIC Sci Fi Magic and Technology Modpack!


Recommended Posts

Welcome to Project Icarus

-- Merging Magic and Technology --

 

Quite possibly one of the craziest mod packs out now!

Merging the best magic and Technology Mods to create one hell of an ULTIMATE Modpack!

Ever wanted to build a massive empire using technology mods but your friend wants to turn himself into a vampire? Well now you can have best of both worlds!

The idea of Project Icarus is to merge the best Tech & Magic mods to create UNLIMITED POWEEEERRRR! No seriously.

 

We Have STARGATES (LanteaCraft)

We Have THAUMCRAFT!

We Have MEKANISM

We Have ARS MAGICA

And Much, Much more...

 

-- Join us on this Epic adventure to create the best Modpack for everyone! --

 

!!WE Take Mod Suggestions!!

 

Developers:

Jack.T (rex00991)

Ollie.R (fuOllieread)

Edited by rex00991
Link to post
Share on other sites
  • Similar Content

    • By Capio13
      So I have been working on a modpack of mine lately, recently switched computers to a higher end one, and here I am working on the first update I have done for this modpack since I got the new pc. I make sure to test to make sure all the mods work together in a test pack, and then I decide to zip up the mods,scripts(for crafttweaker), llibrary, coremods, config, cache, bin, and the .mixin.out folder into one neat folder like I have done in the past. So here i go and upload the folder onto dropbox and test downloading the update through the technic launcher, instead of the name of the folder, it starts downloading a folder with the name of the version it is on the website, and when I launch it, it is just a fresh install of forge with none of the mods or anything. I don't know what went wrong in the process, but I need some help. Here's the DL Link and the modpack link.
      DL link: https://www.dropbox.com/s/nn2zia9l4g9u6sa/EOI 0.2.0.zip?dl=0
      Modpack Link: https://www.technicpack.net/modpack/eoi-devbuild.1783065

      TLDR; It is defaulting to a fresh install of forge with no mods even though I have done the exact same thing I did in the past.
    • By Zvery
      Hi, My modpack seems to not be opening whenever I press play. It takes me out of the Technic screen at first then it goes back to the Technic screen here are my logs
      cX8tNvDL (3).txt
    • By Nyrab
      I'm trying a new modpack
      The version is 1.10.2
      I tried to remove some mods and still don't work
       
      Modpacklog.zip
    • By zoezp
      I am new to making modpacks and this is the first one I ever made so I watched some youtube tutorials and it worked well until I tried to launch the modpack and It started as vanilla but when I checked the modpack options it had the mods installed and they were all in the folder. I tried to fix it and tried out things like renaming the files but nothing worked for me so thats why I am here asking for your help.
      I don't know what the problem is at this points so I would really like some help.
      Here is the dropbox link I used to upload the modpack: https://www.dropbox.com/s/u2qfs8zuco8fh39/pixelmon fun.zip?dl=1
      Here is the modpack download link: https://www.technicpack.net/modpack/pixelmon-2780956.1833394
       
      If any more info is needed just ask and I'll provide it if I can.
      Thanks in advance! 
    • By Zilverrr
      Whenever me or my friends try to download my modpack https://www.technicpack.net/modpack/minecraft-steden-oorlog.1830815 it only runs vanilla 
      can someone help me with this ?
×
×
  • Create New...