Jump to content
Sign in to follow this  
Ben Whitehead

Why Can I only connect to tekkit server using local ip? Others cant connect to server!

Recommended Posts

I have recently set up a tekkit server on my home computer, but after finding that my ip was dynamic i have used no-ip.org:

sheepland.no-ip.org is my server address now

it is the same as my remote ip, listed with a DUC app.

I have port forwarded on my router and I have added exceptions for the firewall to allow inbound and outbound connections for both of the options on my firewall for port 25565.

The ip address on the properties file is left blank also.

I have, and so have my friends, tried to connect to:

sheepland.no-ip.org:25565 and it says cant reach server.

However, i have added it to the tekkit server list, where after a while it says it is online and displays how many people and the motd are connected to it.

After this, I have tried again and it still does not connect.

I have tried entering in just the ip (not the sheepland.no-ip.org one), my external not internal one without any luck!!

I do not want to use hamachi, so does anyone else know why this is happening or how I can fix it?

My system is 64bit windows 7 with 32gb ran and i7 processor.

Please can you help!!!...????

***I definitely do not want to use hamachi!!***

I have uploaded a picture of the router port forwarding in case it is wrong:

Share this post


Link to post
Share on other sites

Quadruple-posting useless comments is going to hinder you, not help you. Read the rules, seriously.

Either your port forwarding is wrong, or your IP is messing up. I find that trying to change the IP just makes it screw up and unconnectable.

Share this post


Link to post
Share on other sites

go to canyouseeme.org and enter 25565, if it says connection refused or something else negative, that means that your port isn't open. Remember to have your minecraft server OPEN and RUNNING while doing this. your router would most likely only have ports open when an application requests it.

Anyways, internal ips don't need port communication. So that's why it works.

The reason why you're allowed to connect to other servers is that their firewall settings allow incoming connections. However most routers by default do not allow incoming connections (to prevent port hacking via port scanning, a problem with windows xp which allowed people to infect other computers via ip.) All you have to do is port forward and allow incoming data to your router. Internal data that happens within the router and does not communicate outside of the router does not go through the firewall.

I'm sounding a bit redundant, but basically:

1: go to canyouseeme.org and type 25565

2: if it says connection refused or something, port forward your router.

3: if it says that it's open, post your logs here and i'll take a look at it.

Share this post


Link to post
Share on other sites

oh, i didn't see your posted image, but do the canyouseeme thing still.

And make sure that your no-ip directs to your external IP address. You can alternatively download the No-ip duc and make it dymanically update to your external ip. Your ip may have changed from the last time you updated your no-ip.

Share this post


Link to post
Share on other sites

I have had servers on tekkit for a long time and I think the problem is that you need to add your local IP to the server properties file. it should be something like 10.0.0.1* The image below may help. It is my server properties file.

http://seatdog.tumblr.com/

*Last Number Different

Share this post


Link to post
Share on other sites

10.0.0.1 would not even been in his ip range since in the op screen shot a 192.168.1.* address is used, and he would only need to specify if he wanted the server to bind to a specific adapter or address

not saying that you could not have those two esisting in the same physical network, but it does require additional iptable information and when i have seen those together before a vpn was in use

Share this post


Link to post
Share on other sites

A 10.* address is really only used for private networks. 99% of people with a normal home network have 192.168.* instead of anything else as local IP.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...