Jump to content
Sign in to follow this  
Schilcote

How Do I Shot Mods?

Recommended Posts

I think Technic has made me soft. I'm trying to mod Minecraft the old-fashioned way (and by the old-fashioned way, I mean by installing Forge and dropping crap into the appropriate folders), and it isn't working. I'm making my own "pack" (for use by myself and a select group only) for use in an LP, since I need specific mods.

First problem I'm having is that IndustrialCraft doesn't work. I can go without it, but... mining lasers. And construction foam, and nuclear reactors, and QuantumSuit... I think it's just that the latest IC2 doesn't like the latest Forge, and they sit at opposite sides of my computer and refuse to talk to eachother, not letting anyone get any work done.

Second problem is that NEI doesn't work. Items don't show up in it, though the utility buttons work. This may very well be the same problem as above. I've tried the reccomended installation with both Chickenbone's Core and the actual NEI jar in the CoreMods folder, as well as the other three possible combinations. They all behave exactly the same.

Third problem is that RedPower doesn't work. This I can't go without. The client just doesn't seem to think its installed, and the server more helpfully informs me that Forge doesn't think that it's a mod. I have the server distros on the server and the client distros on the client, of course.

Fourth problem is that ICBM doesn't work. It works great client-side, but when it's installed on the server the launchers disappear seconds after being placed. Now that I think of it, does it explicitly mention anywhere that ICBM is SMP-compatible? Aren't ALL mods SMP-compatible now, though?

Fifth problem is that Railcraft doesn't work. About the same thing as IC2.

Sixth problem is that EE2 doesn't work. About the same problem as RedPower; though Forge seems to recognize it as a mod, no EE2 items actually show up in-game on either client (SSP) or server (SMP).

Seventh problem is that MoCreatures doesn't work. Same problem as RedPower.

Eighth problem is that Balkion's Weapon Mod doesn't work. Same problem as RedPower.

The only mods that DO work are:

ICBM (Only in SSP)

ComputerCraft

MoCreatures (Only in SSP)

Rei's Minimap

Treecapitator

Any suggestions?

Share this post


Link to post
Share on other sites

Ah, I think I see the problem.

I accidentally installed an old version of Forge. Re-installing now, gonna see if it works with the latest.

EDIT:

Nope. Latest reccomended build doesn't seem to work at all.

Share this post


Link to post
Share on other sites

if you're talking about using redpower, then you are clearly either using the wrong version of minecraft, or the wrong version of redpower. there's been no updates to redpower past 1.2.5, and if you're using the latest forge you are probably running 4.1.2 (4.1.3 maybe? is that even out yet?). this leads me to believe that you are probably using the wrong versions of pretty much everything.

make sure that the mods you're using actually work for the minecraft client version you're using. this is also why EE2 doesn't work. there is no EE2 for 4.1.2 or 4.1.3, whichever is current nowadays.

edit: in fact, now that I've read the entire OP, you may want to not try and copy/paste stuff from tekkit and expect it to work.

Share this post


Link to post
Share on other sites

Oops. Well that explains a few things. I suspected that was the problem when I was looking at Elloraam.net trying to figure out what I did wrong.

And I didn't, I installed the latest versions of everything.

Share this post


Link to post
Share on other sites

And I didn't, I installed the latest versions of everything.

not if you're getting those kinds of problems you didn't. IC2, railcraft, NEI, and mo' creatures all have 4.1.2 versions. in fact, the 4.1.2 dev build of technic has all of them in there.

Share this post


Link to post
Share on other sites

not if you're getting those kinds of problems you didn't. IC2, railcraft, NEI, and mo' creatures all have 4.1.2 versions. in fact, the 4.1.2 dev build of technic has all of them in there.

I didn't know minecraft 4 came out! (I believe it's 1.4.2)

Share this post


Link to post
Share on other sites

you should tell us what version of minecraft your planning on running, because if your going to use the latest which is 1.4.2 not all mods are updated. Also ICBM does work on SMP, though there are a few problems with smp vs ssp, mainly that when a chunk with certain things like the launchers and such unload on smp it can glitch things.

Share this post


Link to post
Share on other sites

you should tell us what version of minecraft your planning on running, because if your going to use the latest which is 1.4.2 not all mods are updated. Also ICBM does work on SMP, though there are a few problems with smp vs ssp, mainly that when a chunk with certain things like the launchers and such unload on smp it can glitch things.

You're telling me! I once installed ICBM to play, and the server kept crashing and kicking players out after 5 minutes with an internal server error! It's damn bullshit if you ask me.

Share this post


Link to post
Share on other sites

get MultiMC for putting together and testing your pack. It has ways of logging, makes adding and removing mods super simple, and can even downgrade your jar for you if you need it.

After testing and configuring, you can still set it up to use the technic launcher if you want.

Share this post


Link to post
Share on other sites

I can tell you a cheap way to do it. :downsrim:

I'm really sorry.

This just made my day.

(I am ashamed)

If your adding sdk gun mod to this pack ill be happy to download it

Just add it yourself...

Share this post


Link to post
Share on other sites

Just add it yourself...

you cant add mods to packs unless youre creator and even if i could id have to do a whole bunch of downgrading crap :/

I myself have added quite a few mods to the Technic pack. Also, downloading crap is how you obtain things on the internet...

Share this post


Link to post
Share on other sites

I can tell you a cheap way to do it. :downsrim:

I'm really sorry. (sure you are)

Just add it yourself...

you cant add mods to packs unless youre creator and even if i could id have to do a whole bunch of downgrading crap :/

These both made my day much better. I just came from chem, so this is very nice to come back to.

Share this post


Link to post
Share on other sites

These both made my day much better. I just came from chem, so this is very nice to come back to.

Haha you're right, I wasn't sorry at all.

And also, haha can't add mods to packs, thats a new one. I would say "I thought I'd heard everything" but I know I never can when it comes to minecraft.

Share this post


Link to post
Share on other sites

Haha you're right, I wasn't sorry at all.

And also, haha can't add mods to packs, thats a new one. I would say "I thought I'd heard everything" but I know I never can when it comes to minecraft.

I think he meant you can't add mods to the distribution of the pack, i.e. I couldn't add sparklefarts to the entire modpack (meaning the copy people download) as I'm not the creator of the pack. He was talking about the entire modpack as a whole, not the individual copy he downloaded.

That, or he's just stupid.

Share this post


Link to post
Share on other sites

I think he meant you can't add mods to the distribution of the pack, i.e. I couldn't add sparklefarts to the entire modpack (meaning the copy people download) as I'm not the creator of the pack. He was talking about the entire modpack as a whole, not the individual copy he downloaded.

That, or he's just stupid.

I'm going with the second option... Just my opinion though

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...