Jump to content

Low Fps On Tekkit Legends

Recommended Posts

I have been experiencing low fps on tekkit legends, around 10 - 20 fps. I have an......

i7 core



I have been experiencing this ever since i installed tekkit legends, i have installed optifine and have tried setting the priority to 'high' and i dont see a difference. I have also tried reinstalling Java 8 64bit and still, has done nothing. I also use the sphax texture pack, i luv it, its a must need.

Link to comment
Share on other sites

And are you running minecraft.exe on your GTX 960m or on your integrated graphics card (usually Intel HD Graphics)?

You can check by opening the NVidea configuration screen (rightclick an empty spot on your desktop, should be in said menu), then going to 3D-configuration (or similar), then selecting minecraft.exe.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By JustLisa
      Hi, i have big problem with server.
      Here is my console: 
    • By MaukasWanukas
      I have ben playing for a while now but cant seem to find blue power copper and i need it for pneumatic tubes where can i find it the easiest? I have had 3 64x64 quarries mining and still no copper only forest and icc
    • By Czaxi
      If anyone wants to join my tekkit legends server, good news! we have upgraded to evolve! The party invite link is: https://www.evolvehq.com/recruit/party?token=player:nxch1hUSEcuF14u1,party:xtjybic7jAM9LqsL if anyone would like to join!
      it doesn't really have players, I just want people to play with. see ya on the server!
      Server is now bukkit! more ranks will be added.
      btw, not 24/7 will be online most hours though
      Discord invite: https://discord.gg/5rsTRxc
    • By RoborooskieX
      Hello all!
      Since I installed windows 10 I seem to have a problem with almost all modpacks.
      When I try and launch AOTBT, Voltz or tekkit it takes an incredible long time for the program to load such modpack.
      While loading it will give a not responding in the top left of the window.
      Once one of the modpacks have loaded the menu screen seems locked/unresponsive and has a very low fps of about 1 or 2.
      Does anyone know what the problem might be? Willing to answer all questions and clear up some info if needed.
      Extra info: Used to work before windows 10, have 16GB RAM, Tekkit Lite and yogbox work fine.
      Thanks ahead!
    • By TechnicalOwnage
      Pretty straightforward..
      None of the crafting recipes that use UU-Matter are in Not Enough Items.
      Version: Tekkit Legends 1.1.1
  • Create New...