Sign in to follow this  
Gregatar

Server lagg

Recommended Posts

a while ago i created a Tekkit server. and after we have geting more machines and stuff running it start lagging as crazy.

I cant seem to find the reason why it lag either. The server is located on my personal computer. whit 4.5 Quadcore 8 gb ddram and 100/100 broadband. The server is using 4 gb dedicated to it but still it lags?

Any solution?

Share this post


Link to post
Share on other sites

Got spyware infection? Try superantispyware. Windows up to date? Got java 7? When's the last time you defraged? Hard drive dying for that matter? Run a scandisk. Does it lag for local machines on the lan or just for people connected through your broadband, which I doubt it 100/100. Sure that's the lan speed, but not your wan speed. Is your router old and shitty or fritzing ouit?

My bet is spyware and slow upload wan speed.

Share this post


Link to post
Share on other sites

a while ago i created a Tekkit server. and after we have geting more machines and stuff running it start lagging as crazy.

I cant seem to find the reason why it lag either. The server is located on my personal computer. whit 4.5 Quadcore 8 gb ddram and 100/100 broadband. The server is using 4 gb dedicated to it but still it lags?

Any solution?

I'm sorry, but without any real details there could be a million reasons why.

Share this post


Link to post
Share on other sites

Same thing happened to my server. What seemed to be causing the issue on my server was some of my users were using inefficient piping methods that were spewing out hundreds of items on to the ground. I installed the Nolagg addon from bukkit which limits the number of entities that are view-able at any one time. This is modifiable in the config but i just use the default settings. Good luck, trying to diagnose lag is no fun.

Share this post


Link to post
Share on other sites

Same thing happened to my server. What seemed to be causing the issue on my server was some of my users were using inefficient piping methods that were spewing out hundreds of items on to the ground.

This was my first thought as well. Happened on my server because of inefficient piping, like you said.

Share this post


Link to post
Share on other sites

The windows is fully uppdated and i have norton antivirus.

got the newest java aswell.

spyware? i will take a look into it

Sorry for the missguided internet speed before

25/10 mbit 23/8 true speed

it is kinda od. cause when other ppl login aswell. the server start beeping and even my personal game lags

we are using standrad tekkit clients aswell.. Where is the extra-far chunk loading options ?

Im investigating about the poor piping work aswell. atm there are 4x quary running to a central assembling point where dirt and stuff is being splited and so on

Where from can i download the nolagg addon from bukkit?.

Share this post


Link to post
Share on other sites

The windows is fully uppdated and i have norton antivirus.

got the newest java aswell.

spyware? i will take a look into it

Sorry for the missguided internet speed before

25/10 mbit 23/8 true speed

it is kinda od. cause when other ppl login aswell. the server start beeping and even my personal game lags

we are using standrad tekkit clients aswell.. Where is the extra-far chunk loading options ?

Im investigating about the poor piping work aswell. atm there are 4x quary running to a central assembling point where dirt and stuff is being splited and so on

Where from can i download the nolagg addon from bukkit?.

If people login and then it starts happening on your local PC where the game is, it's not your internet connection. Hosting it on your personal machine while playing might be an issue. Do other people lag if you are not playing?

Share this post


Link to post
Share on other sites

Kaspersky, my anti-virus, was hammering our server at first. It's much better now though. I know there is a way to set certain permissions, but I'm lazy and simply disable it *gasp* when the server is up.

Share this post


Link to post
Share on other sites

it is kinda od. cause when other ppl login aswell. the server start beeping and even my personal game lags

What kind of beeping does your server do? Unless you have installed a specific server-side mod that makes your server beep when a client logs in, it shouldn't do that.

Have you considered running the Tekkit server in a Linux virtual machine? You have enough resources for it, and it would eliminate some potential causes (such as your anti-virus software).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this