Jump to content
Sign in to follow this  
Cheap Shot


Recommended Posts

If the instructions below are not clear enough for you to understand, please use Google to assist yourself. We can not babysit you, and

the solutions below assume you have a basic understanding of the computer you're using. If not, ask for help from someone who does, or your parents, or your friends, etc.


Where is my Technic Launcher folder?

Windows: C:\Users\"User Name"\%AppData%\Roaming\.techniclauncher

Mac: Users\"User Name"\Library\Application Support\.techniclauncher

The folders may be hidden, so make sure to make hidden folders visible in your systems settings.

Google will tell you how.

Where are the files for the different versions, Technic SSP, Tekkit, Yogbox and Vanilla?

They are all contained in their own folders inside the .techniclauncher folder. When a solution

includes "modpack name", it means go to the proper folder for the pack you are using.

Where are the logs for reporting a problem?

Your "Logs" folder is located in .technicfolder. The most recent will always be "launcher_0".

How do I find out what bit version my Operating System is? (32 or 64)

This website shows how to find out your operating systems bit version:


(If this link is ever broken, please PM me)

How do I tell what bit version of JAVA I have? (32 or 64)

This is a little trickier and there are many different ways depending on your OS.

Google will have to help you here. One possible way to find out if you don't have 64 bit JAVA is to load up

Vanilla minecraft (Not using the Technic Launcher), and in the game options, turn the view distance to Far.

If you are using 32 bit JAVA, you will see a red error message. That will only come up if minecraft is using

32 bit Java. A thing to note, if you have a 64 bit OS, it is perfectly fine to have both versions of Java installed.

Most web browsers use 32 bit Java, and Minecraft will default to 64 bit if you have it.

The launcher stops in the middle of downloading the mods.

The most common reason is that your antivirus is blocking it. Common perps are AVG and Norton.

You need to set technic as an exception. If that doesn't work, turn it off while you download the mods.

If that doesn't work, uninstall those terrible anti-virus programs and get one that doesn't get in your

way constantly. Two anti-virus programs that are much much better are Microsoft Security Essentials

and Avast. AVG and Norton aren't worth the money they cost, especially when outclassed by free options.

TMI doesn't work!

I'm sorry to hear it! Good thing TMI isn't in the technic pack. Perhaps you're thinking of NEI?

Fine! NEI doesn't work!

Actually, it does. See this thread for more information.


The mod select button doesn't work.

Your computer might not have any program designated to open config files. Go to your .techniclauncher and find

the "Config" folder in any of the mod folders you have already installed. (They will be empty if you haven't yet.)

Right click a file ending in .cfg, select "open with..." and set Notepad (Windows) or TextEdit (Mac) as the default

program that opens it. Your mod select button should now work as long as you have a pack selected in the drop


Some mods can't be turned off with the mod select config.

Some of the mods in technic have to be applied directly to the .jar, so unfortunately that means to turn them off

you'll have to remove the files manually. The associated files will be in .techniclauncher\"modpack name"\bin\modpack.jar.

Look up the mod you want to disable and find out what files it adds so you can remove them.

The launcher freezes on a white screen when I log in.

Sometimes the lwjgl (Light Weight Java Games Library) binaries just don't work for everyone.

Disable lwjgl by opening the launcher and clicking "Options" above the log in field. Then uncheck

"Use latest LWJGL binaries".

The latest LWJGL binaries option wasn't/isn't on and I am still getting a white screen.

Might be time to post a bug/problem report. But first, try going to .techniclauncher\"modpack name"\bin

and open the jinput.jar. (on a mac you may have to rename the .jar to .zip and extract it, then rezip

and rename to a .jar after you're done.) Delete Meta-INF. If that doesn't work nuke the .techniclauncher

folder and re-download it.

Opening the .exe does nothing, or flashes a loading icon, or says "checking launcher version" then closes.

This is a Java issue. The most common cause is using 32 bit Java. If your Operating system is 64 bit, make sure you update to the latest 64 bit version of Java. Links on www.technicpack.net.

If no matter what you do, the exe just doens't work, go to your .techniclauncher folder and there should be a .jar in there. If not then download

it from www.technicpack.net and use that. Read further up the list for how to determine the bit version of your OS or JAVA.

I get an error that says "Can't find JAVA directory".

The cause and solution to this problem is the same as the problem directly above this one. You're

most likely using the incorrect bit version of JAVA, or it isn't up to date. Find out if you need the

64 bit version of JAVA and then go to www.technicpack.net and use the JAVA download links.

Read further up the list for how to determine the bit version of your OS or JAVA.

I've tried everything but I still can't get it to work with my 32 bit OS.

Not sure what to tell you. A temporary fix could be to use the .jar instead of the .exe which seems to work

for most people. If we manage to isolate a common cause to 32 bit OS issues then we'll update with a real fix.

I can't log into my tekkit server anymore, it says I am missing mods

this means you are not using the correct version of tekkit. the most common cause is trying to a development version instead of the recommended build. in the launcher, make sure tekkit is selected, then click on "options" and click on "always use recommended builds". once you've done that, click ok and log in to tekkit.

[More problems and solutions will be added in the future. This list is subject to change.]

Thank you to Zebrin for starting the original FAQ thread.

Share this post

Link to post
Share on other sites


Waah! My world crashed when I placed a teleport pipe!

Calm down! Use a heavenly program called MCEdit to delete the block. Also works for any other error caused by placing a block, like a wooden pipe next to a condenser.

Share this post

Link to post
Share on other sites

Updating from Technic 6 to Technic 7

I tried to update to Technic 7 and all I got was a saving chunks error or white screen

Solution: Go to your .techniclauncher folder, and delete your technicssp folder. Then just re-launch the Technic Launcher and re-download and install Technic 7.

Reason: Technic 6 is installed to the TechnicSSP folder. When You try to update to Technic 7, it installs all the Technic 7 mods into THE SAME FOLDER. Think of it like this: If You installed Hack/Mine, and then installed The Yogbox Directly into the same folder, You would expect errors right? The same goes for upgrading to Technic 7.

Technic 7 is essentially a new Modpack. Since it doesnt delete the original TechnicSSP folder before updating, You end up with config files and such for the Technic 6 mods. Minecraft doesnt like that, and will crash.

Hopefully This helps, I've seen a TON of people posting with this problem. I know Technic 7 is still a Dev build, but If this is a common solution, it might reduce the number of people who post about getting this issue.

Share this post

Link to post
Share on other sites


My NEI broke 'cause I typed in some crazy shit and haven't disabled the mob spawners

You don't actually have to re-download. This has been fixed on at least two occasions by deleting NEI.dat from your saves folder. The game should generate a new one (eventually) but NEI doesn't even seem to need it to run.

I've had this problem as well, and I could be wrong, but I believe simply pressing the PGUP key will fix the problem. At least, it did for me.

Share this post

Link to post
Share on other sites


i have the problem that i start downloading and it will stop in the middle by minecraft.jar


Share this post

Link to post

help please, everytime i try to do anything with technik launcher it loads and then comes up with a blue screen error "saying bad video card driver" ITS A BRAND NEW LAPTOP!!! FUUUUU


Share this post

Link to post

I upgraded to the 3.03 tekkit and everything seems fine till I try to launch a game, the game launches to a black screen , well not completely I see the milliaries(sp?) message briefly and then I get the saving chunks screen and the the screen go's white. That is a Little different then your other white screen issue.


Share this post

Link to post

Well, I played on Tekkit and basically used the technic laucher for all that is minecraft, but I seems that now it won't log in. It says that it can not connect with minecraft.net so that it can authenticate my account. This also happens when I do the normal minecraft.exe from minecraft.net. I could log into minecraft.net via browser but not launchers...PLEASE HELP!!!!


Share this post

Link to post

Not sure this counts as a "common problem", but anyway...

Also, I read the rules :)

Tekkit 3.0.3 is trying to use the vanilla .minecraft folder as its folder (alternatively, WHERE ARE MY MODS???!!1)

Make sure you are using the latest technic launcher, that is, For whatever reason, older launchers that will work fine for earlier versions and other modpacks do this.

Share this post

Link to post
Share on other sites

Help I am not shor how to update to tekkit to 3.0.3 how, if you do it wood be very kind thx


Share this post

Link to post
This topic is now closed to further replies.
Sign in to follow this  

  • Create New...