Jump to content

Newbie Tekkit Server Needs help


PeskyMrPickles
 Share

Recommended Posts

Hoping that some kind soul will help get me through this. I am admittedly very new to this. I have created a vanilla server from scratch, added essentials and working to familiarize myself with the in's and outs of running a Minecraft server. My son is dying to get into Tekkit so I am trying to get a local Tekkit server up and running fir us. 

I have a clean download of the Tekkit server .zip.

I have java 8.0 installed

Running on a macbook pro OSX El Capitain.

I set up the start.command file and on startup I see some warnings and errors around Extra Utililities and ProjRed Core, but things keep moving along. It eventually runs down to this where things seem to go off the rails

"

2016-08-16 13:47:00 [SEVERE] [Minecraft-Server] Encountered an unexpected exception IllegalArgumentException

java.lang.IllegalArgumentException: Slot 3972 is already occupied by [email protected] when adding m[email protected]71ab8a65

 

Followed by a bunch of warnings about buildcraft not being able to run a version check 

2016-08-16 13:47:00 [SEVERE] [Minecraft-Server] This crash report has been saved to: /Users/kurtwinkelman/Desktop/SORT_MC/Tekkit_Server_New/./crash-reports/crash-2016-08-16_13.47.00-server.txt

2016-08-16 13:47:06 [WARNING] [Buildcraft] Unable to read from remote version authority.

2016-08-16 13:47:06 [WARNING] [Buildcraft] java.io.FileNotFoundException: https://dl.dropboxusercontent.com/u/38558957/Minecraft/Buildcraft/version.txt

2016-08-16 13:47:06 [INFO] [Buildcraft] Version check attempt 2 failed, trying again in 10 seconds

2016-08-16 13:47:07 [WARNING] [EE3] Error while connecting to remote version authority file; trying again

2016-08-16 13:47:16 [WARNING] [Buildcraft] Unable to read from remote version authority.

2016-08-16 13:47:16 [WARNING] [Buildcraft] java.io.FileNotFoundException: https://dl.dropboxusercontent.com/u/38558957/Minecraft/Buildcraft/version.txt

2016-08-16 13:47:16 [INFO] [Buildcraft] Version check attempt 3 failed, trying again in 10 seconds

2016-08-16 13:47:17 [WARNING] [EE3] Version check stopping after three unsuccessful connection attempts

2016-08-16 13:47:26 [INFO] [Buildcraft] Version check failed

and then it just hangs.  I try to run /help as a test to see if the server is up and get errors in return. I try logging in and the connection drops immediately. 

Sorry for the long post but I know information helps. If anyone can give me some tips or things to try I would really appreciate it.

Would it help if I upload the crash report?

 

Thank you.

 

 

Link to comment
Share on other sites

So I spent hours working out some kinks. I dropped my Java down to 7.0. Figured out how to run Minecraft at version 1.6.4. Installed the right version of Forge.

So now I see my server and can attempt to log-in BUT it still drops the connection. I have pasted the crash report into pastebin and it is up here:

http://pastebin.com/EwDCHaqY

Please help when you can. Every time I think I have it... another hurdle.  =)

Thank you for taking the time.

 

Link to comment
Share on other sites

No luck. Deleted options.txt. Restarted everything and hd the same issue. I am getting this set of messages when i start my teckkit server. It talks about unloading dimensions (in bold below) and I see "Failed to register dimension for id2..." as part of the crash error log. 

2016-08-17 12:25:29 [INFO] [Buildcraft] Version check attempt 3 failed, trying again in 10 seconds

2016-08-17 12:25:31 [WARNING] [EE3] Version check stopping after three unsuccessful connection attempts

2016-08-17 12:25:34 [SEVERE] [Galacticraft] Galacticraft update check failed! Trying again in 15 seconds

2016-08-17 12:25:39 [INFO] [Buildcraft] Version check failed

2016-08-17 12:25:41 [INFO] [ForgeModLoader] Unloading dimension 1

2016-08-17 12:25:41 [INFO] [ForgeModLoader] Unloading dimension -23

2016-08-17 12:25:41 [INFO] [ForgeModLoader] Unloading dimension -100

2016-08-17 12:25:49 [SEVERE] [Galacticraft] Galacticraft update check failed! Trying again in 15 seconds

2016-08-17 12:28:54 [SEVERE] [Minecraft-Server] Reached end of stream for /127.0.0.1

2016-08-17 12:29:02 [INFO] [Galacticraft] Registering remote planet dimension: -28

2016-08-17 12:29:02 [INFO] [Galacticraft] Registering remote planet dimension: -29

2016-08-17 12:29:02 [INFO] [Galacticraft] Registering remote planet dimension: -28

2016-08-17 12:29:02 [INFO] [Galacticraft] Registering remote planet dimension: -29

2016-08-17 12:29:03 [SEVERE] [Minecraft-Server] Reached end of stream for /127.0.0.1

2016-08-17 12:29:03 [INFO] [Minecraft-Server] PeskyMrPickles [/127.0.0.1:49807] lost connection

Any other ideas? Thank you in advance.

 

 

Link to comment
Share on other sites

That seems to have solved the crashing issue!!!!  Thank You!  But like every step along this journey a new hurdle has popped up.

Now getting a new set of errors around missing server mods. Server log at the pastbin link.

http://pastebin.com/hdhCYUH3

i have uploaded an image of what I saw when I logged in here:

https://www.dropbox.com/s/be3ap3f21zbz1i1/New_Message.jpg?dl=0

I am starting to feel cursed. =)

 

 

Link to comment
Share on other sites

Please forgive my density. Could you be a little more specific on where to remove it from? I don't have anything else that i know of connecting to the server. I haven't installed anything extra. I'm just trying to open the straight Tekkit server download. I pulled anything that has anything to do with dimensional doors out of every other folder in the server folder and no luck. Same result. I'm going to crawl under my desk and cry as I hug my knees for a while.

Link to comment
Share on other sites

  • Moderators

Ah ok, that helps.

There is another place you will need to remove DimDoors from. I don't speak Mac very well, but probably in 

~/Library/Application Support/tekkit/mods

or something similar. 

If you have other players joining on other computers, they will need to remove DimDoors as well. 

Edited by AetherPirate
Link to comment
Share on other sites

So I have an error with my server for a modpack. I have all the mods installed on the server correctly, weeded out the client side mods, and done everything right. I can connect to my server easily but friends from a different router can't. I have tried almost every method I have seen. I have port forwarded my IPV4 address with ports TCP and UDP 25565. I have added port rules on firewall for 25565. I have allowed Java SE Binary, javaw.exe and minecraft through firewall. I know a lot of people said to keep server.properties blank, but the minecraft says you can have it set to whatever you want for an IP that everyone connects to. I've tried putting my external ip in the ip address, i've tried it with nothing there, i've tried port forwarding my external Ip, i've tried near everything I could think of and find on any forum sites. Yet, my friends still gets the Connection Timed Out error. Anybody know a fix?

Link to comment
Share on other sites

No luck on files there. I looked in all of the application support libraries and there were no Tekkit folders.  Even checked in the minecraft folder that i found there. Question. Should I be logging into the Tekkit server from the regular minecraft game or through Tekkit Launcher?

And do I also have to somehow install the mods into minecraft itself before joining the server? I am seriously new to this.

Link to comment
Share on other sites

  • Moderators

If its just you, you don't need the server at all. Just open the launcher and choose Tekkit. The server is for allowing other players who live elsewhere to play with you, and it allows for much greater customization and control. If you don't need that then I'd skip it. 

There is an "open to lan" option in-game to allow others in the same house to play together. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By yugimo
      #
      # A fatal error has been detected by the Java Runtime Environment:
      #
      #  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007ffd2cb03899, pid=20448, tid=0x0000000000007040
      #
      # JRE version: Java(TM) SE Runtime Environment (8.0_301-b09) (build 1.8.0_301-b09)
      # Java VM: Java HotSpot(TM) 64-Bit Server VM (25.301-b09 mixed mode windows-amd64 compressed oops)
      # Problematic frame:
      # C  [ig11icd64.dll+0x593899]
      #
      # Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
      #
      # If you would like to submit a bug report, please visit:
      #   http://bugreport.java.com/bugreport/crash.jsp
      #
       
    • By Grexxity
      Hey come checkout my tekkit classic server. I put a lot of work tweaking out all of the bugs and trying to make it so players have the best tekkit classic experience. Also I am not using a "Fake Player" plugin to simulate there are a bunch people on the server *cough *cough mc-complex. So I hope you come and check it out!
      My main reason for creating this server is to bring back one of my favorite mod packs back.
      Ip: tekkit.dragoncraftmc.net
      Discord: https://discord.gg/H9e6MVRTEv
    • Guest
      By Guest
      ..
    • By BloodScythe
      https://pastebin.com/kRLp5Y2Y These are the error msgs, I have already tried re installing the pack, restarting the launcher, updating the pack, any more ideas?
    • By 4net_E
      LAUNCHER VERSION: v4.664
      OPERATING SYSTEM: macOS 10.14.6
      JAVA VERSION: Oracle 1.8.0_261 64-Bit
      ANTIVIRUS: none
      recently I tried to play some modpacks, but i couldnt start any of them. Every time I wanted to launch them, icon of the modpack showed up in taskbar, window popped up, but after approximately a second, it had crashed.
      I tried to solve this problem by myself, but I didnt manage to success. The closest Ive got to solution was in this thread :
      However, there is a solution linked on another forum thread, but that link is probably corrupted or something, as it just redirected me to the same thread all over again. Thus Im stuck and seek help. This is a log after one of the unsuccessful launch attempts: https://pastebin.com/Md4yW3yw
      For any kind of suggestions or additional information request I'd be very thankful
      Okay, fortunately under this post's recommended threads I've found another new thread which stated a similar problem: 
       
      The solution right there seems to do the job (at least temporarily), but still, I'd like to know the core of the problem, for example - why 8u251 works and 8u51 doesn't?
      Hope this helps someone someday
×
×
  • Create New...