freeman725

Why no Ender IO?

Recommended Posts

I've recently started playing Tekkit again, and I have to say, it's a decent pack. A lot of the bugs I used to encounter seem to have been worked out. Something that confuses me though, is the pack has the Big Reactors mod installed, but not Ender IO. To me, it seems kinda pointless to have the ability to design something that can produce massive amounts of power, and be limited to kinesis pipes for power transfer. On a small scale, it's viable I guess, but on a bigger scale, it's just not enough. Unless you want 23523532463364345 kinesis pipes coming out of whatever you build. For example, I built a reactor that's 19 blocks high, has 9 control rods, and is surrounded by 6 turbines with ludicrite coils. Each turbine produces over 28k RF/t. For power storage I built (I admit it's insanely overkill) a Zetta battery that can hold something like 295 GRF. Granted I know that any kind of power transfer would take forever to charge that thing, but being able to use conduits would definitely be worlds faster.

Another problem I ran into, is that I tried messing around with automated reactor and turbine control via computercraft. I don't know how to code, so I cant just design my own program to suit my needs. Pretty much every program that can be installed from pastebin to the in game computer relies on having a capacitor bank connected to the network. Yet another handy component of Ender IO. No one seems to be interested in writing a program that will recognize a Zetta battery, even though there is a computer port for it, and it can be connected to a network. Just to name a couple things I would like to do, but can't.

I've tried adding Ender IO to the mods folder, but it causes the game to crash on startup. Is there another mod that Ender IO depends on? Or am I just flat out unable to use it? It would be kinda disheartening to think that I can't even install what mods I want to this pack without rendering it useless. Another mod I'd like to use is MineFactory Reloaded for laser drills. I could care less about not being able to play on Tekkit servers. I pretty much only play by myself or over lan anyway.

Share this post


Link to post
Share on other sites
1 hour ago, freeman725 said:

I've tried adding Ender IO to the mods folder, but it causes the game to crash on startup. Is there another mod that Ender IO depends on? Or am I just flat out unable to use it? It would be kinda disheartening to think that I can't even install what mods I want to this pack without rendering it useless. Another mod I'd like to use is MineFactory Reloaded for laser drills. I could care less about not being able to play on Tekkit servers. I pretty much only play by myself or over lan anyway.

Naw, its certainly not written in the description, like at the end or something...

https://mods.curse.com/mc-mods/minecraft/ender-io#t1:description

Share this post


Link to post
Share on other sites

Oops. It says right at the top that it requires a reasonably current version of Forge and EnderCore. Guess I'll try that. I downloaded version 1.7.10 and didn't see the dependencies anywhere.

Share this post


Link to post
Share on other sites

I'm guessing that I need mod versions corresponding to the version of Minecraft that Tekkit is using, which is 1.7.10. I installed Forge for 1.7.10 and EnderCore for 1.7.10 along with Ender IO for 1.7.10 and it still crashes... Oh well. I guess I'll just start with a current version of vanilla and add what mods I actually want to use. Vanilla is up to version 1.11.2, which means development for Tekkit hasn't happened in a year or more? Kinda sad...

Share this post


Link to post
Share on other sites
1 hour ago, freeman725 said:

I'm guessing that I need mod versions corresponding to the version of Minecraft that Tekkit is using, which is 1.7.10. I installed Forge for 1.7.10 and EnderCore for 1.7.10 along with Ender IO for 1.7.10 and it still crashes... Oh well. I guess I'll just start with a current version of vanilla and add what mods I actually want to use. Vanilla is up to version 1.11.2, which means development for Tekkit hasn't happened in a year or more? Kinda sad...

You already have forge installed, so you would be using two version of forge at the same time. That's gonna crash.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.