bobplz

I made a Minecraft server with my modpack but it doesn't want to load in the mods

Recommended Posts

So, hello. I didn't know where to put this, but I'm making a Minecraft 1.7.10 server, I've put in the mods and the configs, and when I open the forge server file, It doesn't want to load a large number of the mods. I don't know why, because they're all non-client, and they work in singleplayer. Please help!

Edited by bobplz
wasnt good enuff

Share this post


Link to post
Share on other sites

So you have all those fancy server files like mods, forge, logs etc. Just zip them together with winrar or 7zip and upload to dropbox and give a link. If you have a link already just provide it here.

Share this post


Link to post
Share on other sites
7 hours ago, E4RU said:

So you have all those fancy server files like mods, forge, logs etc. Just zip them together with winrar or 7zip and upload to dropbox and give a link. If you have a link already just provide it here.

Here it is! (I used MEGA)

https://mega.nz/#!zBEzDCrZ!U1Ilcnz6HbbHxlEyuIZIWNGcdhJt2-z-hluz9-Y4Kg0

 

Edited by bobplz

Share this post


Link to post
Share on other sites

You are using Forge 1.7.10 1422, use 1614.  And don't forget to make a batch file to start your server with. 

The version of The Ultimate Pun Mod you have is old, use from here http://www.minecraftforum.net/forums/mapping-and-modding/minecraft-mods/1294446-the-ultimate-pun-mod-updated-aug-2015

You have client-side only mods in your server, find and remove them. 

Edited by AetherPirate

Share this post


Link to post
Share on other sites

Thank you all for the help!

Let me see how this'll work with the mods!

26 minutes ago, bobplz said:

Thank you all for the help!

Let me see how this'll work with the mods!

It still does the same thing. That was the original problem. When I open the Forge server file, it loads some stuff in, then closes. I will try a batch file, but first, since you're all smarter than me, I'll show you a crash report: 

Quote

---- Minecraft Crash Report ----
// Oh - I know what I did wrong!

Time: 2/16/17 6:15 PM
Description: Exception in server tick loop

cpw.mods.fml.common.LoaderException: java.lang.NoClassDefFoundError: net/minecraft/client/Minecraft
    at cpw.mods.fml.common.LoadController.transition(LoadController.java:163)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:544)
    at cpw.mods.fml.server.FMLServerHandler.beginServerLoading(FMLServerHandler.java:87)
    at cpw.mods.fml.common.FMLCommonHandler.onServerStart(FMLCommonHandler.java:314)
    at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:117)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:387)
    at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685)
Caused by: java.lang.NoClassDefFoundError: net/minecraft/client/Minecraft
    at com.minimap.XaeroMinimap.<clinit>(XaeroMinimap.java:44)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at cpw.mods.fml.common.FMLModContainer.constructMod(FMLModContainer.java:440)
    at sun.reflect.GeneratedMethodAccessor5.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)
    at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)
    at com.google.common.eventbus.EventBus.post(EventBus.java:275)
    at cpw.mods.fml.common.LoadController.sendEventToModContainer(LoadController.java:212)
    at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:190)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)
    at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)
    at com.google.common.eventbus.EventBus.post(EventBus.java:275)
    at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:119)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:513)
    ... 5 more
Caused by: java.lang.ClassNotFoundException: net.minecraft.client.Minecraft
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 30 more
Caused by: java.lang.RuntimeException: Attempted to load class bao for invalid side SERVER
    at cpw.mods.fml.common.asm.transformers.SideTransformer.transform(SideTransformer.java:50)
    at net.minecraft.launchwrapper.LaunchClassLoader.runTransformers(LaunchClassLoader.java:279)
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:176)
    ... 32 more


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- System Details --
Details:
    Minecraft Version: 1.7.10
    Operating System: Windows 10 (amd64) version 10.0
    Java Version: 1.8.0_91, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 562238168 bytes (536 MB) / 895483904 bytes (854 MB) up to 2844786688 bytes (2713 MB)
    JVM Flags: 0 total; 
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML: MCP v9.05 FML v7.10.99.99 Minecraft Forge 10.13.4.1614 42 mods loaded, 42 mods active
    States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
    UC    mcp{9.05} [Minecraft Coder Pack] (minecraft.jar) 
    UC    FML{7.10.99.99} [Forge Mod Loader] (forge-1.7.10-10.13.4.1614-1.7.10-universal.jar) 
    UC    Forge{10.13.4.1614} [Minecraft Forge] (forge-1.7.10-10.13.4.1614-1.7.10-universal.jar) 
    UC    battlegear2{1.7.10} [Mine & Blade Battlegear 2 - Bullseye] (1.7.10-MB_Battlegear2-Bullseye-1.0.8.3.jar) 
    UC    IronChest{6.0.41.729} [Iron Chest] (14139716919_Iron-Chests-Mod-1.7.10.jar) 
    UC    lucky{5.1.0} [Lucky Block] ([1-7-10]_Lucky_Block_v5-1-0.jar) 
    UC    securitycraft{v1.8.1} [SecurityCraft] ([1.7.10] SecurityCraft v1.8.1.jar) 
    UC    lotr{Beta v28.2 for Minecraft 1.7.10} [The Lord of the Rings Mod] ([1.7.10] The Lord of the Rings Mod B28.2.jar) 
    UC    FLabsBF{4.3} [Better Furnaces] ([1.7.10]Better_Furnaces_V4.3.jar) 
    UC    bspkrsCore{6.12} [bspkrsCore] ([1.7.10]bspkrsCore-universal-6.12.jar) 
    UC    crazyores{2.0.6} [CrazyOres] ([1.7.10]CrazyOres-V2.0.6.jar) 
    UC    adventurebackpack{1.7.10-0.8b} [Adventure Backpack] (adventurebackpack-1.7.10-0.8c.jar) 
    UC    armourersWorkshop{1.7.10-0.26.1.55} [Armourer's Workshop] (Armourers-Workshop-Mod-1.7.10.jar) 
    UC    atum{0.6} [Atum] (Atum-1.7.10-0.6.77.jar) 
    UC    Backpack{2.0.1} [Backpack] (backpack-2.0.1-1.7.x.jar) 
    UC    BiblioCraft{1.10.5} [BiblioCraft] (BiblioCraft.jar) 
    UC    CakeIsALie{4.05} [CakeIsALie] (CakeIsALie-1.7.10-4.05.jar) 
    UC    clonecraft{3.0} [CloneCraft] (Clone-Craft-Mod-1.7.10.jar) 
    UC    props{1.11} [Decocraft] (Decocraft-v1.11_1.7.10.jar) 
    UC    dungeonpack{1.7.10-1.0} [Dungeon Pack] (dungeonpack-1.7.10-1.0.jar) 
    UC    eternalfrost{2.0b2} [Eternal Frost] (eternalfrost-2.0b2.jar) 
    UC    flansmod{4.10.0} [Flan's Mod] (Flans Mod-1.7.10-4.10.0.jar) 
    UC    FoodPlus{3.2rS} [Food Plus] (FoodPlus.jar) 
    UC    godzillamod{1.6.6} [Godzilla Mod] (Godzilla Mod-1.7.10-1.6.6.jar) 
    UC    iChunUtil{4.2.2} [iChunUtil] (iChunUtil-4.2.2.jar) 
    UC    GraviGun{4.0.0-beta} [GraviGun] (GravityGun.jar) 
    UC    Hats{4.0.0} [Hats] (Hats-Mod-1.7.10.jar) 
    UC    InfernalMobs{1.6.6} [Infernal Mobs] (InfernalMobs-1.7.10.jar) 
    UC    InventoryPets{1.4.7.1} [Inventory Pets] (inventorypets-1.7.10-1.4.7.1-universal.jar) 
    UC    TeNNoX_KeyAndCodeLock{1.4} [KeyAndCodeLock] (Key-and-Code-Lock-Mod-1.7.10.jar) 
    UC    malisiscore{1.7.10-0.14.3} [MalisisCore] (malisiscore-1.7.10-0.14.3.jar) 
    UC    malis

And I've also got a more detailed one from the batch file, I think it actually worked, because Java asked for Admin rights near the end. I wanted to test it, so I declined, and copied the code. I will allow java more access and see how that works, but there are still errors.

Quote

Wait I'm going to do it in another reply

 

 

 

Edited by bobplz

Share this post


Link to post
Share on other sites

Hmmm... maybe the LOTR mod won't work because it creates another dimension that you can spawn in to.

Does anyone know if I should try to use MCPC+? My mod pack is 1.7.10, and I'm sure MCPC+ only goes up to 1.6.4.

I've removed ALL the client mods and am using the latest Forge.

P

Share this post


Link to post
Share on other sites

Remove the map mod, 

2 hours ago, JaariAtmc said:

Server zip contains a minimap mod.

Also contains quite a bit of "downloaded crap". Many "modname-mod" files.

Remove the map mod. And make sure you are getting your mods from legit sources (minecraftforum.net, curse, curseforge, author's website)

http://stopmodreposts.org/

Add a browser pluggin if you are not sure, it will stop you from downloading crap

 

Share this post


Link to post
Share on other sites
17 hours ago, AetherPirate said:

Remove the map mod, 

Remove the map mod. And make sure you are getting your mods from legit sources (minecraftforum.net, curse, curseforge, author's website)

http://stopmodreposts.org/

Add a browser pluggin if you are not sure, it will stop you from downloading crap

 

Yeah. I got some from MinecraftSix and 9Minecraft and planetminecraft.net

I'll go to the author's websites and get the newest versions for everything :)

Share this post


Link to post
Share on other sites
On 2/16/2017 at 8:07 PM, AetherPirate said:

Remove the map mod, 

Remove the map mod. And make sure you are getting your mods from legit sources (minecraftforum.net, curse, curseforge, author's website)

http://stopmodreposts.org/

Add a browser pluggin if you are not sure, it will stop you from downloading crap

 

Still not loading mods in I deleted all the client mods and conifg files for them

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By JokeInABox
      Hi All,
      when i install a modpack and click play, all it dose is close launcher then minecraft appears in the taskbar takes a few seconds then switches to the name of the mod im trying to play (Legands) then dose nothing, wont let me click on it and when i hover over its just a blank white box. 
      I have tried a Couple of different things to get it to work but to no avail.
      Reinstalled minecraft and launcher
      restart PC 
      Changed to 64bit java and set to 4GB ram 
      checked to see if my NVIDA was up to date 
       
      all help would be greatly appreciated.
      link to my logs https://pastebin.com/rNEDnvKb 
    • By Keno_
      I tried creating a modpack, but when I try to open it in the Technic launcher it won't open. When I click play the launcher closes and then reopens. I looked through the logs to see if I could find the problem, but I'm not really sure what to look for. Can someone help me?
      Heres the link to the pack:
      https://www.technicpack.net/modpack/an-aberrant-magic-modpack.1482134
    • By FastClap
      Hello im posting this thread looking for some help i downloaded the technic launcher yesterday and tried to download mod packs. when i go to load one it will not load 'minecraft assets' then proceed to close then re-open the launcher. i have looked up solutions but none have worked i am on windows 10. literally bought my PC yesterday i have 64bit java  aswell and even tried resetting my java and also tried to run the launcher as an administrator  nothing is working can someone please help fix this issue? i dont know how to copy the link so here are the recent logs.. [B#407] 2019/07/08 19:06:10 [INFO] Console Mode Activated
      [B#407] 2019/07/08 19:06:11 [SEVERE] java.io.FileNotFoundException: File 'C:\Users\Patrick\AppData\Roaming\.technic\assets\launcher\OpenSans+Cyberbit.ttf' does not exist
      [B#407] 2019/07/08 19:06:11 [SEVERE]     at org.apache.commons.io.FileUtils.openInputStream(FileUtils.java:299)
      [B#407] 2019/07/08 19:06:11 [SEVERE]     at net.technicpack.ui.lang.ResourceLoader.getFontByName(ResourceLoader.java:76)
      [B#407] 2019/07/08 19:06:11 [SEVERE]     at net.technicpack.ui.lang.ResourceLoader.getFont(ResourceLoader.java:318)
      [B#407] 2019/07/08 19:06:11 [SEVERE]     at net.technicpack.ui.lang.ResourceLoader.getFont(ResourceLoader.java:314)
      [B#407] 2019/07/08 19:06:11 [SEVERE]     at net.technicpack.launcher.autoupdate.TechnicRelauncher.buildUpdaterTasks(TechnicRelauncher.java:114)
      [B#407] 2019/07/08 19:06:11 [SEVERE]     at net.technicpack.autoupdate.Relauncher.runAutoUpdater(Relauncher.java:97)
      [B#407] 2019/07/08 19:06:11 [SEVERE]     at net.technicpack.launcher.LauncherMain.main(LauncherMain.java:198)
      [B#407] 2019/07/08 19:06:11 [WARNING] Unable to load users from C:\Users\Patrick\AppData\Roaming\.technic\users.json because it does not exist.
      [B#407] 2019/07/08 19:06:11 [INFO] Starting download of http://launcher.technicpack.net/resources/OpenSans+Cyberbit.ttf, with 3 tries remaining
      [B#407] 2019/07/08 19:12:26 [INFO] Expected MD5: 94a9d4cbcb9ceaa25000fa303fa81acc Calculated MD5: 94a9d4cbcb9ceaa25000fa303fa81acc
      [B#407] 2019/07/08 19:12:26 [INFO] Starting download of http://launcher.technicpack.net/resources/Raleway+FireflySung.ttf, with 3 tries remaining
      [B#407] 2019/07/08 19:19:58 [INFO] Expected MD5: b62087eb4b11746987c800c0512890ef Calculated MD5: b62087eb4b11746987c800c0512890ef
      [B#407] 2019/07/08 19:19:58 [INFO] Starting download of http://mirror.technicpack.net/resources/aether-dep.jar, with 3 tries remaining
      [B#407] 2019/07/08 19:21:49 [INFO] Expected MD5: EBF34784444ABCB976F77C9E23692057 Calculated MD5: ebf34784444abcb976f77c9e23692057
      [B#407] 2019/07/08 19:21:49 [INFO] OS: windows 10
      [B#407] 2019/07/08 19:21:49 [INFO] Identified as windows
      [B#407] 2019/07/08 19:21:49 [INFO] Java: 1.8.0_211 32-bit
      [B#407] 2019/07/08 19:21:49 [WARNING] Unable to load users from C:\Users\Patrick\AppData\Roaming\.technic\users.json because it does not exist.
      [B#407] 2019/07/08 19:21:50 [WARNING] Unable to load installedPacks from C:\Users\Patrick\AppData\Roaming\.technic\installedPacks because it does not exist. 
    • By Souppey
      I keep trying to run MIANITE REBORN OLD and the mod pack will load to about 28% and says "Pre Initializing Loading Forge Microblocks" and then it will crash. Help bc i wanna play a server with friends. Thank you!!!
       
      pastebin: https://pastebin.com/3gixkwEr
    • By MONOCHROMATIK
      Hi everyone.
      I've been trying to login to the actual site itsself but i've forgotten the login digits.
      then i go attempting to turn of 2FA but it needs a recovery code, which i never got.
      Is there anyway to get a new code and/or set of digits? if so please let me know. Thanks!