Jump to content

Problem Creating Modpack, Please Help!


Recommended Posts

Hi everyone!

First forum post, here goes.

So I've just created my first Modpack!

I'm having an issue where, having made it and uploaded it, I download it from Technic Launcher and start it up. Initially it goes well, Minecraft opens in 1.6.4 as I had intended. But the game doesn't actually load up with any mods, despite the fact that there are loads in the pack (well, actually not loads, maybe ten or so). I was wondering if anyone could help me fix this. I've left a link to the pack's page and a link to the download (basically so people can see what I've done and tell me where I've gone wrong lol). I've also described what I did below in case it makes any difference.

 

Modpack: https://www.technicpack.net/modpack/to-the-moon-or-bust-copy.1067411

Modpack location: https://www.dropbox.com/s/2rgovwj5m8qz8p8/Making the Modpack.zip?dl=1

 

 

I created a new directory for minecraft to run in, and installed Forge Installer in it (for 1.6.4, the intended version to be played with). I also made a folder with three subfolders inside it, bin, mods, and config, which is the second link. I installed Forge Universal for 1.6.4 in the bin file and renamed it modpack.jar Next I, in turn, downloaded each mod that I wanted one by one in 1.6.4, put it in the mods folder in the Forge Game Directory, ran it, copied the config files from the Forge Game Directory to the Modpack config Subfolder, and moved the mod from the Forge Game Directory to the Modpack mods Subfolder. I repeated this with every mod I wanted until it was all done.

After this I compressed it into a zip file and uploaded it to dropbox, and then changed the end of the dropbox sharing link to =1 not =0. I then put in the settings of the new modpack, putting the link in and selecting 1.6.4

 

Yeah that's what happened. I'd be super grateful if anyone could help me? Obviously I'm really really new to all of this and this was my first time, so there's probably something obvious I've missed, but yeah, let me know!

 

 

UPDATE: In the time writing this, I tried deleting the pack from my launcher and installing it again. I installed it, but for some reason the install button shows instead of the play button next to the delete modpack button. I press install again, and within seconds it just goes back to the same problem, no play, just install. Anyone able to help me out?

 

Further update: Disregard the UPDATE - turns out I was being an idiot and I was trying to load it whilst I had it open. Still got original issue though

Edited by CookieMan833
Link to post
Share on other sites

I'll take a look

Go into your technic file location and copy and paste your modpack file and upload it.

if you cant get it i will download it on technic

I see what you mean it only loads 1.6.4

I really Don't see any problems it could be anything from forge being wrong version (Most likely) or technic having wrong version and without a log i can't really help you :( 

But what you could do is download and upload your logs from technic and your modpack

Link to post
Share on other sites

the logs for your Modpack are in the file location just got to the top right corner and click the "Modpack Options" when your on your modpack in technic and you will be brought to a screen that says "Install Folder" click open and you will be brought to file explorer then you can get the modpack logs.

The Logs for Technic are in the same place except back one folder just go up in the file explorer and click ".technic" then go into the "logs" folder and upload and share the logs folder with me.

Edited by Mr.Redstone
Link to post
Share on other sites

Ok! Well, I managed to get myself locked out of my account, but here you are, here are dropbox links to two folders of logs!

 

Modpack logs: https://www.dropbox.com/s/imdpwg5jmmgddvj/Logs.zip?dl=1

Technic logs: https://www.dropbox.com/s/l7inuz7acjq5pty/TechnicLogs.zip?dl=1

 

When clicking the links you then need to edit the 0s at the end to 1s - I tried to do this in the post but as you can probably see from the colour change it didn't work.

Edited by CookieMan833
Link to post
Share on other sites

Problem: Your java Memory facade has a Problem with Logging the Files and you need to download and install the Latest Java (or download this: https://www.dropbox.com/s/e232eq5o28oyspb/slf4j-1.7.25.zip?dl=0 and find your path)  if you want to know more about this error then go to this link: http://www.slf4j.org/codes.html#StaticLoggerBinder

 

 

 

Link to post
Share on other sites

If it STILL doesn't Work I've got another plan: I'll Download your modpack and upload it under my name and then I will Make you the Owner But you will have to delete the one you have now so I can replace it.

 

 

 

Oh And you still have some mods that won't work like iron chest and Hats Iron Chest doesn't have a safe legit download for 1.6.4 so you can't get it :(  Plus another problem is is that you had forge installer in mods folder :/.

 

 

 

I am gonna send you the fixed version and you can try it.

Here it is: https://www.dropbox.com/s/j2gms0kstoxhybb/Making the Modpack (FIXED).zip?dl=0

 

 

Link to post
Share on other sites

Of Course It's Okay if you don't trust me most people wouldn't by how unsafe the internet is but If I uploaded it it would most likely fix the problem or  uploading the one I sent you. (Hopefully)

I would also like to ask if you would like to be a contributor to my modpack: Mr.Redstone's 1.11.2 Pack?

Link to post
Share on other sites

Aha! I fixed it! Turns out the forge file in the bin on the modpack was called modpack.jar as I'd named it so, but my computer already recognised it as an executable jar file and so had added an extra .jar to the filename that I couldn't see. I got rid of the .jar in the name and it now works fine!

 

I'd love to help contribute, but honestly I'm terrible with modpacks xD I am also on holiday soon so will be unavailable, so I'll have to decline :( Thanks for your help though! 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Nyrab
      I'm trying a new modpack
      The version is 1.10.2
      I tried to remove some mods and still don't work
       
      Modpacklog.zip
    • By zoezp
      I am new to making modpacks and this is the first one I ever made so I watched some youtube tutorials and it worked well until I tried to launch the modpack and It started as vanilla but when I checked the modpack options it had the mods installed and they were all in the folder. I tried to fix it and tried out things like renaming the files but nothing worked for me so thats why I am here asking for your help.
      I don't know what the problem is at this points so I would really like some help.
      Here is the dropbox link I used to upload the modpack: https://www.dropbox.com/s/u2qfs8zuco8fh39/pixelmon fun.zip?dl=1
      Here is the modpack download link: https://www.technicpack.net/modpack/pixelmon-2780956.1833394
       
      If any more info is needed just ask and I'll provide it if I can.
      Thanks in advance! 
    • By Zilverrr
      Whenever me or my friends try to download my modpack https://www.technicpack.net/modpack/minecraft-steden-oorlog.1830815 it only runs vanilla 
      can someone help me with this ?
    • By YTDannydan
      So i made a modpack, and i have tried linking my file on several different websites, dropbox, MediaFire and Google Drive. but the modpack settings keep saying: "The modpack location you specified is not a valid zip file." can someone please help me? i want to make a server of this modpack in future but for the last couple days i have been struggling!
    • By seraphicsong
      I have a folder, inside are config, mods, and bin folders. The mods are in the mods folder, I have a forge installer renamed to modpack.jar inside the bin folder. I zip the config, mods, and bin folder and then upload them to dropbox. I take the download link from dropbox, and change the end number from 0 to 1. I put it in the modpack location of the edit modpack on the technic website. However, when i try to install the modpack from technic launcher, I get vanilla Minecraft when it opens. Please help!
×
×
  • Create New...