TheJamessss

Server issues! Please help

Recommended Posts

So i have a tricky problem for whoever would like to help. I've been playing minecraft for a while, but Lan servers worked too inconsistently for me and my friends (We use Hamachi), so I decided to set up a server for us to play on using my IPv4. The server worked pretty well, but all of the mods were broken. Like they would appear in NEI, but you couldn't craft or spawn in any items from the modpacks. I searched around for a bit and found that my system didn't have enough RAM for the heap dump. It gave me this message: 

C:\Users\Joseph\Desktop\B-Team>java -Xmx3G -Xms2G -jar BTeam.jar nogui
Error occurred during initialization of VM 
Could not reserve enough space for 3145728KB object heap

C:\Users\Joseph\Desktop\B-Team>pause
Press any key to continue . . .

So I, thinking I was tech savvy enough to fix it, tried to add a Enviornment variable to fix this issue

Name: _JAVA_OPTIONS

Value: -Xmx512M

Now, whenever I try to launch, it gives me a different issue:

C:\Users\Joseph\Desktop\B-Team>java -Xmx3G -Xms2G -jar BTeam.jar nogui
Picked up _JAVA_OPTIONS: -Xmx512M
Error occurred during initialization of VM
Initial heap size set to a larger value than the maximum heap size

C:\Users\Joseph\Desktop\B-Team>pause
Press any key to continue . . .

So now I'm stuck. Im not sure what exactly to do or if I'm even going in the right direction to fix my issue. I think my files are correct and in order, but look at this https://imgur.com/a/n9QmP to verify. Any and all help would be much appreciated!

Share this post


Link to post
Share on other sites
2 hours ago, TheJamessss said:

So I, thinking I was tech savvy enough to fix it, tried to add a Enviornment variable to fix this issue

Name: _JAVA_OPTIONS

Value: -Xmx512M

 

Why did you think this was a good idea? That just limits ALL java processes to 512 MB. Your initial error is not enough RAM available to allocate the the 3 GB you wanted it to have.

Your original issue, how did you start the server? Like, what file did you use to start it?

Share this post


Link to post
Share on other sites
On 3/11/2018 at 2:24 PM, JaariAtmc said:

Why did you think this was a good idea? That just limits ALL java processes to 512 MB. Your initial error is not enough RAM available to allocate the the 3 GB you wanted it to have.

Your original issue, how did you start the server? Like, what file did you use to start it?

I've launched it every different way I could think of. I've use the minecraft_server.1.6.4 file, the BTeam .jar file, the launch .bat file, and combinations of the 3. Nothing i do seems to work.

Share this post


Link to post
Share on other sites
56 minutes ago, TheJamessss said:

I've launched it every different way I could think of. I've use the minecraft_server.1.6.4 file, the BTeam .jar file, the launch .bat file, and combinations of the 3. Nothing i do seems to work.

Well, as long as you do not have 3 GB RAM available (be that due to a lack of 64 bits java, or due to you not having that amount of RAM free), your server will not start. You will have to use the launch.bat btw. The other two won't get you anywhere if you launch the server that way.

Share this post


Link to post
Share on other sites
3 hours ago, JaariAtmc said:

Well, as long as you do not have 3 GB RAM available (be that due to a lack of 64 bits java, or due to you not having that amount of RAM free), your server will not start. You will have to use the launch.bat btw. The other two won't get you anywhere if you launch the server that way.

My computer has 6 GB's of RAM available. How to I set 3 GB aside for the server because Im obviously an accident who doesn't know

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Keno_
      I tried creating a modpack, but when I try to open it in the Technic launcher it won't open. When I click play the launcher closes and then reopens. I looked through the logs to see if I could find the problem, but I'm not really sure what to look for. Can someone help me?
      Heres the link to the pack:
      https://www.technicpack.net/modpack/an-aberrant-magic-modpack.1482134
    • By FastClap
      Hello im posting this thread looking for some help i downloaded the technic launcher yesterday and tried to download mod packs. when i go to load one it will not load 'minecraft assets' then proceed to close then re-open the launcher. i have looked up solutions but none have worked i am on windows 10. literally bought my PC yesterday i have 64bit java  aswell and even tried resetting my java and also tried to run the launcher as an administrator  nothing is working can someone please help fix this issue? i dont know how to copy the link so here are the recent logs.. [B#407] 2019/07/08 19:06:10 [INFO] Console Mode Activated
      [B#407] 2019/07/08 19:06:11 [SEVERE] java.io.FileNotFoundException: File 'C:\Users\Patrick\AppData\Roaming\.technic\assets\launcher\OpenSans+Cyberbit.ttf' does not exist
      [B#407] 2019/07/08 19:06:11 [SEVERE]     at org.apache.commons.io.FileUtils.openInputStream(FileUtils.java:299)
      [B#407] 2019/07/08 19:06:11 [SEVERE]     at net.technicpack.ui.lang.ResourceLoader.getFontByName(ResourceLoader.java:76)
      [B#407] 2019/07/08 19:06:11 [SEVERE]     at net.technicpack.ui.lang.ResourceLoader.getFont(ResourceLoader.java:318)
      [B#407] 2019/07/08 19:06:11 [SEVERE]     at net.technicpack.ui.lang.ResourceLoader.getFont(ResourceLoader.java:314)
      [B#407] 2019/07/08 19:06:11 [SEVERE]     at net.technicpack.launcher.autoupdate.TechnicRelauncher.buildUpdaterTasks(TechnicRelauncher.java:114)
      [B#407] 2019/07/08 19:06:11 [SEVERE]     at net.technicpack.autoupdate.Relauncher.runAutoUpdater(Relauncher.java:97)
      [B#407] 2019/07/08 19:06:11 [SEVERE]     at net.technicpack.launcher.LauncherMain.main(LauncherMain.java:198)
      [B#407] 2019/07/08 19:06:11 [WARNING] Unable to load users from C:\Users\Patrick\AppData\Roaming\.technic\users.json because it does not exist.
      [B#407] 2019/07/08 19:06:11 [INFO] Starting download of http://launcher.technicpack.net/resources/OpenSans+Cyberbit.ttf, with 3 tries remaining
      [B#407] 2019/07/08 19:12:26 [INFO] Expected MD5: 94a9d4cbcb9ceaa25000fa303fa81acc Calculated MD5: 94a9d4cbcb9ceaa25000fa303fa81acc
      [B#407] 2019/07/08 19:12:26 [INFO] Starting download of http://launcher.technicpack.net/resources/Raleway+FireflySung.ttf, with 3 tries remaining
      [B#407] 2019/07/08 19:19:58 [INFO] Expected MD5: b62087eb4b11746987c800c0512890ef Calculated MD5: b62087eb4b11746987c800c0512890ef
      [B#407] 2019/07/08 19:19:58 [INFO] Starting download of http://mirror.technicpack.net/resources/aether-dep.jar, with 3 tries remaining
      [B#407] 2019/07/08 19:21:49 [INFO] Expected MD5: EBF34784444ABCB976F77C9E23692057 Calculated MD5: ebf34784444abcb976f77c9e23692057
      [B#407] 2019/07/08 19:21:49 [INFO] OS: windows 10
      [B#407] 2019/07/08 19:21:49 [INFO] Identified as windows
      [B#407] 2019/07/08 19:21:49 [INFO] Java: 1.8.0_211 32-bit
      [B#407] 2019/07/08 19:21:49 [WARNING] Unable to load users from C:\Users\Patrick\AppData\Roaming\.technic\users.json because it does not exist.
      [B#407] 2019/07/08 19:21:50 [WARNING] Unable to load installedPacks from C:\Users\Patrick\AppData\Roaming\.technic\installedPacks because it does not exist. 
    • By Souppey
      I keep trying to run MIANITE REBORN OLD and the mod pack will load to about 28% and says "Pre Initializing Loading Forge Microblocks" and then it will crash. Help bc i wanna play a server with friends. Thank you!!!
       
      pastebin: https://pastebin.com/3gixkwEr
    • By MONOCHROMATIK
      Hi everyone.
      I've been trying to login to the actual site itsself but i've forgotten the login digits.
      then i go attempting to turn of 2FA but it needs a recovery code, which i never got.
      Is there anyway to get a new code and/or set of digits? if so please let me know. Thanks!
    • By Meeshy
      in more detail, Technic was working fine, something bugged in my computer where twitch completely crashed and died randomly and forced me out of MC, going black screen. once it stopped (happened for not more then 30 seconds) it resumed to the launcher which would (like other crashes) start, exit the launcher and not manage to open the actual game, then the launcher re-appears. trying again gives the same result. I've lowered my  allowed ram which has fixed the problem before. I've completely deleted all Technic stuff and reinstalled still the same results. 
      here are the logs: https://pastebin.com/xDMxrtYX
      (past when i downloaded the modpack i use)
       
      EDIT: deleted and reinstalled java 8, but to no avail